Can See Samba At WINXP Network Places, But Cant Login

Help ....
Hi, Do you have such experience ?

I try to setup Samba and sharing the public folder and printer.

I can see my Linux PC ( Name: RedhatPC ) from my network places, when I try to double click this PC icon,
it prompt me "RedhatPC is not accessible. YOu might  not have permission to use this network resource ...."

I wonder what is happening ? From my RedhatPC , i can use command smbmount mount to WinXP PC share folder,
but my WinXP cannot access Redhat PC.

The /etc/hosts.allow already put ALL:ALL.

This is my smb.conf contents:

[global]
netbios name=garden
workgroup=garden
server string=Samba Server
guest account=nobody
security=user
password level=8
syslog only=Yes
encrypt passwords=Yes
hosts allow=10.0.0.
wins support=Yes

[homes]
comment=Home directory
browseable=no
writeable=yes

[public]
path=/home/public
comment=Public directory
guest ok=yes
public=yes
browseable=yes
writable=yes

Thank you very much if you would help me !

regards,
xiaoy
xiaoytanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
> security=user
You need to have Linux local/NIS accounts match your Windows accounts.

Wesly
0
xiaoytanAuthor Commented:
hi, Wesly.

Thank for your fast reply. But  I not really understand it.
Where can I set it ??
Do you have MSN ? Can we discuss via MSN ?

Thank you !!!

xiaoytan@hotmail.com
0
owensleftfootCommented:
The username & password logged into the Windows machines have to exist on the redhat box. Ie if you are logged into the windows box as xaoi with password secret, you have to have an account on the linux box called xiao with password secret.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

wesly_chenCommented:
Hi,

   Here is my smb.conf, for your reference

----- /etc/samba/smb.conf ----
workgroup = <your Windows domain>   <====
server string = RedhatPC  Samba server
security = SERVER    <================
encrypt passwords = Yes
password server = <Your Active Directory server's OP address>    <=====
passwd program = /usr/bin/passwd %u
passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *Passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
----------------------

Besides, you need to have/create Windows' username/password on your Linux box.

Wesly
0
Gabriel OrozcoSolution ArchitectCommented:
No.

you need the sign or seal registry file. look for it on your linux machine, copy it to your windows XP, and then XP will be able to log to the linux via samba.

why is this? well, it is because microsoft has several ways to connect. all of them doing the same, but samba team choose to support only one (the best one). so please run the signorseal.reg on your XP and you should be working okay after that.
0
jeilerCommented:
What version of Samba are you running, there were some fixes to winbind that addressed a couple of issues like this.  I would recommend upgrading to 3.0.7 or later.
0
Gabriel OrozcoSolution ArchitectCommented:
any news?
0
xiaoytanAuthor Commented:
Hi, The Issues have been solved, I re-do all the setting and find the answer from the books.
The browseable should always set to "YES".
Thank you.
Can Administrator close the topic ?
0
snedelchevCommented:
security = share

[global]
        local master = no
        interfaces = 192.168.66.1
        bind interfaces only = yes
        workgroup = TRAKIA
        netbios name = PENGUIN
        server string = DarkStar
        security = SHARE
        encrypt passwords = Yes
        lanman auth = No
        log level = 1
        log file = /var/log/samba/%m.log
        min protocol = NT1
       change notify timeout = 300
       deadtime = 15
       socket options = TCP_NODELAY SO_RCVBUF=8192 IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        lm announce = No
        guest ok = yes
        hosts allow = 192.168.66.0/255.255.0.0
#        hosts deny = ALL
        hide unreadable = Yes
        browsable = Yes
[homes]
        comment = Home Directories
        create mask = 0750
        browsable = No

[Share]
        comment = Temporary file space
        path = /home/stasy/share
        guest ok = Yes
        browsable = Yes
        writable = Yes
        Browsable = Yes
0
CetusMODCommented:
PAQed with points refunded (250)

CetusMOD
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.