Can't run Delphi 5 CGI App using IIS 5.1 on XP. Worked fine on on W2K.

I can't run my Delphi 5 CGI App using IIS 5.1 on XP. Worked fine on W2K.

The main website pages run ok, it just doesn't like it when I run the CGI app.
I'm just testing it will a simple "Hello World" example to ensure nothing else is going wrong.

It comes up with: "The page cannot be displayed"

In IIS I have set: Execute Permission: Scripts and Executables for directory where the .exe lives. Have also added it to the list of ISAPI filters in the properties of the website.  Not sure if that is required.

What else do I need to do in order for it to run ok?

Thanks for you help.
cjclaytonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wim ten BrinkSelf-employed developerCommented:
I don't think it needs to be in the ISAPI filters, since it's not an ISAPI filter but a CGI executable.

It is most likely that your CGI application is trying to access data in some other folder. However, the security in XP is slightly tighter thus your application might not be allowed to access this folder since the web user account has no proper access rights. If you do use a data folder, make sure your application has access rights to it.
The same applies for some other system resources like the registry, etc.

But if all your application is doing is displaying "Hello, World" then something else might be wrong. Are you sure you made no spelling errors while calling your page?

You might also need read access to this folder. (And perhaps set it up as an application with high (isolated) protection just to be sure.)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cjclaytonAuthor Commented:
I ended up getting it going - it appears I did have some extra code that I didn't know it was trying to excute - trying to open a file that didn't exist, instead of displaying the usual error it should "The page cannot be displayed" - not sure why.  Anyway I created the file and all worked fine. Thank you for your help it made me look at bit more at the code it was trying to excute.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.