• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 174
  • Last Modified:

Laptop apparently obtained roaming profile and moved files from local My Documents to server?!?

We use Roaming Profiles and something odd just happened on my laptop. We currently redirect My Documents on all desktop PCs to the user's home directory so the files don't copy up and down whenever they logon and logoff. On laptops, however, I enabled the local policy to "Only allow local user profiles" so the documents I save on my laptop would remain on my laptop. Out of the blue yesterday, I noticed that the laptop took a long time to login and the hard drive was thrashing like mad. When it finally came up, I discovered that all of my local files moved from my local My Documents folder to the My Documents in my home directory and the local My Documents was now redirected to the server. I checked and that policy setting was still enabled on my laptop.

Any idea on what would make this happen suddenly and the best way to undo it?

Thanks!
0
gdladmin
Asked:
gdladmin
  • 5
  • 4
  • 3
2 Solutions
 
GATOR420Commented:
I don't believe that enabling the policy to only allow local user profiles has anything to do with the folder redirection. Check out these links:

Folder redirection feature in Windows
http://support.microsoft.com/default.aspx?scid=kb;en-us;232692

Registry Settings for Folder Redirection in Windows
http://support.microsoft.com/kb/q242557/
0
 
gdladminIT DirectorAuthor Commented:
If that's the case, though, any idea why it did not redirect for so long and then suddenly decide to move the files yesterday? And regardless, how can I have two computers, one desktop that I want redirected and one laptop that I don't want redirected?
0
 
GATOR420Commented:
Can't answer the first question. As far as the second, please refer to the links I gave you.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
gdladminIT DirectorAuthor Commented:
Those links show how to setup folder redirection (which we've already done) but they don't explain how to accomplish having one computer redirected and another not redirected for the same user account.
0
 
GATOR420Commented:
Turn off inheritance of group policies on your computer/account.
0
 
gdladminIT DirectorAuthor Commented:
I'm sorry but I've seen no way to do that. Can you please tell me how?
0
 
GATOR420Commented:
Try this link:

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_sp_bestprac.mspx

It is for Windows XP, but it should be pretty similar to Windows 2K.
0
 
SKULLS_HawkCommented:
Did anyone change a domain Group policy.  Local policy are ALWAYS overwritten by domain policies.

Another way you can stop the redirection, is in the permissions of the policy add the relevant user to the permissions for it and add the deny read right.  That way he won't be able to see the group policy so it won't apply to him.

0
 
SKULLS_HawkCommented:
Sorry meant to say change the permissions of the DOMAIN policy, not the local one.
0
 
gdladminIT DirectorAuthor Commented:
Gator,

That policy inheritance isn't for a computer inheriting a group policy from a domain, it's for an OU inheriting a group policy from somewhere else so that information doesn't apply to this situation.

Skulls,

I make changes to the group policy all the time, but haven't made edits having to do with the folder redirection. The problem with your solution (I was looking at that earlier) is that the same account is on both machines (the laptop and the desktop) so specifying an account won't solve this dilemma. I still don't understand why it worked for so long and then suddenly decided to get enforced. Friggin' Windows.

By the by, the PCs are using Windows XP. I put this under Windows 2000, since it had to do with Group Policy on Windows 2000 Active Directory.

I'm starting to think there isn't a solution to this issue, other than using a different account on the laptop.
0
 
SKULLS_HawkCommented:
In that case add the computer account of the laptop to the properties of the Group Policy and specify the deny right to that.  That should stop the laptop but leave his user account alone.

Possibly one of the changes you made refreshed something that it shouldn't have?  Windows... :-)

0
 
gdladminIT DirectorAuthor Commented:
Well, Skulls, I thought you were on to something with that last suggestion. I added the Computer account to Deny the ability to Read and Apply the Policy. I then rebooted the laptop and My Documents was still pointing at the server. I then went into the registry to see what would happen if I edited those redirection entries manually. I did that, rebooted and got the Policy back. I can also tell I still have the policy because the screen saver timeout is still locked (which we have set in the User Configuration). I'm wondering if putting a computer account in the security doesn't work since they are User, not Computer settings. The only difference I've seen since editing the Security is that at first logon, I wasn't connected to the DC and got the warning that I was using Offline files. Oh well.

Thanks for your help, guys.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 5
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now