Tape Drive Problem - Sony SDT 9000

I am using SONY SDT 9000 tape drive for backups. Recently, I have started facing one strange problem - Whenever I inserts the tape disk in tape drive, sometimes, it is detected and sometimes I got the error message:
 /usr/local/backup/backup.script: line 81: 18611 Broken pipe             tar -czf $device usr >>$logfile 2>&1
/dev/st0: Input/output error
mt: The device is offline (not powered on, no tape ?)..
I changed the tape disk but still I am getting this message. It seems I need to replace the tape drive. Since it would be a little expensive affair, so, I want to troubleshoot tape drive first and if I am right, can anyone share info. about the manuals and troubleshooting techniques for this tape drive?  
mn210Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mn210Author Commented:
Secondly, can anyone please walk me thro the steps for installing new tape drive - SDT 9000 ?
0
paullamhkgCommented:
Hv you format the new tape before doing the backup? or in your backup script, dose it have the format or check media statment?

sometime it's because the tape is normally formatted for win32/FAT32, do a ext3 format might help.

try

mkfs.ext3 /dev/st0 (provided that you put the new tape in), this will format the tape.

and try the backup script again.
0
makhanCommented:
pls. post the contents of

/usr/local/backup/backup.script
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mn210Author Commented:
Sorry for the delay .
I tried formatting as suugested and got following message:
mkfs.ext2 /dev/st0
/dev/st0 is not a block special device.
Proceed anyway (y/n) y
mkfs.ext2 : Device size reported to be zero. Invalid partition specified or partition table wasn't reread after running fdisk due to modified partition being busy and in use. You may need to re-read your partiton table.

I booted the machine and even changed the tape but still  got the same message.

0
mn210Author Commented:
If I have to do the fresh install of SONY SDT 9000 TAPE DRIVE on Red Hat Linux 7.2,I got a lot of information at http://sg.torque.net/sg/ but  can anyone please walk me thro' the steps of installing the drivers? Actually, I am doing it for the first time.
Thanks a lot for your cooperation
0
paullamhkgCommented:
before reinstall the drive, have you try as the message suggested, fdisk to create the partition and do the format again??

fdisk /dev/st0         <--  to create the partition
mkfs.ext2 /dev/sto  <-- to format

since your type drive installed and it's work before, so even you reinstall the result may be the same.
0
mn210Author Commented:
I tried fdisk /dev/st0 ( with the new tape in the tape drive)  and got message - unable to read.
0
makhanCommented:
are u sure u have your tape drive installed properly.

pls. post the output of following command.

lsdev

Also you have posted this question in the other link as pointed by paullamhkg... please avoid this.

Regards.
0
mn210Author Commented:
Here is the output of - lsdev

[sharmam@enterprise ~]$ lsdev
Device            DMA   IRQ  I/O Ports
------------------------------------------------
Adaptec                            d000-d0ff
ATI                                  c000-c0ff
cascade             4      2
dma                                 0080-008f
dma1                               0000-001f
dma2                                00c0-00df
eth0                          5
fpu                                   00f0-00ff
ide0                        14      01f0-01f7 03f6-03f6 d800-d807
ide1                        15      0170-0177 0376-0376 d808-d80f
keyboard                  1       0060-006f
Lite-On                             d400-d4ff
Mouse                    12
PCI                                   cf8-0cff c000-cfff
pic1                                  0020-003f
pic2                                  00a0-00bf
rtc                           8        0070-007f
serial                                02f8-02ff 03f8-03ff
timer                       0       0040-005f
tulip                                 d400-d4ff
usb-uhci                  11      dc00-dc1f e000-e01f e400-e41f
VIA                                  d800-d80f dc00-dc1f e000-e01f e400-e41f e800-e8ff

Secondly, if I want to have fresh install of new SDT 9000 Tape drive on Red Hat 7.2  Linux m/c , where can I get the drivers for installation?
0
makhanCommented:
Now some suggestions.

there is an mt command in linux for manipulating the tape drives. pls. use this command to check if u can manipulate ur tape drive

mt -f /dev/st0 status

Post what is the output.

Also check if u are rewinding the tapes before starting ur backup script. to do this u should use

mt -f /dev/st0 rewind.

0
mn210Author Commented:
Here is the output :
[root@enterprise sharmam]# mt -f /dev/st0 status
SCSI 2 tape drive:
File number=-1, block number=-1, partition=0.
Tape block size 0 bytes. Density code 0x0 (default).
Soft error count since last status=0
General status bits on (10000):
 IM_REP_EN
------------------------------------------------------------
[root@enterprise sharmam]# mt -f /dev/st0 rewind
/dev/st0: Input/output error
mt: The device is offline (not powered on, no tape ?).
-----------------------------------------------------------
Can you please also help in getting the drivers for fresh install as I need to do it on another machine (Red Hat Linux 7.2) ?
0
mn210Author Commented:
As I want to install new tape drive,  can anyone please walk me thro the steps for installing and configuring new
 tape drive - SDT 9000 ?
0
makhanCommented:
What is ur o/s and version?
0
mn210Author Commented:
I am running Red Hat Linux 7.3
0
makhanCommented:
1. Do you have a scsi Drive?
2. Is you SCSI Card Configured Properly and recognised by linux.
3. Make sure you have all the necessary drivers for your scsi card either installed or in a floppy.


I am giving you a breif outline of the procedure to be followed.

1. Make a checklist of your existing scsi hardware.
2. Now you need to get your jumper settings right for the scsi tape drive. It should be configured to take the next device ID after all your devices. There will be a set of four jumpers at the back of the drive where you need to set them.
The order for the jumper setting would be given in the manual of the tape drive. It should be configured to use the next free ID available.

3. Check out if you have the scsi cable which is automatically terminated. If not then you need to terminate this on the last scsi device.

Auto terminating cables have a closed connecter at one end of it. Manual terminating cables would be having a connecter pin at both ends.

There will be a jumper on the drive which will be marked as "TERMINATION ENABLE". Set it appropriately - using the instructions in manual.

Now you are ready to plug the drive into your PC.

Shutdown the PC and plug the power and Data cables :).

Do you have the drivers for this tape drive shipped with it? if not you should search the net for SONY SDT 9000 drivers for linux 7.3. Copy them on a floppy once you obtain them.

Start the PC. The linux will try and detect the hardware using "KUDZU" utility. If your scsi drivers for the scsi cards are installed properly then this should be able to detect the Tape Drive and install it. It may ask you for the drivers in the floppy.

Hope this helps.... I would welcome other experts to add on to whatever I have missed.

Regards!

makhan







0
mn210Author Commented:
Sorry for the delay ...
I got the sony SDT 9000 tape drive yesterday. Now, I checked the site http://sg.torque.net/sg/ for downloading drivers. Can you please tell as which tar file ( sg version 3.0.19 or sg version 1.5.01 ) should I download ?
Secondly, I am curently running Red Hat Linux ( kernel-2.4.20-28.7) and am trying to locate the directory for kernel where this downloaded file would be untarred/extracted .
How can I  find the top of  Kernel tree as I checked /usr/lib/linux which is  of size 4.8 M and also checked /usr/src/redhat which is just 124K ?
Thanks alot in for your cooperation ...
0
mn210Author Commented:
Still looking for help ...
0
makhanCommented:
Hi!

Pl. check out the folder
  /lib/modules/<your_kernel_version>/scsi/

You may already have the scsi drivers installed on your pc. check out and give me the feedback.

In this case you can proceed with the hardware installation and boot up the machine.

Regards!









0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.