[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 351
  • Last Modified:

VPN Client to pix does not work

Im setting up a PIX TO PIX soultion and a VPN client to PIX solution.

The PIX to PIX im unable to check at the moment cus the other pix is not up yet.

The VPN client to PIX does not work. I suspect the reason is that i have not set up an ip-address just
PPPOE " ip address outside pppoe setroute" I have a fixed ip address that my isp has provieded for me


PS im administrating this over the internet SSH, so i dont want to lose internet connection
on the device.

What to do???

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password sUh51JfF84zKYNlu encrypted
passwd hjrpJ.hBw/QsytJw encrypted
hostname pixfirewall
domain-name sotra
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list pix2pix permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list c2pix permit ip 10.10.1.0 255.255.255.0 10.10.2.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 10.10.2.0 255.255.255.0
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 10.10.1.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.10.2.200-10.10.2.250
pdm location 10.10.1.17 255.255.255.255 inside
pdm location 10.10.1.0 255.255.255.0 inside
pdm location 10.10.2.0 255.255.255.0 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 213.164.206.164 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 213.164.206.164 255.255.255.255 outside
http 10.10.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto ipsec transform-set CiscoVPNClient esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set CiscoVPNClient
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address pix2pix
crypto map transam 1 set peer 213.239.120.44
crypto map transam 1 set transform-set chevelle
crypto map transam 10 ipsec-isakmp dynamic dynmap
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 213.239.122.31 netmask 255.255.255.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 10.10.1.1
vpngroup vpn3000 wins-server 10.10.1.1
vpngroup vpn3000 default-domain sotra
vpngroup vpn3000 split-tunnel c2pix
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh 213.184.206.164 255.255.255.255 outside
ssh 10.10.1.17 255.255.255.255 inside
ssh timeout 60
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname so-grup@onlins.no
vpdn group pppoe_group ppp authentication pap
vpdn username so-grup@onlins.no password *********
dhcpd address 10.10.1.3-10.10.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:951d630488f49e26d899d0955e909363
: end


0
daxa78
Asked:
daxa78
  • 8
  • 7
1 Solution
 
lrmooreCommented:
>isakmp policy 20 authentication rsa-sig

Change to
   no isakmp policy 20 authentication rsa-sig
   isakmp policy 20 authentication pre-share
0
 
daxa78Author Commented:
Thanks for the input wish i could say i was drunk when i wrote that :-D

Jepp im in now but im unable to ping any of the hosts and my address is in the 10.10.2.250 range.
And the subnet is listed at 255.0.0.0

(I know about the magic of translation)

I know that it is a server at the 10.10.1.15 but im unable to ping it.
Im unable to ping my address at 10.10.1.200 but i can ping the 10.10.1.200 address....

What to do..
0
 
lrmooreCommented:
What is the default gateway setting/mask on the server 10.10.1.15 ?
Can you ping that server from the ssh session with the PIX?
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
daxa78Author Commented:
Yes i can ping it the default gateway at the server is 10.10.1.2  and the subnetmask is 255.255.255.0
0
 
lrmooreCommented:
add this to the PIX:
   isakmp nat-traversal 20
0
 
daxa78Author Commented:
that has been done still im unable to ping any addresses on the inside using the cmd only using ssh

The subnet on the pix client is 255.0.0.0 and the computers on the network is located at 255.255.255.0

Should not this be a problem?
0
 
lrmooreCommented:
That shouldn't be a problem, but just in case, try using a totally different subnet for the client:
     
     ip local pool ippool 192.168.200.200-192.168.200.250

 no access-list c2pix permit ip 10.10.1.0 255.255.255.0 10.10.2.0 255.255.255.0
      access-list c2pix permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0

      access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
      access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0

0
 
daxa78Author Commented:
yes, i have tried that now but the magic seems to be gone if you know what i mean...

Im in the same subnet now but i am unable to ping any remote computers on the network.

I can log on fine.... but cant access the network resources. I have tried to ping several hosts.

This is my config

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password sUh51JfF84zKYNlu encrypted
passwd hjrpJ.hBw/QsytJw encrypted
hostname pixfirewall
domain-name sotra
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list pix2pix permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list c2pix permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 10.10.1.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.200.200-192.168.200.250
pdm location 10.10.1.17 255.255.255.255 inside
pdm location 10.10.1.0 255.255.255.0 inside
pdm location 10.10.2.0 255.255.255.0 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 213.124.206.164 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 213.184.222.164 255.255.255.255 outside
http 10.10.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto ipsec transform-set CiscoVPNClient esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set CiscoVPNClient
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address pix2pix
crypto map transam 1 set peer 213.232.120.44
crypto map transam 1 set transform-set chevelle
crypto map transam 10 ipsec-isakmp dynamic dynmap
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 213.214.122.31 netmask 255.255.255.0
isakmp identity address
isakmp nat-traversal 20
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 10.10.1.1
vpngroup vpn3000 wins-server 10.10.1.1
vpngroup vpn3000 default-domain sotra
vpngroup vpn3000 split-tunnel c2pix
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh 213.164.206.164 255.255.255.255 outside
ssh 10.10.1.17 255.255.255.255 inside
ssh timeout 60
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname so-grup@online.no
vpdn group pppoe_group ppp authentication pap
vpdn username so-grup@online.no password *********
dhcpd address 10.10.1.3-10.10.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:4eb9a552bb806ce4e2b82f349d6dc09d
: end


0
 
lrmooreCommented:
Can you post result of
C:\> route print
From your PC with the VPN connected?
You PC's home LAN does not happen to also be 10.10.1.x does it?

There's nothing else wrong with the PIX config..
0
 
daxa78Author Commented:
i just noticed that im also unable to ping hosts on the network using ssh either now.

my lan is in 192.168.1. range

here it is



C:\Documents and Settings\Administrator>route print
===========================================================================
Grensesnittliste
0x1 ........................... MS TCP Loopback interface
0x1000003 ...00 04 e2 3d 9a 2b ...... SMC EZ Card 10/100 (SMC1255TX) Network A
pter NDIS5 Driver
0x5000004 ...00 05 9a 3c 78 00 ...... Cisco Systems VPN Adapter
===========================================================================
===========================================================================
Aktive ruter:
     NettverksmĂ„l   Nettverksmaske          Gateway     Grensesnitt Metrikk
          0.0.0.0          0.0.0.0      192.168.1.1    192.168.1.10       1
        10.10.1.0    255.255.255.0  192.168.200.200  192.168.200.200      1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0     192.168.1.10    192.168.1.10       1
     192.168.1.10  255.255.255.255        127.0.0.1       127.0.0.1       1
    192.168.1.255  255.255.255.255     192.168.1.10    192.168.1.10       1
    192.168.200.0    255.255.255.0  192.168.200.200  192.168.200.200      1
  192.168.200.200  255.255.255.255        127.0.0.1       127.0.0.1       1
  192.168.200.255  255.255.255.255  192.168.200.200  192.168.200.200      1
  194.248.203.192  255.255.255.255      192.168.1.1    192.168.1.10       1
        224.0.0.0        224.0.0.0     192.168.1.10    192.168.1.10       1
        224.0.0.0        224.0.0.0  192.168.200.200  192.168.200.200      1
  255.255.255.255  255.255.255.255     192.168.1.10    192.168.1.10       1
Std. gateway:          192.168.1.1
===========================================================================
Faste ruter:
  Ingen

0
 
lrmooreCommented:
>also unable to ping hosts on the network using ssh either now

Hmmm.....

Try this:
   sysopt noproxyarp inside

0
 
lrmooreCommented:
Since your home LAN is 192.168.1.x, you may have to remove this one line just for testing so that it won't confuse the client..

  >access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
0
 
daxa78Author Commented:
nope nothing still... im going home to my  apartment and try from there could the netscreen xp device here at the office be the cause of the problem??? im back in 8 minutes approx
0
 
daxa78Author Commented:
Im back at my apartment now. Im expirencing the same thing from here unable to ping any host either via ssh or cmd.

But the vpn connection is up and running
0
 
daxa78Author Commented:
im closing the question and posting it again.. You have already answered what i asked about.

It seems that the question has changed entierly now...
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now