How can I guarentee that my server always gets the same internal IP address from my router?

I have 3 PCs connecting to the internet via a Linksys BEFSR41 Router and a static IP DSL connection.  One of the PCs is set up as a webserver, running Windows Server 2003, Standard Edition with IIS.  The Router is set up with Port Range Forwarding to forward Port 80 to the internal IP for the server.  But I haven't found a way to guarentee that the server always has that IP.

I have limited the available internal IP's to a range of 3, 1 per machine.  However, my concern is that if the server renews it's lease with the router while one of the other PCs is turned off, it may not get the same IP, making the port forwarding useless, and rendering my web server unreliable, since I won't know for sure if the router is forwarding to the proper machine.

Is there any way I can guarentee that the server is always assigned the same internal IP address?

Thanks in advance.
dei1c3Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Make a reservation or assign the address statically
0
sunray_2003Commented:
Why dont you assign a static IP to that windows 2003 machine so that it would remain the same
0
dei1c3Author Commented:
Bear with me, because I'm pretty much a newbie when it comes to this stuff.

1) How do I make a reservation?

2) How do I assign a static IP for the server?  Is that something that is done in the router (I've looked, and don't see an option for something like that) or is it done on the server?  If the latter, does that mean that the server is basically telling the router "I want THIS IP address" and the router says "OK, no problem?"  I guess I thought the router had the final say.  Also, if I do that, is there a way to ensure that neither of the other PCs takes that IP if the server goes down?

Thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sunray_2003Commented:
dei1c3,

pretty much this should work

open control panel
go to network connections > right-click on LAN connections and go to properties
scroll down to internet protocol , click on it and then click on properties

give the following info assuming certain info here

ip address : 192.168.0.100
subnet mask: 255.255.255.0
default gateway: 192.168.0.1

primary DNS : 192.168.0.1
Secondary DNS : 4.2.2.2

>> 192.168.0.100

Can you anything in your case. Check now what is the IP that router is assigning and give that there

>> 192.168.0.1

I guess for linksys mostly this would be 192.168.1.1

not sure tho
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lee W, MVPTechnology and Business Process AdvisorCommented:
The linksys router may not have an option for reservations.

However, you can set the address of the server statically.  You had to configure your DSL router to a static address.  the process is similar.  Linksys I think hands out addresses from .100 to .200 or so.

Type

IPCONFIG /ALL | MORE

from a command prompt - note the IP Address, Gateway, Subnet Mask, and DNS Server(s).

Then go to the Network Connection properties and reconfigure TCP - set it to use a static address - manually entering all the information you noted from IPCONFIG earlier.  Just change the last set of numbers for the IP Address.  For example if you had 192.168.1.101, then change it to 192.168.1.49. then reconfigure the router to forward the ports to that IP.  
0
MarkDozierCommented:
Do not forget to EXCLUDE the static IP from the DHCP scope or you will have issues.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
That's why I said to use .49 as, if memory serves, it's well out of the range of DHCP addresses from a Linksys box.
0
dei1c3Author Commented:
Thanks a lot, guys.  This seems to have done the trick.  I've got the router assigning IPs to the 2 non-server PCs and the server has a static IP which is outside of the DHCP range.

Server up and running.

Thanks again.  I'm going to split the points between leew and sunray because they basically posted at the same time and I used a bit of info from both.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.