• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 819
  • Last Modified:

Can't install MS MSDE2000A.exe

Downloaded MS  MSDE 2000A.exe from  -> http://www.microsoft.com/downloads/details.aspx?FamilyId=413744D1-A0BC-479F-BAFA-E4B278EB9147&displaylang=en#filelist

After clicking   'setup'    'Microsoft  SQL SERVER DESKTOP ENGINE'  message box asked me to use the SAPWD switch to enter a strong SA password.
Entered  'setup SAPWD="[Strongpassword]" '   at command prompt according to  a previous post.  Shut down and restart but can't  find the application.  Clicking setup again repeats the above message.
Thanks for your help.

-y

0
yunikon
Asked:
yunikon
1 Solution
 
illCommented:
what "can't  find the application" means?there si no GUI for msde( not sure about start menu links, cause i already use full version).
 you can use it from command promt ( osql command)or connect to it using odbc, ole, ado from some free visual database tools like dbexplorer.
0
 
yunikonAuthor Commented:
Thinking of downloading   'APEX SQL EDIT' (first link) from this site    http://www.handyarchive.com/free/sql/.   Is this a good choice?

-y
0
 
yunikonAuthor Commented:
When I try to use the osql command at command prompt the following error occurs,  

Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\Documents and Settings\Administrator>cd ..

C:\Documents and Settings>cd ..

C:\>osql -E idsm
'osql' is not recognized as an internal or external command,
operable program or batch file.

C:\>

-y

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Lori99Commented:
Check your services for the MSSQLSERVER service and make sure it is started.  If it isn't there, you didn't get MSDE installed.  If it isn't started, most likely you have some sort of problem with the startup account.  

Install MSDE as follows.

- Open a command prompt
- Navigate to the directory where you downloaded and unpacked MSDE
- Enter:  setup SAPWD="mypassword"
0
 
yunikonAuthor Commented:
Trying to get  osql to work by putting the following in the environment variables, system, PATHEX,
 
C:\Program Files\Microsoft SQL Server\80\Tools\Binn

Still get   'osql.....'   error.

SOURCE:
http://66.102.9.104/search?q=cache:RxORTK5HcCAJ:web.lemoyne.edu/courseinformation/MIS465/Chapter06Data/MSDE_ReadMe.doc+osql+tutorial&hl=en

How do I get osql command to work?

0
 
yunikonAuthor Commented:
Went  to start , settings, control panel, administratiev tools.  Clicked on Services icon.  MSDE is not there.  MSDE was saved on C\: drive.  Did Entered C:\ setup SAPWD=...............    at command prompt.  Also downloaded MSDE service pack on C: drive.
Service packs:

        * Sql2ksp3.exe. Updates for database components.
        * Sql2kasp3.exe. Updates for Analysis Services components.
        * Sql2kdesksp3.exe. Updates for Microsoft SQL Server 2000 Desktop Engine (MSDE 2000).

  After  download service packs, entered foll command;

C:\setup DISABLENETWORKPROTOCOLS=1  /upgradesp sqlrun SECURITYMODE=SQL UPGRADEUSER=25 UPGRADEPWD=myPWD

Not seeing SQL icon in system tray or MSDE  in Services.

-y
0
 
yunikonAuthor Commented:
MSDE was downloaded on C: drive in a folder named MSDERe 1A.  When I try to go to that directory with   C:\>cd MSDERe 1A    I get error saying    'The system cannot find the path specified'.  I can cd to the other directories on the C: drive.

-y
0
 
yunikonAuthor Commented:
I had run 'setup' after downloading MSDE and before going to the command prompt.  Could this be causing the difficulty?
 I would like to see an edit feature on tihs forum.

-y
0
 
fhoCommented:
I had some issues to install my first MSDE. I though it was installed, but it wasn't.
To check if it is, have a look in installed services. There must be a service named MSSQL$<yourinstancename>.
If not, it means that MSDE hasn't been installed.
I used a setup.ini file to install MSDE.

Setup.ini

[Options]
INSTANCENAME="myinstance"
TARGETDIR="C:\Directory_where_the_database_will_be_installed"
DISABLENETWORKPROTOCOLS=0
SECURITYMODE=SQL

MSDE installation :

Setup /settings “Setup.ini” SAPWD=”passwd” /L*v d:\Tools\MSDE\MsdeLog.log

 Hope this help.

Fred
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now