[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

PIX 2 PIX does not work  Same goes for client to PIX

Posted on 2004-11-12
4
Medium Priority
?
406 Views
Last Modified: 2013-11-16
Here is the config at the 506 pix that is set up at both pix to pix and client to pix.....
Im able to connect using the pix vpn client but unable to ping any of the host on the network.

look at the pix to pix first :-)

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password sUh51JfF84zKYNlu encrypted
passwd hjrpJ.hBw/QsytJw encrypted
hostname pixfirewall
domain-name sotra
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list pix2pix permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list c2pix permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list nonat permit ip 10.10.1.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 10.10.1.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.200.200-192.168.200.250
pdm location 10.10.1.17 255.255.255.255 inside
pdm location 10.10.1.0 255.255.255.0 inside
pdm location 10.10.2.0 255.255.255.0 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 213.184.206.164 255.255.255.255 outside
pdm location 213.234.122.0 255.255.255.0 inside
pdm location 192.168.200.0 255.255.255.0 outside
pdm location 213.234.122.0 255.255.255.0 outside
pdm location 213.239.120.44 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nat_zero
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 213.184.206.164 255.255.255.255 outside
http 10.10.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt noproxyarp inside
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto ipsec transform-set CiscoVPNClient esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set CiscoVPNClient
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address pix2pix
crypto map transam 1 set peer 213.239.120.41
crypto map transam 1 set transform-set chevelle
crypto map transam 10 ipsec-isakmp dynamic dynmap
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 213.234.122.31 netmask 255.255.255.0
isakmp key ******** address 213.239.120.41 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 10.10.1.1
vpngroup vpn3000 wins-server 10.10.1.1
vpngroup vpn3000 default-domain sotra
vpngroup vpn3000 split-tunnel c2pix
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh 213.184.206.164 255.255.255.255 outside
ssh 213.234.122.0 255.255.255.0 outside
ssh 213.239.120.44 255.255.255.255 outside
ssh 10.10.1.17 255.255.255.255 inside
ssh timeout 60
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname so-grup@online.no
vpdn group pppoe_group ppp authentication pap
vpdn username so-grup@online.no password *********
dhcpd address 10.10.1.3-10.10.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:f5ff93e2e710e2706dd37342ffd15da3
: end







And this is the 501 pix at the other site

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname nsi
domain-name sotra
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list n2v permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
pager lines 24
logging on
logging standby
logging console errors
logging monitor errors
logging buffered errors
mtu outside 1500
mtu inside 1500
ip address outside 213.239.120.41 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.10 255.255.255.255 inside
pdm location 213.184.206.164 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list n2v
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 213.239.120.41 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set toyota esp-des esp-md5-hmac
crypto map bmw 1 ipsec-isakmp
crypto map bmw 1 match address n2v
crypto map bmw 1 set peer 194.248.203.192
crypto map bmw 1 set transform-set toyota
crypto map bmw interface outside
isakmp key ******** address 194.248.203.193 netmask 255.255.255.0 no-xauth no-config-mode
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh 213.184.206.164 255.255.255.255 outside
ssh 192.168.1.10 255.255.255.255 inside
ssh timeout 60
console timeout 0
dhcpd address 192.168.1.10-192.168.1.30 inside
dhcpd dns 213.184.200.1 213.184.200.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:e6e465180b964761db0286aac6ed2a71
: end
0
Comment
Question by:daxa78
  • 3
4 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12570197
In your first config, your nat_zero acl is backwards:

  >access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0

  Should be:
    access-list nat_zero permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
Syntax is:
     access-list nat_zero permit ip <local LAN> <mask> <remote LAN> <mask>

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12570233
In the second config:
  >crypto map bmw 1 set peer 194.248.203.192
  >isakmp key ******** address 194.248.203.193 netmask 255.255.255.0 no-xauth no-config-mode

The peers should be the same IP in both places....

Also, your default route cannot point to your own interface IP, it must be the "next hop"
   >ip address outside 213.239.120.41 255.255.255.0
   >route outside 0.0.0.0 0.0.0.0 213.239.120.41 1
0
 
LVL 1

Author Comment

by:daxa78
ID: 12570326
Just sendt you an email :-) Mr lmoore.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 12571691
On the 501, add:
  isakmp enable outside

0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question