IIS/Citrix/Comcast connection problem

I currently have my server up and running windows 2000 adv srv
Here is my thing Im using Citrix Metaframe xp if anyone has used it
The reason for citrix is to run nfuse redirected to port 80 to run apps from work or wherever regardless of firewall since its on port 80 or i can redirect it to whatever port. Apps like rdp,vnc,ieplorer from home without the stupid proxy filtering here at work.
Citrix is sharing port 80 with iis its works great on lan but from say my cousins to me which he is on earthlink dsl ,the web page wont even come up for him or anyone else.
Im wondering if this is a comcast thing i know that they dont allow webservers by there rules but is the http filter only to inbound traffic and not outbound on comcasts end?
Server is also dmz'ed through my router with a few rules sets/port fowarding.
I am also running http://www.dyndns.org 
ftp is working fine, ssh is working fine on lan outside also
citrix metaframe xp is working fine on lan
IIS is running fine on lan
Also same **** with VPN Server connects then drops the user.
If this is the case im gonna switch todsl or a service that allows this.
Everything is patched and updated
I am using  static ips mac filtered with a router netgear wgt624
The server is dmz'ed out and is also setup for port forwarding and port triggering.
Any ideas anyone?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You could try changing the port that NFuse listens on, to a port that you know works from outside of Comcast. You mentioned that FTP works fine, try shutting down FTP for a day, setting IIS and NFuse to use port 21, and see what happens.
kane77573Author Commented:
Nope still dont work
when i changed it to port 21 and stop the ftp service same thing just goes blank does not even come up on the lan.
If i use port 4545 8080  works ok not gonna try any more ports
also tried the ssh port 22 same thing nothing
not sure if they r blocking the TOS ( Type Of service) on the packets going outbound
still no luck
Go to https://grc.com/x/ne.dll?bh0bkyd2 and have the site scan your ports.  If port 80 comes up as stealth, then your ISP is probably blocking it.
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kane77573Author Commented:
tried that website
funny thing is ssh is open ftp is open ( and i know this ) and it said there were stealth.
Still no luck.
Im going to go with dsl for more on the upload 6 down 768 up
redoing the os tonight with windows 2003.
Not sure what else to do with this.
kane77573Author Commented:
also now that windows 2003 is up and running
i cant install metaframe xp since windows 2003 does not have Microsoft java virtual machine installed
anyone know how or where i can get it
I tried to download it but needs the origanl version
kane77573Author Commented:
Anyone have any other ideas? And i dont have Citrix Metaframe XP FR3
kane77573Author Commented:
Ahh I finally fixed the virtual machine problem
what i did was i had to install microsoft virtual machine off of a dvd i had and then update it with windows update. then installed netscape. Then installed Feature Release 3.
Now java is up and working
Well i guess ill wait till my dsl arrives and try my website then.
PAQed with points refunded (300)

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.