Problem starting VB program with telnet & psexec

When I use a telnet session to start a Visual Basic program, the program starts, but then stops after about a minute.  I think the reason is that the VB program gets to the part where it needs to access the network, somehow doesn't have permission, and locks up.  I can get on this computer directly and run the program fine.  Is there something in telnet that I need to put in the command line to get network access?  I have a batch file that I run from telnet which accesses the network also, and it runs fine.

I've also run a program called psexec that starts the program with the same results; it stops after about a minute:
psexec \\E11877 -d C:\Cessna\CPDPriceFileBuilder.exe

I tried putting in the username and password, which I know is correct, but get the message, "Logon failure: unknown user name or bad password.":
psexec \\E11877 -u c82418 -p hiuy2ert -d C:\Cessna\CPDPriceFileBuilder.exe

Any ideas?  Thank you!
psmithphilAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TannerManCommented:
Take your command of....

psexec \\E11877 -u c82418 -p hiuy2ert -d C:\Cessna\CPDPriceFileBuilder.exe

and change it by adding domain name of the user account in question....like this "\DOMAIN\"......as I have here.....

psexec \\E11877 -u \DOMAIN\c82418 -p hiuy2ert -d C:\Cessna\CPDPriceFileBuilder.exe
0
PakaCommented:
Why not run it using Term Serv?

Paka
0
troopernCommented:
Paka perhaps he doesn't use Win2K server, XP or Win2k3 server ?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

psmithphilAuthor Commented:
I see I left some things out.  I can use Terminal Services to get to a server and run commands from there.   I can use Terminal Services to get to the server, but not to the pc, at least as far as I know.  The pc is using Windows 2000.   I've tried running psexec and telnet from the server, but haven't quite succeeded in doing what I need yet.

It tried the psg command you gave me, Tannerman, but I get the same error message of the logon failure.  I ran it from the server in the command prompt.  The server OS is Windows 2000 Terminal, I guess a Win2K dirivative.  When I sign on, my domain is "Cess01".   Any ideas?

psexec \\E11877 -u \Cess01\c82418 -p hiuy2ert -d C:\Cessna\CPDPriceFileBuilder.exe

I appreciate everyone's help and efforts!!
0
psmithphilAuthor Commented:
By the way, can I thought Terminal Services Client was only for servers.  If I can use it on a Windows 2000 computer, how do I turn the services on so I can connect?
0
psmithphilAuthor Commented:
I was looking on the server and see Terminal Services is present in "Services", but it's not on the computer.  Can Terminal Services be installed on a pc?
0
TannerManCommented:
Ok, I am confused now for sure.

What machine are you wanting the program CPDPRICEFILEBUILDER.exe to run on? The w2k workstation or the Sever?

It almost sounds as though you would like the ability to log directly onto the w2k workstation just like you do the Server's terminal services. This is possible, but not with terminal Services on a w2k workstation. XP was the first MS workstation to have built in Terminal Services known as Remote Desktop (RDP and Terminal Services is basically the same thing). The only other MS product to do this with, prior to XP, was the Netmeeting product.

 Download Real VNC from the below link and install it on the w2k workstation AND the machine by which you'd like to control the w2k workstation FROM. It is a remote control software that is free. Instead of opening up a "blind" session to a remote machine (where users's in front of hte physical machine can't see you connected) it is a direct console emulator. You are, in reality, loggoing onto the server's login screen as if your in front if it.

http://www.realvnc.com/

Please explain EXACTLY what machine you want to run the EXE file ON and what machine your wanting to remotely run the program FROM. This is, if the above software doesn't get you where you need to be on this issue. If all your needing to do is just gain remote access to the W2K workstation to periodically run the Executable then the VNC is your ticket.

If your wanting to run the EXE on the W2K workstation periodically without physically connecting, just put the exe on the workstation and create you a batch file to run it and then schedule it with Task Scheduler.

Hope it helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
psmithphilAuthor Commented:
Yes, I don't feel I've done a good job at explaining my situation, and for that I apologize.  I am wanting to run the executable (cpdpricefilebuilder.exe) on the Win2K workstation, and I figured I'd have to use the server in some way to get it started.  I can use Terminal Services to connect to the server.
VNC may work, I don't know, but I will try it.  I see I would put the VNC server on the Win2K workstation and use the VNC viewer on the server.  My concern at this point is that someone would have to be at the workstation to authorize the server to connect.  I will try it at work tomorrow and see if it works.  Thank you for your help!
0
TannerManCommented:
No need to apologize. Some situations,like these in paticular, are tough to get the idea across in text.

The VNC server service requires you to set a password during install. There is also a place to choose for the service to be loaded automatically, which you want.

Now, as to your other point. NO, the server plays no part in you running the service on the w2k station.

Put cpdpricebuilder.exe in the root of the C:\ drive of the w2k workstation.
Go to control panel and open up Task Scheduler.
Choose your exe file as the program to run
setup your time/day schedule.
In the credentials section use an administrative username / password for the w2k machine.
Once created to a run now and see if it will run
Now, set the time schedule in the properties of your task to run once, in about 5 minutes. Log off and check the results in about 10 minutes to see if the exe ran. Whatever it is your exe does, just verify it did it when scheduled.
Now edit your time schedule the way you want it and your done.

No need to involve the server at all.

Hope that helps
0
psmithphilAuthor Commented:
Thank you, Tannerman, I will let you know asap how it works!
0
psmithphilAuthor Commented:
Okay, I just got finished with my testing.  I earlier tried VNC but just couldn't get it to work.  However, a person at work showed me I could use my Terminal Services hookup to run what I wanted on the laptop.  He had me use "Start .. Run" and type in the laptop's name on the network (\\E11877).  That opened a window where E11877's shortcut to the Task Scheduler was.  I opened the shortcut and was able to run the 2 programs successfully.  Everything transferred over the network!

You guys have been very helpful and I think the way I explained my situation was lacking.   I am going to award the points to both of you, Tannerman & Paka, as I appreciate what you did and what I learned from you.  If you think I'm not being fair, please let me know.

Thank you very much for your outstanding help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.