• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 536
  • Last Modified:

Need to find a BIOS update....

Hello Experts,

I am trying to find a BIOS update for an old BIOS on an old gateway pc...
The BIOS version I am running is:

AMIBIOS version 1.00.07.DQ0T U
1992 American Megatrends, Inc.

It's a long story, but I need to try and make this old machine see an old optical drive and the SCSI host adapter.  I think it's a BIOS incompatibility that's stopping it from seeing it.  So please help if you can?!

Thanks.

Mark
0
mark-wa
Asked:
mark-wa
  • 5
  • 4
  • 3
  • +5
1 Solution
 
tosh9iiiCommented:
You wouldn't have the model number for the motherboard would you?
0
 
mark-waAuthor Commented:
I will check to see if I can get the model number for the motherboard.  I have put in service requests to both of those websites, but I haven't heard anything back yet.  I did that before posting this Q on EE.  I just really don't want to have to pay for the support and not have it work or not be able to get an update.

Thanks for trying though.  Hope to hear more ideas.

Mark
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
woodendudeCommented:
http://www.snapfiles.com/get/everest.html   download and install Everest if you're able, under motherboard you'll find the info needed.
0
 
mrielfCommented:
SCSI Host adapter works in your computer?
0
 
ridCommented:
The optical drive(s) are usually accessed through drivers. Unless you're compelled to boot from an opticl drive, the BIOS doesn't need to see it for you to be able to use it. It is a matter of your O/S (e.g. DOS relies on a CD driver file like oakcdrom.sys and the mscdex.exe file).

A scsi adapter is the same thing, really. If it has a BIOS of its own, you'll notice during POST (there'll be POST messages from its BIOS); such an adapter allow booting from a SCSI hard drive. An adapter without a BIOS will require drivers to use any kind of SCSI device. It does not rely on being seen by BIOS.
/RID
0
 
nobusCommented:
Get a new bios here :

http://www.recoverybios.com/                              replace bios
http://www.badflash.com/                                        "          "
http://www.amptron.com/documents/Recover.pdf                  recover BIOS
0
 
BjornEricssonCommented:
mark-wa,
If you could provide me with the modeltype/machine number of your old gateway machine I could use that to locate the type of motherboard you have and thereby find the correct BIOS update.
/B
0
 
mark-waAuthor Commented:
Here's the info for the computer:

S/N: 0006772200
Model No: LPMINI-TOWER P55C-200

Thanks.

Mark
0
 
tosh9iiiCommented:
Unfortunately, I don't think there's an update available.  In other words, you have the latest version.

1007dq0t.exe
BIOS revision 1.00.07 DQ0T


http://support.gateway.com/support/drivers/getFile.asp?id=14781&uid=68447872
0
 
mark-waAuthor Commented:
That's kind of what I was thinking.  So maybe I asked the wrong question.  I just don't understand.  Here's the long story I spoke about in my original post:

I have a machine running Minolta's MiMs database program with which we use this machine to lookup old patient cases on the optical drive.  MiMs no longer has support and these OD's (optical disks) are the only place we have this data contained.  We have to keep this data for another few years, and unfortunately, this machine is the only one that can read these OD's because they were formatted by MiMs, which is very proprietary.  So I bought a program called Instant Recovery from NovaStor Software and used it to make an exact duplicate of the MiMs machine's hard drive onto a new hard drive.  When I plug this hard drive into the original MiMs machine, it works fine.  But when I plug this hard drive into this other machine (the one that I wanted the BIOS update for), I also plug in the same SCSI card from the MiMs machine and the same Optical Drive, it errors during the bootup process.  It gets to the Windows 98 splashscreen, then you hear a semi-long beep, then it goes to a dos screen and has the following error:

LaserData LV-912 SNYWORM.EXE version 4.33g, pre-release
Optical Disk Driver
Error:   Unable to locate a SCSI host adapter.
           Program not loaded.
Strike a key when ready...

Then you hit enter or any other key and it will boot into Windows 98 and you can't read the optical drive.

Funny thing is though, this SCSI card has it's own BIOS and it loads when running on this other machine, and it sees and identifies the Optical Drive, all before it goes to the Windows 98 splash screen.

So, the same backup-imaged hard drive works fine on the original machine but when plugged into this other machine, it can't see the optical drive or the SCSI adapter.  Doesn't make sense because it identifies both during bootup.  The SCSI card is an Adaptec 1540/1640 SCSI Host Adapter.

One strange difference during bootup though, after it detects the SCSI card, it calls Optical Drive "Drive #0" on the machine that's not working, but it calls it "Drive #1" on the machine that works correctly.

So I guess the problem seems that it's not seeing the SCSI adapter correctly.  I don't know.

Any thoughts?

Mark
0
 
_Commented:
Might be some kind of driver conflict with the cloned drive and the new system.
Boot into SAFE MODE and see if you have duplicate entries in Device Manager. Or " ! " or " X " beside anything.

Are there mobo drivers that need to be install for the new system?
0
 
tosh9iiiCommented:
That computer seems to be pretty old, maybe it's time to get a new one.  You can get a barebones sytem with P4 Celeron 2.7ghz for about $99 after rebate.
0
 
ridCommented:
So, the hard drive on the working system is not SCSI, but IDE?
And you try to move this IDE HD and the SCSI adapter to another machine and it doesn't work?

1) Why are you trying this operation (i.e., why can't the original machine be used)?

The problem may very well be that the "other" machine has some other kind of hardware that conflicts with the SCSI adapter and the conflict becomes apparent when the drivers are loaded (they load with the config from the "old" machine, remember...). It might help to start in safe mode (if possible) and unistall the SCSI adapter and then reinstall it..
/RID
0
 
mark-waAuthor Commented:
Ok, the reason we are using this "old" machine to connect this optical drive and SCSI card is because we don't have any other machines that have ISA slots, they are all too new.  The hard drive that I using is IDE, so I can install that, with the SCSI card and the optical drive in the original MiMs machine and everything works great.  I take the hard drive, SCSI card, and optical drive and hook them up to this other "old" machine and it gets to the Win98 splash screen and gives the error from my previous post.

The only thing I can come up with is that because the 2 machines have different hardware, when the hard drive is plugged into the second machine, it has to reinitialize all of the hardware and it's giving the resources that the SCSI adapter is set to use to another device.  In fact, I see that IRQ 11 is being used by the video card, and it won't let me change it.  I tried to change the SCSI adapter to a different IRQ, but it didn't make a difference.  But my partner, that's been here longer than me and was here when the original MiMs machine was originally setup, said that she remembers the Minolta techs having a problem with this and it seemed like the only IRQ it would work with is 11.

So I don't know, I'm about to give up.  Any more thoughts before I throw in the towel?

Thanks.

Mark
0
 
ridCommented:
http://www.adaptec.com/worldwide/support/suppedindexprod.jsp?sess=no&language=English+US&cat=%2FProduct%2FAHA-1540

If the SCSI adapter is an AHA 1540, some info can be found there. It seems both IRQ, I/O address and BIOS address are jumper configurable.

I have been where you seem to be (old, very expensive or not-easily-replacable equipment and an out-of-date control computer) so I think I can appreciate the problem. Installing an AHA 1540 shouldn't really be a problem if you can find and correct the resources clash that seems to be happening here. My question about the different computers was more in the way of wondering why the original machine couldn't be used any more as it seems still be be functional. Perhaps I didn't understand something.

If you really want to go to the bottom with this, you should go through all values for I/O, memory addresses and IRQ that you can find in use on  the 98 machine's device manager and compare to what can be set on the SCSI adapter (per the manual). Perhaps even trying to find another "old" machine with ISA slots is a good idea and do a from-scratch install of 98, with the SCSI adapter in place.

/RID
0
 
nobusCommented:
Can you install win98 first, then insert the scsi card and install that?
0
 
_Commented:
Tough one. Maybe rid (his last post). Maybe coral47 (load mobo drivers).
Otherwise Delete/Refund
0
 
mark-waAuthor Commented:
Sorry about that.  I forgot about this question being open.  Thanks.

Mark
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 4
  • 3
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now