How to get write permission for php scripts on a windows 2003 server.

I have a Windows 2003 server with php4.0 and IIS V.6 and I am trying to get write permissions for a php script and nothing I am doing is working.  I have tryed giving write permission to isuer for the folder, the whole site, and even the entire computer, but nothing works.  Anyone have any idea what I am doing wrong?
LVL 1
studeggleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave_DietzCommented:
Are you using PHP as an ISAPI or as a CGI?  Is the page authenticated or anonymous?

Try giving write permissions to the IIS_WPG group on the target folder.

Dave Dietz
0
studeggleAuthor Commented:
I am useing ISAPI php, I had tried giving permision to the group.  A friend found the solution for me.  I was only issueing the permission through the IIS manager, I also had to go into windows explorer and issue it dirrectly to the folder.  What a pain you'd think microsoft would make that happen automatically.
0
studeggleAuthor Commented:
I would like to reward you for your effort especially since I was delayed in getting back to you.  But I don't think its fair to give you a excellent/good grade when you didn't have the answer.  So pehaps you can give me a clue on another minor issue that has arrisen.  I have to use the php.exe file and the server set to execute scripts and exe to get php to work.  It would be better, and from what I know should work, to have the dll file for interpretation and execute scripts only as the setting.  Anby idea why I can't use the dll file instead of the exe file?
0
Dave_DietzCommented:
If you're using the EXE you're *not* using PHP as an ISAPI - you're using it as a CGI application.

In any case, what happens when you try using the DLL?  My guess is you end up with 404 results.

If this is the case you will need to configure a Server Extension for the DLL and enable it.

In Service Extensions create a new Extension, add the php.dll file to it and then set it to Allowed.

Dave Dietz
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.