BGP on a Catalyst4500 with Sup4.

Hi,

I've just recently got a Cat 4500 with a Sup4 (512mb RAM)... Whenever I try and send it a full table I get a CEF error telling me its disabling CEF. The routers not live, so im leaving it in "testing". I've tried the newest IOS and its not worked. I've tried sending sh tech off to Cisco etc.. No difference.

00:37:02: %FIB-2-FIBDOWN: CEF has been disabled due to a low memory condition.
 It can be re-enabled by configuring "ip cef [distributed]"

After re-enabling CEF it then just resets, even with a full table and CEF "disabled", its got about 300mb RAM left free! I just don't understand why its showing a problem. BGP works fine, I've just got a default route set at the moment, but this needs to change very soon.

Any suggestions would be great.
alexcfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kpmasCommented:
What else is in this box?  There must be line cards etc... can you post a "sh diag" ?

Just ran across this with a 7513 router for example that has lots of memory however the GigE card itself (and the card that drives it) only had 32 Meg of RAM and when it tries to load the FIB into the card's processor it can't .... the interface card has to be able to hold the entire FIB.  In this case it looks like a full BGP feed is loading the FIB memory beyond what it physicaly has.

0
AutoSpongeCommented:
From 12.2 caveats
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cavs/122mcavs.pdf

• CSCuk51673
Symptoms: Distributed Cisco Express Forwarding (DCEF) may become disabled and the
following error message may appear on the console:
%FIB-3-NOMEM: Malloc Failure, disabling DCEF %FIB-2-FIBDOWN: CEF has been disabled
due to a low memory condition. It can be re-enabled by configuring “ip cef
[distributed]”
Conditions: This may be seen on a platform running DCEF. DCEF may get disabled. This
depends on how much memory is being allocated at runtime.
Workaround: Upgrade to the image containing this bug-fix.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.