• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 520
  • Last Modified:

Qt configure error

hello, all,

  i installed KDevelop  on my machine (SuSE 8.2, SHELL=bash), and used wizard to create a "Hello World" app, however i got error like follwing when compiling it.
  Qt itself had already been installed in /usr/lib/qt3, because i can start Qt designer from there.
  something wrong?


error message:
---------------------
checking for Qt... configure: error: Qt (>= Qt 3.1.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
---------------------

thanx in advance
kim
0
kim_wei
Asked:
kim_wei
1 Solution
 
gripeCommented:
Hi kim_wei,

Do you have the QTDIR environment variable pointing to your qt installation? If not, try setting QTDIR to /usr/local/qt or whever you have it installed and then running kdevelop from the same shell.


0
 
wesly_chenCommented:
Hi,

> checking for Qt... configure: error: Qt (>= Qt 3.1.0) (library qt-mt) not found. Please check your installation!
Please run the following command:
# ldd /usr/lib/qt3/<qt designer name>
to check what library is missing or the path of that library is not right.
Make a symbolic to the right place or set the QTDIR variable like gripe said.

Regards,

Wesly
0
 
kim_weiAuthor Commented:
thanx a lot Wesly,

  properly, Qt was not correcly installed. Now everything is fine.

kim
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now