Cannot connect to my cold fusion server using https:// ONLY http://

I have a confusing problem with trying to connect to my Secure Server.
I have everything completed  to allow SSL connections (only) installed on my Apache web server 2.0.
My OS is Red Hat Linux ES Server. (https://myservername.com)
My secure site is running fine I can conect using https:// only. When I use http:// cannont connect  directly to my web server web site name. (I will be directed to a page in my html directory that I have set to instruct users to use https:// on the secure server to connect.

Problem is.
I cannot connect to my coldfusion server pages using https:// only http://
If I try:
https:/www.myservername:8500/CFIDE/administrator
I cannot connect to my cold fusion server.
If I try:
http://www.myservername:8500/administrator
I will connect just fine.
When I add:
Listen 0.0.0.0:8500
to my ssl.conf file I get an error message when I restart Apache stating that
Apache cannot bind to port 8500.
Can someone help me solve this problem.
I do configure apache2.0 with a SSL module in the conf.d directory.

Thank you in Advance.
Keith Henriques
keitharisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MauseCommented:
There was a bug in CF administrator on https but there is also an update for this problem:

http://www.macromedia.com/support/coldfusion/ts/documents/navserver_blank_61u.htm

Hope this helps,
Mause
0
keitharisAuthor Commented:
Hello Mause:
I think my problem is with finding a way for Apache 2.0 SSL to accept connections on port 8500.
The way I have it configured now it will only accept connections on port 443.
I don't know how to get the server to accept connections on another port.
Thank you in advance for any ideas you have.
Keith Henriques
0
MauseCommented:

I don't know how to configure Apache for ssl on port 8500
You can find some documentation about Apache ssl here:
http://www.apache-ssl.org/docs.html

Or you can ask your question in the Apache section:
http://www.experts-exchange.com/Web/Web_Servers/Apache/
I think they know more about this then I do

0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

keitharisAuthor Commented:
Hello Again Mause:
I don't think my problem has anything to do with Apache.
When I stop Apache I still can only connect to my coldfusionmx server with http://wwwmysite.com:8500/CFIDE (etc.)
My issue must be with having coldfusionmx accept a SSL connection.
Thank you again in advance!
Keith Henrqiques
0
MauseCommented:
What webserver do you use then?
Did you also installed the Coldfusion webserver?
0
keitharisAuthor Commented:
Hello Mause:
Yes, I have installed the Cold Fusion Web Server.
Below is some of the information from the administration program that comes with it.

Server Product       ColdFusion Server  
 Version       6,1,0,63958  
  Edition       Enterprise  

Keith Henriques
 
0
MauseCommented:

Why using buildin webserver if you already have apache running?

The settings of this buildin server are saved in yourcfdir/runtime/servers/default/server-inf/jrun.xml
But I never configured the buildin server to use ssl.
0
MauseCommented:
there is a section
<!-- This is the built-in JRun Web Server                               -->

where you need to uncomment the last past to enable ssl
0
keitharisAuthor Commented:
I have not been able to implement the connector to use Apache with coldfusionmx. I am a bit lost in how to
go about this. I have tgried to use the apxs utility but have not been able to actually compile a module.

I cannot find any documentation on exactly what to uncomment to allow the jrun.xml file to allow
SSl conmections from apache.
Can you shen any light on this.
Thank you in advance.
Keith Henriques
0
MauseCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.