config Solaris in order to connect to Internet

hello
I just re-configured the router with static IP.
Then, I executre sys-unconfig to setup the hme0 for solaris 9

after rebooting, I also edit resolv.conf and nsswitch.conf with appropriate DNS information

However, the Netscape cannot connect to internet (error: server is not responding) ; whereas,  the PING command to yahoo.com reported "yahoo is alive".

Can you help me?

valleytechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
Does 'nslookup www.sun.com' return an IP?

Does your router have any firewall rules that could be preventing access?

0
wesly_chenCommented:
Hi,

> the PING command to yahoo.com reported "yahoo is alive".
That doesn't sound like DNS issue. It looks like some access rule on the router/firewall block the http traffic.
Do you have other PC on the same network as Solaris 9 box so you can test Internet Explorer for the same
site you was trying to browse in Solaris 9 box?

Wesly
0
yuzhCommented:
Create /etc/defaultrouter file and put your router IP in the file, eg:

echo "xx.xx.xx.xx" > /etc/defaultrouter

replace "xx.xx.xx.xx" with your router IP, then reboot.

If you still have problem, check your firewall setting and make sure port 80 is not blocked.
0
NukfrorCommented:
First, be sure your default gateway is correct and setup.  I know ... sounds pretty silly but check it anyway.  Make sure /etc/defaultrouter is setup and a "netstat -rn" command shows you the exact same IP address.

If default gateway is not setup as expected, be sure your subnet mask is correct.  Another "of course its correct" area but this can easily cause default gateway settings to be ignored.

Ping your default gateway - assuming its allowing ICMP traffic that is.

Try pinging your default gateay's default gateway.
0
moduloCommented:
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.