• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 236
  • Last Modified:

set quotas for virtual server USER

Hello
My SOlaris 9  system is using Apache2 as a webserver and Webmin as a ISP control (to create virtual server)

I used webmin to create USER with home directory is located at /usr/local/apahce2/htdocs/user_name

How can I set quotas for those USERS coresponding to theirs' home directories?

Webmin does incude Disk Quotas; however, that module can only set quota for / and /home, not /usr/local/apache2/htdocs/user_name

Can the experts help me?
I am trying to build up 2 servers by myself and those problems couter me

Thanks alo
best regard
0
valleytech
Asked:
valleytech
2 Solutions
 
wesly_chenCommented:
Hi,

   To set quota on Solaris,
1. Edit the /etc/vfstab file as root, and add "rq" flag to the mount options field for /usr (or /usr/local).
    This enables quotas for the file system.
2. # cd /usr (or /usr/local, depends on you mount as /usr or /usr/local)
3. # touch quotas; chmod u+rw quotas
4. # edquota <user_name>
5. # quotaon /usr ( or /usr/local )
6. Check the quota
 # quota -v <user_name>

Wesly
0
 
yuzhCommented:
Please following the instructions in the following page to setup the quota:

http://experts.about.com/q/2393/1325518.htm

PS: Have a look at you /etc//etc/vfstab  file to find out the mount point (filesystem)
     for /usr/local/apache2/htdocs then setup the quota.

     Pay attention to "Soft Limits vs. Hard Limits" and "How to Set Up Quotas for Multiple Users "

    The instruction in the above page is for Solaris 7, it also apply to Solaris 9, you can
get the Sun docs from (for Solaris x):
    http://docs.sun.com
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now