• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 172
  • Last Modified:

Can't delete mail

Hi Guys

On one of our sites when the admin goes to delete a supected corrupt message from a user's mailbox he gets "you need to run the collector agent against the database".

This is happening with a few different users.  Sorry bout the sketchy info - once again got it second hand.  Any ides on troubleshooting this one?
0
ausadmin
Asked:
ausadmin
  • 10
  • 6
2 Solutions
 
HemanthaKumarCommented:
probably somebody did

Issue this command at server console for the shared mail info..
SHOW SCOS ALL

To unlink the shared mail use these commands

Load Object Unlink USERMAIL.NSF
Load Object Unlink SHARED.NSF

For more details follow the admin help

~Hemanth
0
 
HemanthaKumarCommented:
Backup the shared mail before doing this.. if something goes wrong you can revert back to shared mail
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ausadminAuthor Commented:
Cool - when you say backup - you mean copy the usermail.nsf and shared.nsf ?  Can I do this while the server's live?
0
 
madheeswarCommented:
you can't copy them while server is running.
0
 
HemanthaKumarCommented:
When it is manual .. copy offline

If you have some backup software which can handle open files.. they should be able to do the job
0
 
ausadminAuthor Commented:
The guy finally gave me the exact error.  He goes to delete a mail out of the user's inbox in the
normal notes client and gets:

"The object store note that is used by this note was not found. Run the object store COLLECT task
on this database.

Now obviously the suspect database would be their mail file.

But since this is happening to a few users it suggests a server problem.  Now a few people have
things to try on the database.  But my question is assuming no shared mail - which database
am I trying to fix?
0
 
HemanthaKumarCommented:
what did the console command say ?
0
 
ausadminAuthor Commented:
sorry Hemantha snowed with citrix projects - getting one of our guys to run it today.
0
 
ausadminAuthor Commented:
Guy tried the SHOW SCOS ALL command - it gave him the error: command or option not recognised
0
 
HemanthaKumarCommented:
Using R5 server ?
0
 
ausadminAuthor Commented:
Nope these guys are on 6.5.1
0
 
ausadminAuthor Commented:
Damn guy told me wrong - it IS an R5 server.  
0
 
ausadminAuthor Commented:
Boss told me they had shared mail but kicked it out.  He did it and did the unlink commands.  
There is a mailobj.nsf file there but it's only 1K.  Any ideas - this is getting kind of urgent.
0
 
HemanthaKumarCommented:
if mailobj is present then the unlinking was not successful..

Goto admin help and follow the help for unlinking the shared mail.. or backup and delete mailobj.nsf.

Second check what tasks are running on the server..
0
 
ausadminAuthor Commented:
Sorry LearnedOne

Definately cleanup time.  Hemantha as always spot-on and tip-top.  Routing stopped one day and we did the usual fixup on the mail.box and this
problem went away.  Will still have to investigate the shared mail situation.

0
 
ausadminAuthor Commented:
Hi LearnedOne

Tried to give the points to Hemantha but it didn't work - could you please action this when you get a chance.  Thanks all :)
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 10
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now