PIX501 Disable Ping from outside network

Posted on 2004-11-14
Last Modified: 2012-06-27
Dear Experts

My company has a sbs2000 server running mainly for ERP application.
, Citrix Metaframe XP presentation sever has also been installed
for our remote users access.
(Server Internal IP:

We have a PIX501 firewall installed. (PIX Internal IP:
I have opened tcp port 3389 for remote desktop for administrator works.
Web server is running just for internal, not outside. SQL 2000 server is runnning too.(no exchange server, no ftp server)
Last month I needed to access from home to my company's SQL 2000 server for some programming works,
so I have enabled tcp port 1433. Everything work fine until this weekend there is a huge inbound traffic into the server,
part of the reason as our firewall still accept PING from outside.

>>>built inbound tcp connection 35504 for outside: ( /12033 ( ( /12033) to inside: (uuuu.xx.local) /1433 (aaa.bbb.ccc.ddd (uuuu.xx.local) /1433)
>>>teardown tcp connection 35504 for outside: ( /12033 to inside: (uuuu.xx.local) /1433 duration 0:00:01 bytes 254 tcp fins

Just in case anything happen, I have temporary removed port 1433 now.

I would like to know how to disable PING from outside (but I can till ping from inside)
but not impair my ability to communicate to outside world?
As I'm very new to PIX firewall, I really need some expert advice before I actually mess up my company network.

Many many thanks in advance.



Our PIX 501 config:

Building configuration...
: Saved
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxxxxxx encrypted
hostname YYYYYY
domain-name XXXXX
clock timezone HKST 8
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list 101 permit tcp any host aaa.bbb.ccc.ddd eq 3389
access-list 101 permit tcp any host aaa.bbb.ccc.ddd eq citrix-ica
access-list 101 permit udp any host aaa.bbb.ccc.ddd eq 1604
pager lines 24
logging on
logging timestamp
logging trap informational
logging history warnings
logging facility 23
logging host inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside
ip audit info action alarm
ip audit attack action alarm
pdm location inside
pdm location kkk.bbb.ccc.ddd inside
pdm location kkk.bbb.ccc.ddd outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0 0
static (inside,outside) tcp aaa.bbb.ccc.ddd 3389 3389 netmask 0 0
static (inside,outside) tcp aaa.bbb.ccc.ddd citrix-ica citrix-ica netmask 0 0
static (inside,outside) udp aaa.bbb.ccc.ddd 1604 1604 netmask 0 0
access-group 101 in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname xxxxxxxxxx@NWTBB.COM
vpdn group pppoe_group ppp authentication pap
vpdn username xxxxxxxxxx@NWTBB.COM password *********
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
: end

Question by:csvchou
    LVL 79

    Accepted Solution

    To disable icmp on the interface, simply add the following command:
      icmp deny any outside

    Blocking ICMP will not prevent port scans. Leaving well-known ports (i.e. tcp 1433 SQL) open is the issue. Anytime you open up any port to any server, be 200% positive that your server is protected with latest patches and best practices, and change the default port if you can (security by obscurity)...

    LVL 5

    Assisted Solution


    and open port 1433 only to selective IP addresses and not to any.

    Author Comment

    It works!! now no one can PING our outside IP

       icmp deny any outside

    I've added the following lines (quote from lrmoore's old solution) so that we can PING from inside

       access-list uart permit icmp any any echo-reply
       access-list uart permit icmp any any unreachable
       access-list uart permit icmp any any time-exceeded

    martap is right, I should open port 1433 to selective IP
    I've asked them to split points, 400 for lrmoore, 100 for martap
    Thanks for fixing my problem in such short time. :)

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Suggested Solutions

    Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    Need more eyes on your posted question? Go ahead and follow the quick steps in this video to learn how to Request Attention to your question. *Log into your Experts Exchange account *Find the question you want to Request Attention for *Go to the e…
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now