• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1596
  • Last Modified:

Windows Installer appears but I do not need it

when i open a program (call it "A") the windows installer window appears. it starts to install a previously installed program ( call it "B")  which has been deleted about one month ago. Since B has been deleted, the error message appears- Internal Error 278 and gives the reference number/symbol. i press esc and after 2  complete repetitions, the windows installer stops and the A program works quite successfully.

i tried different solutions:

deleted program A - and re-installed it

deleted the registry names associated with the name of the program that is attempting to be installed.

deleted the config and ini files of the offending program which is the reference/symbol of the old deleted program A

did a search in windows directory for the phase/word of the reference/symbol- there was none.

any recommendations? thanks

0
cityman12000
Asked:
cityman12000
2 Solutions
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Tell us the names of the programs.  That way we can research the problem more effectively.
0
 
tealnetCommented:
You might want to delete all the temp files in c:\windows\temp and c:\documents and settings\{username}\local settings\temp

0
 
alexfrlCommented:
run msconfig and find this installation request there.

or enter your regestry into the folder:

current Machine:software:microsoft:windows:current version
now look for you "B" in Run/RunOnce/RunOnceEx

check your
current User:software:microsoft:windows:current version/run
too

If you find it there, remove it

Hope it helps
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
tealnetCommented:
He didn't indicate this problem occured when starting the computer.  I don't think removing any start-up items would be appropriate.  It seems the installer for "program A" is somehow launching the installer for "program B" which would indicate some files are still hanging around from "program B" and need to be removed.  However, the name of the files likely do not relate to the actual program, so searching for the program name will probably not help.
0
 
cityman12000Author Commented:
i tried all your suggestions in order received. Nothing was shown that i could deleted.

Tealnet- you are correct so far; you will not need the names of the programs but I will present them anyway.

A is TDS-3 ( trojan program)
B is  "Scansoft- PDF Converter Professional2"

more clarification-  my computer runs just fine- starting up and all the programs within it are runnng well.

so when i click to open tds-3 either via shortcut or by actually clicking on tds3.exe application the windows installer appears.

i will exit the windows installer and the error message appears. (An Internal Error 2718) when i exit a 2nd time... the tds begins to work & that's it!

any suggestions? and thanks





0
 
vladonatorCommented:
Your error msg:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/msi/setup/windows_installer_error_messages.asp
2718 Missing package name for product code '[2]'.

Basically the installer is stuck trying to find a package that no longer exists.

I would try and find the orginal program A, re-install it so it can find the msi package.

0
 
LeeTutorretiredCommented:
You might want to try the Windows Installer Cleanup Utility from Microsoft:

http://support.microsoft.com/default.aspx?scid=kb;en-us;290301
OFFXP: Windows Installer CleanUp Utility


I believe it is also on your XP installation CD.  

1. Insert your Windows XP CD into the drive and browse to H:\SUPPORT\TOOLS.
2. Double-click on setup.exe.
3. Then when prompted, opt for the Complete Installation and you’ll have Windows Installer Cleanup utility installed.
4. Click on Start > All Programs > Windows Support Tools > Command Prompt, type msicuu.exe and press Enter.

[This launches the Windows Installer CleanUp dialog window. It displays all the programs and applications that have been installed onto your PC using the Windows Installer.]

5. Select the item that’s causing problems and click on Remove. All the program’s associated registry entries will be removed from your system along with its entries under Add/Remove Programs.

0
 
cityman12000Author Commented:
vladonator, i thought of reinstalling the original program (scansoft) but it was a 14 days trial and that was over a month ago. i would have to use digital river download. hoever, repeating myself, two days ago, i did an uninstall and re-install of tds- which did not solve the problem.

the microsoft clean up utility was installed properly (thanks to giving good directions - take a bow, Lee <smile> ) however, the installed program of neither tds or scansoft appeared.

later on, i will try to download the scansoft program (digital river registration) and see if the 14 day restriction appears.

Any other suggestions?  thanks again.
cm
0
 
cityman12000Author Commented:
i wanted to raise the points so that vladonator and LeeTutor received equal points for their answers.
0
 
cityman12000Author Commented:
I increased the points so both vladonator and LeeTutor could receive equal points. vladonator had the correct answer. LeeTutor's answer was impressive- even though it did not work.

Thanks for your knowledge and help.

cm
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now