?
Solved

What is the best way to implement this ?

Posted on 2004-11-14
12
Medium Priority
?
749 Views
Last Modified: 2008-02-26
Dear all,

We have got a CISCO 3660 router in our location. We have 3 3205 Netvanta , 1 3305 Netvanta and 1 1224 Netvanta (all Adtran) routers at our remote locations.  

We are planning to change the current ip address of all these routers from 172.16 to 172.24..
I would like to know what is the easiest way to doing this ..

Heard that I could make a parallel route with 172.24 and then remove 172.16 route.. Practically , we would like to have everything functional during the changing phase but is it doable.. Also , I would like to do most of the change from my office so that travel to remote locations can be minimized..

Here is the configuration of our CISCO router

*******
************************

Current configuration : 2209 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MYOFFICE
!
enable secret 5 $1$B6FN$MwpxvniOfbbzLJi0NR7j9/
enable password <password removed>
!
ip subnet-zero
!
!
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description D1 T1
!
controller T1 1/1
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24 speed 64
 description D2 T1
!
controller T1 2/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description D3 T1
!
controller T1 2/1
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24 speed 64
 description D4 T1
!
interface Tunnel1
 no ip address
!
!
interface Serial1/0:0
 ip address 172.16.90.10 255.255.255.0
 encapsulation ppp
!
interface Serial1/1:1
 ip address 172.16.96.10 255.255.255.0
 encapsulation ppp
!
interface Serial2/0:0
 ip address 172.16.98.10 255.255.255.0
 encapsulation ppp
!
interface Serial2/1:1
 ip address 172.16.89.1 255.255.255.240
 encapsulation ppp
!
interface Serial3/0:0
 no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 <removed IP address >
ip route 172.16.89.16  255.255.255.240 172.16.89.14
ip route 172.16.91.0 255.255.255.0 172.16.90.11
ip route 172.16.92.0 255.255.255.0 172.16.90.11
ip route 172.16.93.0 255.255.255.0 172.16.90.11
ip route 172.16.94.0 255.255.255.0 172.16.90.11
ip route 172.16.95.0 255.255.255.0 172.16.90.11
ip route 172.16.97.0 255.255.255.0 172.16.96.11
ip route 172.16.99.0 255.255.255.0 172.16.98.11
ip http server
ip pim bidir-enable
!
!
line con 0
 password <password removed>
 login
line aux 0
line vty 0 4
 password <password removed>
 login
!
end


********
0
Comment
Question by:sunray_2003
  • 7
  • 4
12 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12580341
Are you going to change both the LAN and the WAN IP's?

easiest thing to do is to enable dynamic routing, like ospf...

with OSPF, you can remove all statics, and have a simple, common config on all remote site routers:
Assuming that your serial interfaces will all be in the 172.24.0.0 subnet
   router ospf 10
    network 172.24.0.0 0.0.255.255 area 0  
    redist static

At the HQ, you can also advertise a default and remove all statics (except the default)
   router ospf 10
    network 172.24.0.0 0.0.255.255 area 0
    redist static
    default-information originate


   
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 12580731
>>Are you going to change both the LAN and the WAN IP's?

Yes.. Everything which is 172.16 needs to be changed to 172.24..

I am sure there is an advantage of doing dynamic routing but I would like to have it as static.. just like what we have right now. If I need to stick to static , what needs to be done..

In the adtran router , is it like doing something like this

*********
Telnet to the router

config t
int ppp 1
ip address 172.24.5.10 255.255.255.0
exit
int eth 0/1
ip address 172.24.5.11 255.255.255.0
speed 10
half-duplex
ip route 0.0.0.0 0.0.0.0 172.24.5.11
exit
exit
wr mem
exit

******

I did something like above in my previous adtran configuration and just changed .16 to .24 ...
0
 
LVL 13

Expert Comment

by:Dr-IP
ID: 12580865
Generally the way I do what you want to do is change the IP address of the far routers serial interface, which at that point you will lose contact with it, then change the local routers serial interfaces IP address, and then telnet from the local router to the remote routers new serial interfaces address and go from there. At that point you can change the Ethernet interfaces address and the static routes.  
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 12583322
Here's my suggestions. Two options:
1) telnet to the serial IP of the remote router. Change the Ethernet IP, add the old Ethernet IP back in as secondary (helps your systems stay connected until they all get changed), THEN change the serial IP (you will lose connectivity as soon as you hit [enter], then change the matching serial subinterface of the 3660:
Be SURE to telnet to the Serial (ppp) IP
   config t
   int eth 0/1
     ip add 172.24.5.11 255.255.255.0
     ip add 172.16.5.11 255.255.255.0 secondary
   ip route 0.0.0.0 0.0.0.0 172.24.4.10  <== your example above shows the serial and ethernet in the same subnet!
   ip route 0.0.0.0 0.0.0.0 172.16.?.?  10 <== keep the old default, but make it a higher cost "10"
    int ppp 1
     ip address 172.24.4.10 255.255.255.0  <== why are you wasting a while class C on the p2p link?
<bam! lost connection>

  back on the 3660:
    interface serial x/x.x
     ip address 172.24.4.9 255.255.255.0
    ip route 172.24.5.0 255.255.255.0 172.24.4.10

 Now you should be able to telnet back into the Adtran and finish the job
      no ip route 0.0.0.0 0.0.0.0 172.16.?.?  <== then must come back and remove this old one after you get the serial interface changed
     write mem

OPTION 2)
 - Setup a TFTP server on your network, set to "accept all files"
 - Copy all existing configs to the tftp server
      write net
       follow prompts for IP address of tftp server
 - edit the appropriate remote site file with the new IP addresses and route statement.
 - copy the new config direct to startup
     copy tftp start
       <follow prompts>
 - when you are ready to make the changes, reboot the remote. While it's rebooting, make the appropriate changes on the 3660 (change serial IP and add the route statement)

What do you have against doing it right with a dynamic routing protocol?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12583327
> a while class C
Should be
     a whole class C

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12583501
SR - Dr-IP,
Can you peek at this question? I think it's a server issue and I may not be the best to help with the problem:
http://www.experts-exchange.com/Security/Firewalls/Q_21201892.html#12564048

Thanks!
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 12583655
Thanks Lrmoore. I got an idea now. I shall try ..

>> your example above shows the serial and ethernet in the same subnet
I guess , that should not be the case.

>> why are you wasting a while class C on the p2p link?
Originally , it was done by a different person. May be he had kept because he might thought we would expand our network.
I just wanted to change so that they all remain the same. we have actually got the whole Ip set 172.24.*.*

>> What do you have against doing it right with a dynamic routing protocol?
Absolutely nothing. It would be good for me to do this so that I can learn more on this. I have not worked on this before so thought having at static would be easy . Moreover , on the other end we have a polycom unit and a computer. We have set static IP in those units. I am not sure if having dynamic protocol in the cisco would affect them ..
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12583699
K..
Using a dynamic protocol on the routers will absolutely not affect the end hosts. It is only a method to keep you from having to setup static route entries on your core router. Each remote router will simply announce its connected networks, to the router at the other end of the serial link. It can then "learn" the default route, so that no statics, not even defaults, need to be configured on the end site routers.
It is quite simple, and you can use the exact same very simple config on all remote site routers:
   
    router ospf 101
     network 172.24.0.0 0.0.255.255 area 0
     
At the HQ,
   router ospf 10
    network 172.24.0.0 0.0.255.255 area 0
    default-information originate

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12583715
One more suggestion:
  As long as you want to stay with the 172.24.x.x subnet, why not dedicated one subnet for ALL the WAN links and use /30 mask, ie.
                                                          HQ sub-if
   site 1  ppp 1 172.24.255.2 /30            172.24.255.1 / 30
  site 1  ppp 2 172.24.255.6 /30            172.24.255.5 / 30
  site 1  ppp 3 172.24.255.10 /30            172.24.255.9 / 30
  site 1  ppp 4 172.24.255.14 /30            172.24.255.13 / 30
  <etc>
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 12583817
Getting into some basics here..
My IS dept said I can use for our network starting from 172.24.0.0.

Does it mean they have given a Class B IP address and I can use it from
172.24.0.0  till  172.24.255.255  using subnet mask 255.255.0.0 ?

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12584050
That is what I would assume...but I also assume you are free to subnet that class B to your heart's content..
Using my suggestion, you can use just one class C subnet for ALL of your wan links, and an individual Class C at each remote site... unless you want to be creative and want a lesson on variable length subnet masking (VLSM)..
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 12584062
Thanks.. Will get back to you as I do some progress on this. Should take more time than expected as network is down and waiting for telco guys to check the lines..
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question