Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 427
  • Last Modified:

Home network with two routers. Completely confused. Need some help.

What I have:
ADSL Broadxent gateway (from ISP with 1 static IP: 68.xxx.xxx.162, LAN IP is 192.168.1.1, with NAT enabled)
D-Link wireless router (LAN IP is 192.168.0.1, WAN IP is 192.168.1.102 assigned by Broadxent, with NAT enabled)
Desktop (LAN IP is 192.168.0.100 assigned by D-Link)
Laptop (LAN IP is 192.168.0.101 assigned by D-Link)
So both comps have an internet access, but there's some stupid problem:
I can't access to some particular sites. For example: I can get www.msn.com, but I can't get www.hotmail.com.
I can't login to my bank account, I can't get Ebay web site. So why I can get tens of another sites?
And by the way, when I connect, let's say, desktop directly to Broadxent, everything works fine. I'm sorry for my english, but can somebody help me with configuration?
0
vadim63
Asked:
vadim63
1 Solution
 
GiacobeCommented:
Yuck!

Sound like you have a double NAT problem.  You should probably disable NAT on the DLINK router.

It also sounds like the Broadxent gateway is doing the firewall job for you and providing you with a NAT boundary.  If you removed the DLINK altogether, it should work just fine.  Replacing the DLink Router with a simple switch should give you the ports that you need.

Alternatively, you may be able to configure the Broadxent to NOT be a router... and use your DLINK as the only router/firewall/NAT device.
0
 
vadim63Author Commented:
Could you tell me, how can I configure the Broadxent to NOT be a router? Unfortunately, I can't remove DLINK, because I need a wireless connection for my laptop and this is another end of the house. I thought about possibility to turn Broadxent into some transparent thing, but I don't know how?
0
 
vadim63Author Commented:
And by the way, I checked it twice - firewalls, parent control and all that kind of blockers are disabled.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
GiacobeCommented:
I don't know that particular device's interface.  However, you should be able to disable NAT through its web interface - same place you saw all of the firewall stuff.

Failing that, you should definitely be able to disable NAT on the D-Link.  Just run NAT in one place, not two.
0
 
winkingtigerCommented:
Check to see what ports are blocked on the router or firewall(if you have one).  Look for individual ports blocked.  For example, if port 443 is blocked you will have trouble logging on to your banking website.  
0
 
danielwpcCommented:
Just disable the NAT in the Broadxent gateway and try again. Let me know what happen next.
0
 
fettigcj07Commented:
SIMPLEST solution: Your only using the Dlink for it's wirelss aspect, take the cable from the WAN port on the DLINK and plug it into a LAN port, hence allowing you to retain the wireless connection to your network and removing the obfuscation of the 2nd routing device. set each computer to your 192.168.1.X network, point em' at the ISP provided router and ignore/disable the DLink's router functionality entirely.
0
 
vadim63Author Commented:
"Alternatively, you may be able to configure the Broadxent to NOT be a router... and use your DLINK as the only router/firewall/NAT device."

Thank you, Giacobe. I just turned Broadxent into a bridge. Good idea. You were right. So now I have only DLINK as a router/firewall/NAT device, Broadxent as a regular modem and everything works fine. Thank you again. I'm happy now.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now