• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1067
  • Last Modified:

Smartlink 56K Voice Modem - No Dial tone detected

Hi guys,

I had an ESS 2839 Modem, that did not work on my linux Fedora Core 2, so I had to buy a Softlink Modem (code SL 1900).

It worked well just after I bought it, but now, it start to make me sick. When I use the ESS modem under Windows, it connects well, but when the Smartlink is used, it does not detect a Dial tone, and it makes a very high tone beep.

Though, on the ESS, the line is working properly. So, I thought the line wasn't good enough, so I bought a brand new wire, but it still didn't work out well.

On the Phone, when I exchange the two wires (polarity, may be), the phone also make the high tone beep, but while polarity is inverted, the Smartlink still doesn't detect any tone beep (and the same under Linux for this Smartlink modem).

So, what is the solution for this problem, because It's making me sick, now I'm in a CyberCafe to post this message, because the line seems to be bad. I called the phone service (on a public phone) and they sayd, they'll come to see what they can do.

But, before they come, I should have a solution ready for the modem, if it happens that the modem still doesn't detect a dial tone, even after fixing the whole phone line. The idea also is that I use Linux, rather than Windows XP, so, I need the Smartlink modem to do that.
0
e_zedeck
Asked:
e_zedeck
  • 5
  • 3
1 Solution
 
frankhelkCommented:
Hi there,

I don't know much of linux (more exactly ... close to nothing), nor have I got hands at that modem model, but from my modem experience, supposing that the modem understands the Hayes command set, I would suggest the following:

Try to find out where the modem initialisation and/or dialing string resides, then add the command X3 to it. If you're unsure where to add it in the string, please send me string(s). This command suppresses the check for the dialtone, allowing the modem to dial anyway. On the other side you won't get noticed of a dead phone line or if the phone plug falls out of the wall ... =:-)

Best regards
                           frankhelk
0
 
e_zedeckAuthor Commented:
Hi frankhelk,

I use both Windows XP & Linux (Fedora Core 2) on my system. In both OS, the result is the same, so the problem is not on the OS, but either on the phone line or the modem. And since the ESS Modem works fine with the same line, I came to think that it was the Smartlink modem wasn't good.

I put the X3 you told me, but it seems as though it didn't change. I removed also the "Wait for dial tone before dialing" setting, but it still makes the high tone beep, I don't know why. The initialisation string is ATZ. By the way, on both OS, when you ask the modem (for those ATI1, ATI2, ...), it replies well with the Smartlink stuffs and other informations (that I ignore).

Does anyone know a phone line issues in this case? because this is the first time I've gotten in to this situation.

By the way, the phone seems to be stupid. When you put off the phone's handset/receiver (don't know how to call it), and you dial, nothing happens, unless you put it down first, and the use it as normal. And when you take it off the second time, it sounds as if it resets two times.
0
 
frankhelkCommented:
Hi e_zedeck,

OK - the ATZ string (with AT as command prefix and Z as the command) tells the modem to load the NVRAM defaults.

Please try one of the following with the X3 ....

First:
------
Use any terminal program (i.e. hypertreminal, telix, or anything similar) and open the serial interface the modem is connected to. Enter the following commands, followed by the ENTER key:

ATZ
ATX3
AT&W

Exit the terminal program an try to connect.

Second:
---------

Find the modem dial string, it should read

AT<anything>DT
or
AT<anything>DP

with <anything> maybe some additional commands.

If you find a Xn sequence (were n is any number above 3) the replace it with X3
otherwise insert an X3 just before the D.

Retry to make a modem connection.

Third:
-------

Rethinking the phone line problem. Are you behind a phone installation ?

Try to add

!,,

(exactly as shown - an exclamation mark and two (maybe more) commata ) at the end of your dial string or to the beginning of your number to dial.

Fourth:
---------
Try to connect when all other appliances (phone, answering machine, etc.) is disconnected from the phone line. If that works, reconnect the appliances one by one and retry to connect after each. Maybe they interfere with that particular modem.

Fifth:
------
Let the phone company (or the phone installation service) check the line.

Best regards
                       frankhelk


0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
frankhelkCommented:
P.S.: Looks like the modem gets the same as the phone ... an initially dead line. That's why I recommended the !,, thing.

-fh
0
 
e_zedeckAuthor Commented:
I do not know why, but sometimes I get Error 777 after the First step you mentioned. Sometimes it doesn't show this error message, but still doesn't dial at all.

on step 2: I must admit, that the modem doesn't dial anything at all, normally, it should heard dialing the numbers (at least, isn't it?)

on step 3: what you mean by "behind a phone installation" ?

step 4: I have only my computer, and my phone which are connected to the line. I even removed the phone from the line, and used the line exclusivly for the modem, but it still doesn't work. Anyway, It didn't have such interferences before, why should there be ?

and by the way, why would it just won't work? before it was fine? I haven't changed anything to the line, nor the modem, and now it seems to be stupid ??? The wire is re-newed, the connection was double-checked, ... What is wrong with this modem/line? anyone have an idea of sunden change of phone line?
0
 
frankhelkCommented:
Hello e_zedeck,

> [...] but sometimes I get Error 777

Hmmm .... I don't know that error code.

> [...] it should heard dialing the numbers (at least, isn't it?)

No, it is not sure that you'll hear dial tones when you issue a dial command. The normal schedule would be

1. Open the line = "picking up the handset"

2. hear into the line for the dial tone, to ensure that
    there is a open connection to the phone company

3. Dial (maybe "pulse" in some countries, resuting in clicking sounds instead of tones)

If you're behind a phone installation (I'm native german and live in Germany - I mean a appliance that shares one or more phone lines to the telephone company among numerous "internal" phone lines whose can phone internal to each other, too) the dial tone may be different and can not be detected by the modem. The X3 tells the modem to skip the dial tone check and dial anyhow.

Just a last test before I run out of ideas - we just try to dial without any disturbing dialing software, just to test the modem itself:

With a terminal program open the serial port an issue the following commands:

AT&F
ATX0L3M1
ATDT12345678912345

On the first lines the modem should respond with "OK", after the third line the modem should issue some dial tones. To try to connect, just change the number sequence after ATDT into your ISP's dial-in number.

If even that very basic test fails, I would suspect a defect modem (i.e. struck by lightning side effect), or a defect in thelephone company's installations.

Best regards

                              frankhelk
0
 
e_zedeckAuthor Commented:
Hi everyone,

I found out, that it's the Modem which is bad. Even if I take out the phone line from the modem hole, it still make the high tone noise (may be 4000-6000Hz).

And now also, I realize, that the line was not connected in the Line before, but in the Phone; but it was working fine before this problem. So, I think it's the thunder which broke the modem.

But, I don't really believe the modem is completly broken, because it still respond quite well under the terminal. So, the connection must have been striken by the thunder; so I wonder if I can replace some of its component ?

Any idea ?
0
 
frankhelkCommented:
Hello e_zedeck,

I've had a modem killed by lightning effects once before. If you're skilled in electronics (and welding very tiny SMD things on mulitlayer circuits without destroying the board) I would suggest that you open the modem and follow the circuit parts beginning from the phone line connector to identify the dead things. A circuit diagram of the modem would help you, but might be very difficult to get hands on. Don't expect a visible damage (something burnt).

Things to replace might be anything, in the case mentioned above it was an array of treminator resistors.

If you're not that much skilled, the manufacturer of the modem might offer a repair service (is there still warranty on it ?). In example: USRobotics offers modem repair and sometimes hardware upgrade services. Check terms of the service in advance, and if possible, ask for a free quotation of the repair (send in the modem, they check for the error, maybe for a small fee, and tell you how much the repair will cost you. The repair is only performed on your OK).

Best regards

             frankhelk
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now