setting up a db and tnsnameslisterner does not appear/work

Hi,

I have tried to install Toad on a windows 2003 server with a 9.2 oracle database.

I set up the database but when I try and connect to sqlplus/toad I get ora-12154: TNS: could not resolve service name....

The only difference I can find with this setup is that when I go to deveice manager - services there is no Ora92TNSnameslistener in the list. There has also been no TNS entry in Oracle\ora92\network\admin\.

I've manually put:
PLAYP1.WORLD  =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = gbsflatest)(PORT = 1521))
    (CONNECT_DATA = (SID = PLAYP1))
  )

but still no joy.

When I try:
c:Lsnrctl status

I get lsnrctl for 32-bit windows.......
..........
starting tnslsnr: please wait..
Failed to open service <OracleOraHome92TNSListener>, error 1060
STATUS of the Listener..........
..........
The listener supports no services

any ideas what Im doing wrong?

joehodgeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joehodgeAuthor Commented:
I've set up the listener via Oracle Net configuration Assistant and I can now see the tnsnames service running,

however, when I try c:\ Lsnrctl status I get :

Service OracleOraHome92TNSListener already running
TNS-12536: TNS:operation would block
TNS-12560: TNS:protocol adapter error
 TNS-00506: Operation would block
  32-bit Windows Error: 997: Unknown error
0
joehodgeAuthor Commented:
Hi,

I have now set the oracle_sid=playp1 and I can enter sqplus via the dos prompt.

I still get an tnsnames error if I try and access the database throgh TOAD or sqlplus (via Programs - Application Development - SQPLUS)

?? Im confused??
0
-jer-Commented:
When you connect, are you typing in PLAYP1 into TOAD or are you typing PLAYP1.WORLD?

Check your sqlnet.ora file and see of your domain is defaulted, that may have something to do with it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joehodgeAuthor Commented:
Hi,

thats got it working. I put

NAMES.DEFAULT_DOMAIN = WORLD

in my sqlnet.ora

and then


PLAYP1.WORLD =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = GBSFTEST)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = PLAYP1)
     
    )

and it worked.

thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.