Cannot access Exchange server VIA Outlook Web Access from outside the local network

We have Exchange Server 2000 running on our fileserver and we're able to access it from inside the office by entering 192.168.1.25/exchange. However, if we try to access our mail from home or on the road by entering www.domain.com:1010/exchange into an Internet Explorer Address bar, we receive the following error message.

=======================
The page cannot be displayed
The page you are looking for might have been removed or had its name changed.

Please try the following:

Open the s: home page, and then look for links to the information you want.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

If you still cannot open the page, click the Internet Explorer
Search button to look for similar sites.
=========================


If we try to access an account using Firefox, we receive THIS error message

=========================
* OK Microsoft Exchange 2000 IMAP4rev1 server version 6.0.6249.0 (FILESVR.digitaloriginalinc.com) ready.
GET BAD Protocol Error: "Unidentifiable command specified".
Host: BAD Protocol Error: "Unidentifiable command specified".
User-Agent: BAD Protocol Error: "Unidentifiable command specified".
Accept: BAD Protocol Error: "Unidentifiable command specified".
Accept-Language: BAD Protocol Error: "Unidentifiable command specified".
Accept-Encoding: BAD Protocol Error: "Unidentifiable command specified".
Accept-Charset: BAD Protocol Error: "Unidentifiable command specified".
Keep-Alive: BAD Protocol Error: "Unidentifiable command specified".
Connection: BAD Protocol Error: "Unidentifiable command specified".
Cache-Control: BAD Protocol Error: "Unidentifiable command specified".
* BYE Microsoft Exchange 2000 IMAP4rev1 server version 6.0.6249.0 closing connection: invalid command limit exceeded.
=====================

We have a Linksys router with port 1010 forwarded to the Exchange server. Any ideas?
psychedelicsharkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bwinzenzCommented:
Port 1010 is not a standard port that Exchange is configured to listen on.  Internally, you are using port 80 (http), so I'm not sure why you are trying to use port 1010 externally.  What you need to do is configure your Linksys device to forward port 80 traffic (or optionally, port 443 - SSL) traffic to the Exchange server.  Once you do that, then OWA should work fine externally.

Ben
0
psychedelicsharkAuthor Commented:
Thanks Ben. That's what I figured, but I can't find any documentation on how to change the port that Exchange server listens to. I'd leave it on port 80, but we have a web server on the same subnet with Exchange Server 2003 installed. I've considered migrating, but I'm afraid it'd be just another project exploding in my face. :(

Any further suggestions? Thanks in advance.

Chris
0
SembeeCommented:
I have had nothing but hassle when trying to get Exchange to operate on any other port than 80 or 443. Remember that OWA is a very complex web application and is made up of lots of components.

If you have another web server already in place, then you really only have one option that has any chance of working, and that is to use SSL. Get a cheap certificate from FreeSSL.com and then redirect traffic on 443 only to the Exchange server. If you use a different URL and host headers (mail.domain.com for example) then anyone who enters https://www.domain.com will not end up at Exchange.

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

bwinzenzCommented:
Can I hear an AMEN?  :-)

In all seriousness, you CAN change the port that the Exchange server listens on for OWA, but results can vary.  If you do want to try and change it, on your Exchange sever, go to IIS  Manager and go to the properties of your Default Web Site.  In there, you will see the port used for TCP (regular HTTP) and SSL.  You can try and change the port in there to 1010 and see if that works, but it really isn't an elegant solution, as you will be placing the burden on your users of remembering to type in the port each time.

Ben
0
psychedelicsharkAuthor Commented:
Well. This is turning into a real adventure. :)

So far, I've learned that something else (God only knows what) is using port 1010 on the Exchange server, so I changed it to listen on port 1020 and changed the port forwarding on the router. Using Firefox, I'm in. No muss, no fuss. But using IE6, I get...

====================

The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

Please try the following:

Click the  Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
See if your Internet connection settings are being detected. You can set Microsoft Windows to examine your network and automatically discover network connection settings (if your network administrator has enabled this setting).
Click the Tools menu, and then click Internet Options.
On the Connections tab, click LAN Settings.
Select Automatically detect settings, and then click OK.
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the  Back button to try another link.

Cannot find server or DNS Error
Internet Explorer

GRRRRRRRRRR!!!!!!!!!!!
0
psychedelicsharkAuthor Commented:
Okay. For everyone's edification the IE6 problem seems to have been resolved like so:

First go to www.domain.com
Then go to www.domain.com:1020 and get error message
Finally, go to www.domain.com:1020/exchange and boom, it's fixed.

Go figure.
0
psychedelicsharkAuthor Commented:
PS- Thanks again, guys.
0
moduloCommented:
PAQed with points refunded (250)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.