• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 499
  • Last Modified:

POP3 through PIX 506E

Hi all..

As subject reads I need to have POP3 access on my PIX. I think I have been some what confused on what type of access-list I should use… please help me out here! :)


PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password [Removed] encrypted
passwd [Removed] encrypted
hostname [Removed]
domain-name [Removed]
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_in permit tcp any interface outside eq smtp
access-list outside_in permit tcp any interface outside eq www
access-list outside_in permit tcp any interface outside eq ftp
access-list outside_in permit tcp any interface outside eq ftp-data
access-list outside_in permit tcp any interface outside eq 3389
access-list outside_in permit tcp any interface outside eq 4899
access-list 101 permit ip 192.168.227.0 255.255.255.0 192.168.228.0 255.255.255.0
access-list 101 permit tcp any host 192.168.227.210 eq pop3
access-list no_nat_VPN permit ip 192.168.227.0 255.255.255.0 192.168.228.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside [Removed] 255.255.255.252
ip address inside 192.168.227.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_Pool 192.168.228.100-192.168.228.200
pdm location 192.168.227.0 255.255.255.0 inside
pdm location 192.168.227.210 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.228.0 255.255.255.0 outside
pdm location 192.168.227.211 255.255.255.255 inside
pdm location 192.168.227.212 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.227.210 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.227.210 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp 192.168.227.210 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp-data 192.168.227.210 ftp-data netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.227.210 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4899 192.168.227.210 4899 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 192.168.227.210 pop3 netmask 255.255.255.255 0 0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 [Removed] 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth (inside) host 192.168.227.212 [Removed] timeout 10
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.227.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup [Removed] address-pool VPN_Pool
vpngroup [Removed] dns-server 192.168.227.210 192.168.227.211
vpngroup [Removed] default-domain [Removed]
vpngroup [Removed] split-tunnel 101
vpngroup [Removed] idle-time 7200
vpngroup [Removed] password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn enable outside
dhcpd auto_config outside
terminal width 80
0
dsl77
Asked:
dsl77
  • 5
  • 4
1 Solution
 
grbladesCommented:
Hi dsl77,
You dont have any outbound access-list configured so everyone internally should be able to use POP3.

For inbound POP3 you have the 'static' command correct but you are missing the entry in the access list. Copy and paste the following and it should then work.

no access-list outside_in
access-list outside_in permit tcp any interface outside eq smtp
access-list outside_in permit tcp any interface outside eq www
access-list outside_in permit tcp any interface outside eq ftp
access-list outside_in permit tcp any interface outside eq ftp-data
access-list outside_in permit tcp any interface outside eq 3389
access-list outside_in permit tcp any interface outside eq 4899
access-list outside_in permit tcp any interface outside eq pop3
access-group outside_in in interface outside
0
 
dsl77Author Commented:
Hi grblades..

I have successfully added the lines you suggested.

Now I’m trying to add a pop3 account from a remote client. Outlook cannot complete the “test account settings” is just time outs when getting to the “logon server for outgoing mail (pop3)”. ‘Funny’ enough I’m getting the test mail… but can’t send/receive from the account!?
0
 
grbladesCommented:
From the client can you bring up a command prompt window and type the following commands to check connectivity:-

telnet <SERVER-IP> 110
telnet <SERVER-IP> 25

These commands attempt to connect to POP3 and SMTP consequetivly. If you are able to connect you should get a greeting message and be able to type 'quit' to exit. This will show whether it is the connection being denied or another problem.
0
Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

 
dsl77Author Commented:
No luck with port 110 ..it just quits by it self!
0
 
grbladesCommented:
That is strange. It should either connect or if the connection is blocked it should come back with a 'connection refused' error after 30 seconds or so.

Have you checked the settings on the mail server to make sure you don't have it set to limit the addresses clients can connect from.
0
 
dsl77Author Commented:
It quits after 45 seconds or so, but no error is displayed.

POP3 worked fine with our old FW. I almost sure that the POP3 settings on our Exchange server hasn’t been modified for quite some time now.

The user I trying to connect has access to the POP3 protocol, from what I can see in AD.
0
 
grbladesCommented:
Can you repost your current PIX config so I can check it again. Just off home but will be back online in about an hour and a half.
0
 
dsl77Author Commented:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password [REMOVED] encrypted
passwd [REMOVED] encrypted
hostname [REMOVED]
domain-name [REMOVED]
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_in permit tcp any interface outside eq pop3
access-list outside_in permit tcp any interface outside eq smtp
access-list outside_in permit tcp any interface outside eq www
access-list outside_in permit tcp any interface outside eq ftp
access-list outside_in permit tcp any interface outside eq ftp-data
access-list outside_in permit tcp any interface outside eq 3389
access-list outside_in permit tcp any interface outside eq 4899
access-list 101 permit ip 192.168.227.0 255.255.255.0 192.168.228.0 255.255.255.0
access-list no_nat_VPN permit ip 192.168.227.0 255.255.255.0 192.168.228.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside [REMOVED] 255.255.255.252
ip address inside 192.168.227.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_Pool 192.168.228.100-192.168.228.200
pdm location 192.168.227.0 255.255.255.0 inside
pdm location 192.168.227.210 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.228.0 255.255.255.0 outside
pdm location 192.168.227.211 255.255.255.255 inside
pdm location 192.168.227.212 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.227.210 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.227.210 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp 192.168.227.210 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp-data 192.168.227.210 ftp-data netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.227.210 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4899 192.168.227.210 4899 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 192.168.227.210 pop3 netmask 255.255.255.255 0 0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 [REMOVED] 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth (inside) host 192.168.227.212 [REMOVED] timeout 10
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.227.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup [REMOVED] address-pool VPN_Pool
vpngroup [REMOVED] dns-server 192.168.227.210 192.168.227.211
vpngroup [REMOVED] default-domain [REMOVED]
vpngroup [REMOVED] split-tunnel 101
vpngroup [REMOVED] idle-time 7200
vpngroup [REMOVED] password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn enable outside
dhcpd auto_config outside
terminal width 80
0
 
lrmooreCommented:
>The user I trying to connect
Where is this user? On the inside LAN, on a VPN connection, or outside somewhere with an Internet connection?

Can you post result of "show access-list", specifically the line that matches
   >access-list outside_in permit tcp any interface outside eq pop3 (hitcount xxx) <== need to see if hitcount is incrementing...

0
 
dsl77Author Commented:
Sorry grblades... my bad!! The pop3 connector still had its old IP address assigned, after I changed it – bingo!

Thanks for your help ;)
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now