Error deletng and renaming files on W2K server NTFS partition

Windows 2000 SP4 Server, NTFS data partition.

This is very odd, I moved some old files to a different partition using NT backup, This appeared to work correctly.
The files are installation files and I have replaced them but I cannot delete the old ones, I have tried explorer and CMD, using the 8.3 format, I have used RD and numerous other tools all of which say the file cannot be found, I can move/rename the folder that the file resides in and the reference to the file will move as well, but I cannot move the file from within the folder. The folder has the correct owner and permissions but the file although it says it has a the correct size does not have a security tab, one of them is acrobat reader- the size is correct (or it is reporting if as so) but it appears to have properties like a dos window memory settings and window size, but no security settings. I have run CHKDSK /F and /r with no problems found. It is only the files moved with this backup/restore set- nothing else.
Also CACLS does not change or show the permissions. I have tried the things shown on the rest of this site and others
mikesjnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

glenn_1984Commented:
Does  this help?
http://support.microsoft.com/default.aspx?scid=kb;en-us;320081

Did you try
del *.* from a cmd prompt?
0
mikesjnAuthor Commented:
I have tried all command lines- just found the delrp tool on microsoft.com,(This command-line tool deletes a file or directory and any associated reparse )- this works on individual files- but I have thousands of the blighters (*.* does not work- only the full filename). This could be a reparse point issue- I know they are related to remote storage. I will look it up in the morning.
Mike
0
glenn_1984Commented:
At the DOS prompt....

Rename *.* del*.*

DIR *.* /b > goodbye.bat

Edit goodbye.bat
Replace "del" with "del "  (del with a spacebar, no quotes)

Run goodbye.bat



0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

mikesjnAuthor Commented:
I cannot manipulate the file in anyway- it will not rename, delete, move, copy other than as a part of the movement of the folder- which I can rename move etc- but I cannot delete the folder as it has a file in it and it errors on not finding the file (both at the command prompt, unix prompt and in explorer)- just before leaving work I found delrp.exe which is for deleting directories and ass. reparse entries.
I have also tried unix commands using cygwin. I can delete the files using delrp.exe but I will be doing it for several months- this tool works- I just want some way of being more automated as it will not use wildcards. This is to do with the restore not the filesystem as such = I am only having problems with files from that restore, and there were several different restores to that partition. It is propablyto do with the reparse entries- (as this is what delpr is it is command line).
Thanks for your help- but I have tried every command line way of renaming, moving etc. the folder is fine, the file just does not want to know- you cannot move that file off of the partition or anything like that
0
glenn_1984Commented:
Okay...
Let's go back to goodbye.bat

Can you copy the short directory to a file...
i.e. dir *.* /b > goodbye.bat
since is not really copying the files?

Then with a macro in a word processor or text editor add the delrp.exe command to each line of the batch file.
Run the batch file.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tanelornCommented:
you could modify his code above to this...

 At the DOS prompt....


DIR *.* /b > goodbye.bat

Edit goodbye.bat
     open it in excel and insert a column with your delrp command with the appropriate spaces put your switches in colums with spaces etc... and save the file...  


Run goodbye.bat

Tanelorn  
0
thehinkCommented:
from command line, can you run a:

dir /x

and delete using the 8.3 names that this reports?


or can you reset perms on the folder and all child objects, and then propagate permissions from the folder to the files it contains?  (Properties, Security, Advanced)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.