?
Solved

"Could not perform this operation because the default mail client is not properly installed".

Posted on 2004-11-15
13
Medium Priority
?
26,395 Views
Last Modified: 2012-08-14
When clicking on a group email link on a Web Site, we get "Could not perform this operation because the default mail client is not properly installed".   It does *not* work on any of our Win98SE machines but the link works fine with Windows 2000 and XP. All machines are using IE6 and latest updates and using Outlook as part of the Office 2000 Suite.  Outlook (not OE) is set as the default email both in Internet Explorer (Tools, Options, Programs..) and Outlook itself is set to be the default email client.  We do not use Outlook Express nor are the working machines (Win2K & XP) using Outlook Express.  

It appears to be a problem with WIN98SE+IE6+the Web Site+Outlook.  Upgrading to a newer O/S is not an option.  
--------------------
When I use Firefox on the WIN98SE machine(Firefox works ok here on the Win2k machine), I get:
Object not found!
    The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.
    If you think this is a server error, please contact the webmaster
Error 404
    website name
    Mon 15 Nov 2004 10:32:33 AM GMT-6
    Apache/2.0.40 (Red Hat Linux)
-----------
Regards,
Chuck
0
Comment
Question by:chuck53
  • 3
  • 3
  • 3
  • +3
12 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 12586375
Chuck,

In windows 98 , can you check this

go to my computer --> tools --> folder options --> file types
click on URL:MailTo Protocol so that it is enabled
click on Advanced
Click on edit
under "Application used to perform action" give

the location where outlook.exe is present in the system

press OK

Now logoff the machine
log back in and check clicking the hyperlink
0
 

Author Comment

by:chuck53
ID: 12588888
Sunray_2003
Actually Win98 is a bit different than the above Windows2K approach (aren't all these Windows versions great to keep track of) but I essentially did the same thing by:

My Computer-->View-->Folder Option-->File Types
Under Registered File Types I scrolled down to URL:Mail To Protocol- The Icon to the left of it is Outlook and File Type & Opens With shown in the same box is Outlook as well.  

If I click on Edit actions, they are: Actions=open and below it is a box checked called "confirm open after download".  The settings on the Windows 98 problem machine all look similiar to the Windows 2000 machine which works.

Looks like these settings are ok.
Chuck



 
0
 
LVL 11

Accepted Solution

by:
acseven earned 2000 total points
ID: 12593196
Hi,

 Please read this thread here: http://www.newbie.org/help/messages/517.html

 Somewhere in the middle there is someone claiming to have a workaround for this, hopefully it will work for you.

Cheers ;)
ac7
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 88

Expert Comment

by:rindi
ID: 12602410
Do you get the same error message if outlook is already open and running on your system?
0
 
LVL 11

Expert Comment

by:turn123
ID: 12622249
Hi chuck53 :-),
Since we haven't heard from you for a couple of days could you please give us an update on the status of this question?
See:  http://www.experts-exchange.com/help.jsp#hi51 Thank you, turn123's friendly update request script.
Offtopic comments about this script to http://www.experts-exchange.com/Applications/Q_21188389.html please :-).
0
 

Author Comment

by:chuck53
ID: 12802141
Turn123,
thanks for waking me up on this one.  ac7 provided a link to several items which may be the explaination why this does not work.  Although I have not been able to test, if email sender's address's total more tha 70 characters don't work in Windows98, then that was the explaination for the failure, not necessary "a fix."  How would you suggest I reward the points in this case.  ac7 is welcome to them for the link info.  The real fix is to split up email address's to not total more than 70 characters if I understand the essence of the link info.  Was hoping for a different "solution."

thx. and sorry for the delay.

chuck53
0
 
LVL 11

Expert Comment

by:turn123
ID: 12803507
I think the workaround acseven linked to is this post.

Gregoire
gregoire.byrka@businessobjects.com
07/12/02     Hi All,

I found the workaround!!
From the IE (mine is 6.0): Tools\Internet Options, choose the program tab, then in the email field you should be able to choose between Outlook or Outlook express. Choose Outlook express. Then go to a web page with an email link, click to send a mail, it will open outlook express. Then return to IE and change back the default email program to Outlook and now, it works.
I hope it will work for you too ;-)
Thank you,

Greg
0
 
LVL 11

Expert Comment

by:acseven
ID: 12805017
thank you for the post, turn123.

cheers ;)
0
 

Author Comment

by:chuck53
ID: 12806087
ac7 & turn:
For the sake of accuracy and future reference by members;
The solution is the ink I am accepting provided by ac7.  This link is the one referencing:
http://www.newbie.org/help/messages/517.html.  As mentioned at the start, I am not using Outlook Express, but Outlook, so any solution relating to Outlook Express is not applicable.

The answer at the link (since there were several mentioned) was provided by :
gurmeet_bhatia@dell.com
05/22/02 stating:
“The problem is the length of the link!
If you cut it down to 25 Email addresses, you are OK (as long as each Email address is only 16 characters long)
More to the point, you can only fit 470 characters between the ' href=" ' and the closing ' " ' Try it for yourself below: the link on the left will work, the one on the right will not. I last tested this with Internet Explorer and Microsoft® Outlook® 2000”

Thx. Again,
Chuck53
0
 
LVL 11

Expert Comment

by:acseven
ID: 12807762
no problem ;)
ac7
0
 
LVL 11

Expert Comment

by:turn123
ID: 12807913
Glad you got it sorted out Chuck :-).

Now all you have to do is click the Accept button on acseven's post with the link.

Turn123
0
 
LVL 4

Expert Comment

by:kevinizelbanks
ID: 21472922
Open ie explorer click on "tools", "internet options".
Click on the "programs" tab and select another e-mail client.
Click 'apply" and "ok".

Click on "tools", "internet options".
Click on the "programs" tab and select desired e-mail client.
Click 'apply" and "ok".

Your desired e-mail client should now start when you click on a link attached to an e-mail address.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are like me and like multiple layers of protection, read on!
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question