[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 325
  • Last Modified:

Numlock On LogScreen

Hi

Using Fedora Test 3

How can I configure for the Numlock to be ON @ the login screen?


With kind regards



Ramses (x_terminat_or_3)
0
x_terminat_or_3
Asked:
x_terminat_or_3
  • 7
  • 7
1 Solution
 
wesly_chenCommented:
Hi,

   First, enable numlock on in your BIOS.

For KDE:
---
If you use the KDE desktop:
  1. Go to the Start button:
     --> Control Center --> Preferences --> Peripherals --> Keyboard
  2. Check the radio button for "Num Lock On" at KDE startup.
  *note: for some versions of KDE you have to click an Advanced tab.
  3. Log out and Log back in (to restart the X environment)
---

For Gnome:
---
1. Download this very small program: setnumlock.tar.gz
    a) here is the link --> ftp://ftp.silug.org/pub/ltsp/setnumlock.tar.gz     
    NOTE: I tested on Redhat 8/9 (probably works on other distributions too)

    b) I suggest you create a directory named num-on to download the file to.
       type command: mkdir num-on

    c) When you have finished the download:
       cd (change directory) to num-on (or wherever you downloaded the file)
       gzip -d setnumlock.tar.gz
       tar xvf setnumlock.tar
       cd setnumlock
       type "make"
       then type "make install"

  Make install has now created /usr/bin/setnumlock
  (a very small program that turns numlock on)  
       
2. Now you need to run this program whenever you log in:
   Click the start button and go to:
   --> Preferences --> More Preferences --> Session  
   Click the Start Up Programs tab.  
   Click the Add button.  
   Browse to /usr/bin/setnumlock  (or type in /usr/bin/setnumlock)
   Click OK.
   Logout and Log back in (to restart the X server)
----

Regards,

Wesly
0
 
x_terminat_or_3Author Commented:
It doesn't compile

make
gcc    -c -o Numlock.o Numlock.c
Numlock.c:2:34: X11/extensions/XTest.h: No such file or directory
Numlock.c:3:24: X11/keysym.h: No such file or directory
Numlock.c: In function `main':
Numlock.c:6: error: `Display' undeclared (first use in this function)
Numlock.c:6: error: (Each undeclared identifier is reported only once
Numlock.c:6: error: for each function it appears in.)
Numlock.c:6: error: `disp' undeclared (first use in this function)
Numlock.c:6: error: `NULL' undeclared (first use in this function)
Numlock.c:9: error: `XK_Num_Lock' undeclared (first use in this function)
Numlock.c:9: error: `True' undeclared (first use in this function)
Numlock.c:9: error: `CurrentTime' undeclared (first use in this function)
Numlock.c:10: error: `False' undeclared (first use in this function)
make: *** [Numlock.o] Error 1
0
 
wesly_chenCommented:
Hi,

> Numlock.c:2:34: X11/extensions/XTest.h: No such file or directory
> Numlock.c:3:24: X11/keysym.h: No such file or directory

  Did you have XFree86-devel and kernel-sources package installed? Use the following commands to check:
# rpm -q XFree86-devel
# rpm -q kernel-sources

  If not, please intall them from the FC test 3 CDs.

Wesly
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
x_terminat_or_3Author Commented:
I can't...
0
 
x_terminat_or_3Author Commented:
Maybe if I try via RHN update...
0
 
wesly_chenCommented:
Hi,

You can try
# apt-get install XFree86-devel
# apt-get install kernel-sources

Wesly
0
 
wesly_chenCommented:
Oh, do them below first:
# apt-cache search XFree86-devel
# apt-cache serach kernel-sources

Wesly
0
 
x_terminat_or_3Author Commented:
apt-cache: command not found
apt-get: command not found
apt: command not found


sorry
0
 
wesly_chenCommented:
Well,
try to download XFree86-devel and kernel-sources from the following URL:
http://download.fedora.redhat.com/pub/fedora/linux/core/test/

I'm not sure which version you have since Fedora Core 3 have been released.

Wesly
0
 
x_terminat_or_3Author Commented:
Ok Wesley, we are getting closer!

The numlock turns on AFTER login.  What I need it to do is turn on BEFORE login.  



Ramses
0
 
x_terminat_or_3Author Commented:
C'mon Wesly... don't give up just yet.  I managed to compile the num-on, and I did what you said but the thing is called AFTER login and I'm asking the users to have a pass with numbers in it so I want to turn the numlock on BEFORE login.  Is this possible or not?



Ramses
0
 
wesly_chenCommented:
Hi,

   I'm not giving it up. I just haven't figured it out. I'm reading some Xwindow architecture articles...

Wesly
0
 
wesly_chenCommented:
Hi,

   I found another one works as you wish:
http://www.mike-devlin.com/downloads/numlockx-1.0.tar.gz
# tar -xvzf numlockx-1.0.tar.gz
then:
# cd numlockx-1.0
# ./configure
# make
# make install
# make xsetup
# make xinitrc

For more information, please check the following URL:
http://www.mike-devlin.com/linux/README-numlockx.htm

By the way, please reverse what you have done for "setnumlock"
----
Click the start button and go to:
   --> Preferences --> More Preferences --> Session  
   Click the Start Up Programs tab.
Delete /usr/bin/setnumlock
----

Regards,

Wesly
0
 
x_terminat_or_3Author Commented:
You did it!


Way to go



Thanks Wes
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now