Broadband VPN Help

Right, so me and a friend are trying to setup a VPN between our two Broadband connections.
With both have routers (Netgear DM602 and Thomson Speedtouch 510 - don't think they are VPN capable and not sure if this is a major issue - and must add that neither of us can afford to change routers at this time)

We have Win 2K servers behind the routers and I have forwarded port 1723 on the router to the IP of the servers.

We can setup RRAS on the servers and basically when someone connects e.g. without RRAS setup it returns an error msg straight away, if we configure RRAS then it tries to verify a username and password and then takes a while before returning a connection error.

We have made sure that silly things like the username and password are correct and that they have dialin permissions on Active Directory

Basically there are a few points I'm not sure about (well quite a lot actually as I am a total newbie when it comes to VPN's)
1) GRE - what is it? and do I need it (because we can't find anything to do with this protocol on either of the routers - just the ability to forward a specified port to a given IP address)
2)1 or 2 NIC's in the server. Is it needed? because RRAS won't let me setup the connection on the LAN (gives me 2 options. Either no IP address or use the NIC that is currently installed and that one isn't allowed)
3) I have read lots of documentation on VPN's from Microsoft etc but nothing that is specific to setting it up between to ADSL Broadband connections with basic ADSL Routers.

I have given this question (what I think is) a lot of points because myself and my friend are really in need of some Newbish help on this subject. Once we get something like this setup we can work on it and build on our skills.

Many thanks in advance for any replies


LVL 1
DaleHarrisonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

blin2000Commented:
I wish you posted the error code so taht we can have more details about the issue. Assuming you receive the error 721, this is GRE or ip protocol 47 issue. That mean the VPN doesn't pass through the ip protocol 47. The following quotations from http://www.chicagotech.net may help.

How to setup VPN on w2k server with one NIC

Symptoms: When attempting to create VPN on w2k server with one NIC, you may receive "You have chosen the last available connection as the Internet connection. A VPN server required that one connection be used as the private network connection" if you select the NIC.

1. You should highlight No internet connection instead of the NIC or LAN connection.
2. You may try "Manually configured server option".


Error 721: Remote PPP peer or computer is not responding. If you have tried many thing other people suggest like rebooting, reloading hardware and re-installing the VPN or dial in connection, you still get the same problem. I will suggest to check the router settings and make sure TCP Port 1723, IP Protocol 47 (GRE) are opened. Also make sure that the router has the PPTP enabled and not firewall block the traffic. On the RAS server, check the DHCP settings.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
grbladesCommented:
Hi DaleHarrison,
Yes you do need GRE to be forwarded. If you enable the 'PPTP Passthru' option in your router (if you have it) this may get it working. If it still does not work then you could try upgrading the firmware on the router. It is fairly likly that you wont be able to do it with these routers.
0
DaleHarrisonAuthor Commented:
Thanks for the help guys, I will take it from there then that if I can't forward GRE then I won't be able to do it with these routers?
I have the latest firmware (from what I gather) on my router and there is no option for this anywhere to be seen :(

Blin2000 - thanks for your input, I had a browse round your website. Really helpful info there - pointed it out to a couple of friends over here and they like it too.

0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

DaleHarrisonAuthor Commented:
One other thing, would it be an idea to put my server running the VPN in the router as the DMZ??
0
blin2000Commented:
yes, it may work.
0
grbladesCommented:
Yes first try it with PPTP Passthru enabled.
If that does not work then putting it in the DMZ should work but you will loose all the firewall features of the router.
0
DaleHarrisonAuthor Commented:
yes that is what I thought gr, kinda unsecure method of getting it working!
Thanks for the input guys
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.