[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4165
  • Last Modified:

Windows Media Player 10 - has sound, no picture when playing WMV 9 file. Help!

I have 2 computers, both Windows XP.  One of the machines plays the wmv files just fine.  The other one will have sound but no picture.  I upgraded from Windows Media Player 9 to 10 just to make sure, and still the same thing.  I reinstalled the video drivers in case it was a conflict that way, yet still no picture.

I noticed that when I plugged my notebook into a projector, the picture did not transfer to the projector, only played on the notebook computer.  It showed the Windows Media Player outline, but no picture, yet it did on the screen.  So I wonder if something similiar is happening with the graphics card and the CRT monitor.

I downloaded the codecs from Microsoft and installed those just in case it was corrupt, still no picture.  All Windows XP updates have been done including service pack 2.  My other machine has all updates done also and it still plays fine, so that's not it.

Anyone have some feedback or suggestions to try?
0
perkley
Asked:
perkley
1 Solution
 
vladonatorCommented:
I would try adjusting the resolution size, try 640x480 first, if it works try increasing size.
it could also be the color quality, try changing it from 32bit to 16bit color. Might need to reboot when changing color quality.
Both of these seeting can be found by:
Clicking Start ---> Control Panel ---> Display ---> Click Settings Tab.
0
 
perkleyAuthor Commented:
Good thought . . . but didn't help it.  I tried 800x600 16 Bit 75 Mhz Refresh.  That's the lowest I could go on everything.  It is the motherboard graphics card (VIA/S3G KM400/KN400) from a Shuttle computer.  I am wondering if that is the problem.  I have another shuttle, but it has a separate graphics card from MSI, and it plays the video fine.  Maybe I will go check the FAQ's from VIA.
0
 
tosh9iiiCommented:
Maybe you need "more" codecs:

http://fileforum.betanews.com/detail/1058342510/1
http://fileforum.betanews.com/detail/1094057842/3

By the way, try it using a different player just to help narrow down the problem:

http://fileforum.betanews.com/detail/1034861925/1
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
vladonatorCommented:
If you hook up the crt monitor to the notebook does the media player work on it?
0
 
vladonatorCommented:
tosh9iii, it wont be codec related since it plays fine on his notebook.
0
 
perkleyAuthor Commented:
What other player would play wmv files, to test with?

As for the notebook, that is not really the issue, it was mainly that it won't play on the shuttle computer.  It plays fine on the notebook, I am guessing it is a Windows Media Player security to not allow it to play to Analog so you can't record things.  Don't know though.  We did have another computer that played Windows Media fine to the TV, but that was with a ATI TV Card.
0
 
vladonatorCommented:
If it doesnt play at all on the shuttle computer then it is probably codec related, what type of file is it? .avi .mpg .wmv?
Is it a DVD? if it is do you have Powerdvd or Windvd installed?
0
 
perkleyAuthor Commented:
It is a Windows Media 9 (.wmv) file.  I have also tried the news sites and they do the same thing, it plays fine, no errors, sound is normal, but no picture.  I have also tried playing .avi, .mpg, they do the same thing, sound, but no picture.

I don't have WinDVD or PowerDVD installed on this particular machine, but I suppose I could give that a try.
0
 
vladonatorCommented:
just noticed you said wmv :)

I would check your assocciations settings in Windows Media Player,

open media player ---> Tools ---> Options ---> File Types.

The first three should be:
Windows Media file
Windows Media audio
Windows Media Video

and they should have white checkmarks by them if they dont, check them then hit apply, then try video again.

0
 
perkleyAuthor Commented:
I checked the File Types and they are listed and checked, so that's not the problem.  I am really thinking it is the video card and the Windows Media Player Security programming.  Who knows, I will try graphics card in the machine and see if it plays, and if so, it is not a codec or Windows problem, but a hardware issue.
0
 
tymesCommented:
It is actually likely to be codec or mixer (such as a subtitler) related because some other installed codec could be installed with a higher priority and is being used.

The issue you described as pretains to the laptop and a second display (projector) is usually evident when you have multiple displays.  The video will only appear on the primary display.  You can change the primary display or disable overlays in the control panel display.  Overlays is the keyword there.

To dismiss the video drivers as the culprit, you can turn the graphic acceleration down to 0 (display troubleshooting).  There are also video acceleration settings in Media Player that you can also drop to 0.  And then in the Advanced options, turn on or off the internal video mixing render and disable overlays there.


To actually do some troubleshooting find a standard WMV (the first one you find on windowsmedia.com for instance, not something you got filesharing or download from some thirdrate site).  That will generic and that should work.  Test it.  Blah.  Now start looking for and uninstalling any codecs you find.  Start with divx, ffdshow, xvid, matroskova, vobsob, any subtitlers blah blah blah (you can reinstall them later).  Uninstall one, close and reopen replay the standard WMV.

I myself normally use http://www.inmatrix.com/zplayer/ to play videos.  One feature that is may prove useful is that you can view the filter properties (right click on video and Filter Properties, Graph Information) and see what spilters, decoders, mixers, etc are being used when a video is playing.  Comparing that on the two machines will show you the differences.  You also can go into the configuration and register and unregister codecs in there (don't do it you'll only mess things up further).  The registered filter manager also lets you see what codecs are installed and view and change the priorties etc.

0
 
perkleyAuthor Commented:
That was the most useful information I have heard yet.  You seem to really understand what is going on in the background.  I turned down the acceleration just 1 notch in Windows Media options and it plays fine now.  Thank you so much.  I will check out that player also, sounds like a good one.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now