Multiple servers to share domain space

This is very similar to a recent question I asked, but I can't quite get the solution to work at a similar site where we're adding an exchange server to a network with a Netmail server.  Here's what I have:

Two mail servers are internal to the organization.  Public MX records point mail to a NetMail server.  I'm adding an Exchange 2003 server for a few users.  The server name is exchange.  I've set the Netmail Server to forward undeliverable mail to exchange.domain.com.

I read through MS KB article http://support.microsoft.com/default.aspx?kbid=319759 although it says that it's for sending messages to contactw whose user accounts exist in Active Directlry but whose e-mail addresses point to a foreign messaging system that shares the same SMTP domain name space as the Exchange server.  That's close, but I don't want to have to add all the users to Active Directory that are on the Netmail server.  What I'd like to do is get the Exchange server just send all of it's mail directly to the Netmail server for resolution.  Then, for the few addresses that are on Exchange instead of Netmail, Netmail should forward it to exchange (since it's undeliverable) which should receive and deliver it.

My first step was to add exchange.domain.com to the default recipient policy, but it said it wouldn't let me since exchange was a server name.  So I added a DNS entry for mail2.domain.com and pointed it to the exchange server, then set the NetMail server to forward there.  So I now have a single polidy, the default:
ticked SMTP @mail2.domain.com (bold for default)
ticked smtp @comain.com - not set as responsible for all mail to this domain
tickex X400  - default stuff here

I also added a connector called "netmail connector" and set it to forward all mail through this connector to the smart host: <ip address of my Netmail server> and added EXCHANGE under the local bridgeheads.  Under address space, I added precisionservice.com.

Well, none of this worked.
Recieving:
* from the outside I get "Delivery to the following recipients failed testuser@mail2.domain.com."
* from the inside (from a Netmail account) - nothing -- no delivery, no bounce message
Sending:
Exchange users can send to accounts on the Netmail server (user1@domain.com) and to outside addresses without problem.

I'm still missing something.  That KB article had info on adding @local as a domain.  Is that part of this puzzle?

Also, when making changes in this area of Exchange I've been stopping and starting the services for Exchange Routing Service and the SMTP service.  Is that correct, or are there other steps?

I'm also leaving the users on exchange with an email address of user@domain.com (not user@mail2.domain.com).

Thanks.
pcspcsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pcspcsAuthor Commented:
Okay, a reboot and further testing, it appears that things are pretty much working to both internal addresses on the exchange and Netmail server and to external addresses.  I'm down to one last problem:

When I create new accounts, their primary SMTP address is mail2.domain.com, which means that it gets used as the reply-to address.  I want it to just be domain.com.  I can fix it for each user by editing their user properties in Active Directory users, but I'd like for it to default to this.  It seems that I could fix this by editing the default (and only) recipient policy and making domain.com primary.  But if I make it primary, it also makes it authoritative for that domain.  Once it does that I assume that it won't pass mail to unknown addresses through the connector that forwards it to Netmail, so I won't be able to send to other users on the same domain but that are not on the Exchange server, right?

My last problem relates to another domain.  We have multiple domains hostes on the Netmail server.  Using one for an example (hosteddomain.com) I find that I can send from it to the exchange account I've been working with above (testuser@domain.com), but not the other way around.  No bounce message - it just doesn't arrive.
0
David WilhoitSenior Consultant, ExchangeCommented:
"It seems that I could fix this by editing the default (and only) recipient policy and making domain.com primary.  But if I make it primary, it also makes it authoritative for that domain.  Once it does that I assume that it won't pass mail to unknown addresses through the connector that forwards it to Netmail, so I won't be able to send to other users on the same domain but that are not on the Exchange server, right?"

On the messages tab, under the properties of the default SMTP server, you should be able to forward all unresolved recipients to host. that means any address unresolved for the SMTP domain, would get sent to the IP or servername you specify in that field.

D
0
pcspcsAuthor Commented:
Kidego,

If I do that then I'll end up creating a loop for addresses that really cannot be resolved.  Remember, incoming mail comes in first to the Netmail server.  If the name can't be resolved there, then it sends it to exchange.  If I set exchange to sent all unresolved recipients back to Netmail I'll create a loop.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

David WilhoitSenior Consultant, ExchangeCommented:
ok then, here's a trick:
Use ADModify to change the primary SMTP address on the user objects in Exchange 2003. Then clear the checkbox "Update this object with recipient policy" (something like that), and then the primary SMTP address can be domain.com, which is their reply address, but mail2.domain.com still lives on the user object. When you create a new E2K3 mailbox, you'll need to let the RUS stamp it originally, but then you can uncheck the box, and change the primary SMTP address for the object.

D
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pcspcsAuthor Commented:
Well that's pretty much what I'm doing now - changing the primary address for the user after I create them and unchecking the box.  My question is whether or not there's a way to have this be the default for new users so I don't have to remember to go edit this for each user after I add them.  In the KB article noted above they were creating an @local SMTP account, but didn't explain why.  Would that help or can someone explain what that does?  They also created a policy other then the default that was pretty much the opposite settings.
0
David WilhoitSenior Consultant, ExchangeCommented:
the article is written from the standpoint that Exchange is your frontline, not NetMail, and I think that's where the issue lies. That article works, if you remove the message forwarding in Exchange. Have you tried the SMTP connector, and then changed the mail2.domain.com over to domain.com? Maybe...I wish I was at home to test this one...

D
0
pcspcsAuthor Commented:
Yeah, I had luck with that article in a similar situation recently.  It might help to adapt it if I understood what the purpose was for adding the @local part to the recipient policy.  Any ideas?
0
David WilhoitSenior Consultant, ExchangeCommented:
the @local part gives the message a second chance to be delivered, if the first SMTP address is not resolved :)

D
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.