Problem with Tora in Fedora Linux

Hi  friends,

When I open Tora, I immediately get the following error:

"No available connection provider, plugins probably missing"

Can anyone here help out on this?  I'm a Linux newbie.  I don't know how to fix this.

Thank you so much,


Jazon from Jacksonville, FL

LVL 3
piratepatrolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Tora? Is it Toolkit for Oracle?
Did you have Oracle/MySQL or some sort database installed and running?
If not, then please make sure the database is installed and running first.

Regards,

Wesly

0
piratepatrolAuthor Commented:
Hi Wesly,

I have MySQL installed and running.  I can access MySQL using the terminal.  Also, I have every single component of "Database Server" (in the Add/Remove Programs) installed.  Maybe there's a service I need to start to make Tora work?

Jazon
0
wesly_chenCommented:
Hi,

  You probably need to install those packages:
qt-ODBC
qt-PostgreSQL
qt-MySQL    <=== This one for MySQL

Wesly
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

piratepatrolAuthor Commented:
I have all three of those installed.  In "Services", I have PostgreSQL and MySQL running.  I don't see ODBC listed.  Is it supposed to be listed there?

Also, I tried this:  In the "Add/Remove Applications", I went to SQL Database Server and chose Details.  I tried to uninstall "unixODBC" by unchecking it.  When I clicked on update, I got the following error:

Packages Not Found
libodbc.so.1
libodbcpsql.so.2

Man, being a Linux newbie makes so helpless in fixing this stuff.  Your help will be so valuable.  Thanks in advance.


Jazon
0
wesly_chenCommented:
Hi,

   Could you do
# rpm -qa | grep -i mysql
and provide the result?

Wesly
0
piratepatrolAuthor Commented:
Hi Wesly,

# rpm -qa | grep -i mysql

perl-DBD-MySQL-2.9003-4
mod_auth_mysql-20030510-4.1
mysql-3.23.58-9
php-mysql-4.3.4-11
mysql-server-3.23.58-9
0
wesly_chenCommented:
> # rpm -qa | grep -i mysql
>
> perl-DBD-MySQL-2.9003-4
> mod_auth_mysql-20030510-4.1
> mysql-3.23.58-9
> php-mysql-4.3.4-11
> mysql-server-3.23.58-9

Then you don't have plug-in "qt-MySQL" installed. Why you said you have it?
Anyway, please install "qt-mysql" because it's needed for Tora.

Wesly
0
piratepatrolAuthor Commented:
I have everything checked in the "Add/Remove Applications" under "SQL Database Server".  Is qt-MySQL located under a different category?  Or will I need to download if from the Internet.  My friend chose the "Everything" option during installation, and his Tora works.  I didn't chose Everything, but everything under SQL Database Server is checked.  Please advice.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
piratepatrolAuthor Commented:
Thanks, Wesly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.