[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12841
  • Last Modified:

stuck at 127GB on 160GB HDD

hi all,

i'm pretty desperate on this, thats why the points are max.

I bought a 160GB HDD, I intend to use it as external storage for my laptop.
after a few months of usage, it got full. after some checking I realize that the whole files inside only counts for 127GB.

I checked the internet, and got this: http://support.microsoft.com/default.aspx?scid=kb;en-us;303013
[QUOTE]
By default, the original release version of Windows XP Home Edition and of Windows XP Professional do not have 48-bit LBA support. Your computer must meet the following requirements to use 48-bit LBA ATAPI support:
•      48-bit LBA-compatible BIOS.
•      137-GB hard disk or larger.
•      You must have Windows XP SP1 installed.
[/QUOTE]
I checked all of them, and all is good.
- my BIOS, PhoenixBIOS 4 Release 6.0 has support for >137GB HDD (check this out: http://www.eltan.com/brochures/20040226/phoenix_bios_4_6.pdf)
- my HDD is 160GB (obvious)
- I have WinXP with SP1 installed
plus, I have the ATAPI driver as explained in the microsoft link above. but, the problem remains.

anyone knows the solution to my problem?

regards,
crocco

Some things to note maybe:
- when I bought it, I remember having a problem with formatting the drive for the first time, so I brought it back to the store, and ask them to format them for me. It worked normal and I took it home. At home, it works too, and showing the capacity of 152 GB total space (until now) thats why I dont do anything at that point.
- I use the external casing (with USB2.0) of my old CD-RW from Plextor (PX-W4012TU), since I thought that time that it would be no problem, and saves me some money as well. But from browsing the internet about this problem, I saw sometimes the "ATA controller" is also mentioned. Might this be the problem?
0
crocco
Asked:
crocco
  • 5
  • 3
  • 3
  • +5
2 Solutions
 
nobusCommented:
Which drive is it ? Look here : (for a WD)

http://wdc.custhelp.com/                                    Lifeguard 137 Gb limit
0
 
Cyber-DudeCommented:
If your drive is fully recognized by BIOS than naturally, it is a software issue. I would suggest (that is based on the fact you checked everything within Windows and everything is truely OK) that the drive was initially recognized by the OS as 137GB thus you may have to expand the drive's recognition using the 'diskpart' utility within the command prompt:

Go to the following link and follow the steps described there:
http://www.winnetmag.com/Article/ArticleID/38362/38362.html

PS
Let me know if theres anything misaccurate....

Good luck

Cyber
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Cyber-DudeCommented:
Poof....

I need a full refresh system here...

:)

Cyber
0
 
rindiCommented:
Open "Administrative Tools, Computer Management". Select "Disk Management". now select the disk which only has 127GB. Does it show you an "unused" part of this disk? If so, just right-click on that part and select the option you want. You should be able to create a new partition, format it and assign a drive letter. If, on the other hand you want the whole disk to show up as one drive letter, and you don't have a product like partition magic (symantec), which allows you to manipulate partitions without changing the data on it, you should first save all your important data on that drive, then delete the current Partition. Now you should be able to format the complete drive as one partition and assign it an own drive letter.
0
 
muhalokCommented:
Probably the external casing change will be good - it costs very little and it will be much smaller than your current 5 1/4 casing (only 3.5 inch).
0
 
tonyteriCommented:
I've had this issue.  
There is a registry modification that must be done.  

Check your vendors web site for the installation software for the HD, or go to support.microsoft.com  and type in your vendor make and model of the hard drive.  I have found soultions there on how to modify the registry to accept the HD.

0
 
icemanwolCommented:
The most likely problem is your externel haddrive caseing has the 127GB limit but your computer dose not.  See, externel harddrive caseings are basicly externel harddrive controllers and the controller on the caseing is maxed out at 127gb.  Try checking the manufatures web site of the caseing and check to see if they have a possible Firmware update for your caseing or possibly updated drives for XP that will solve this issue.  If you cannot find any of this, your only chooise is to get a new caseing without this limit and use that.  I hope this solves your issue.
Tom S.
0
 
croccoAuthor Commented:
Thx all for the comments!

@nobus: the drive is Maxtor DiamondMax Plus 9 (6Y160PO)

@Cyber-Dude: I'm not sure if I should use your link, since its designated for Windows 2000, right?

@rindi: Disk Management shows the disk as one solid bar ( Z: | 152.66 GB NTFS | Healthy (Active) ). btw, deleting the partition to reformat is the last thing on my mind.

@tonyteri: If you meant EnableBigLba @ HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Atapi\Parameters\  then the value is 1.
if not, I would love to hear more from you.

@muhalok + icemanwol (about casing): actually, I got stronger feeling that the casing causing the problem, since it was not designed (not stated anyway) to support HDD (as big as 160GB). but about controller, isnt that should only control the transfer speed? and not the capacity of the HDD itself?
maybe somebody can give me more info about this "controller"? (I'm not sure what/which type)
0
 
Cyber-DudeCommented:
crocco,
The 'diskpart' is a utility which is in Windows 200/XP/2003 so, if you are wondering wehther it is the same utility - the answer is Yes.
You can use that utility within Windows XP the same way use use it in Windows 2000.

Good luck

Cyber
0
 
Cyber-DudeCommented:
Also, try the Maxtor MaxBlast which is a small drive management and disgnostics software. I think it might be helpful:
http://www.maxtor.com/portal/site/Maxtor/?epi_menuItemID=3c67e325e0a6b1f6294198b091346068&epi_menuID=976d37cd478c5826433f226075b46068&epi_baseMenuID=976d37cd478c5826433f226075b46068&channelpath=/en_us/Support/Software%20Downloads/ATA%20Hard%20Drives&downloadID=58

(award nobus as well for asking for the HD model question in the first place)

Good luck

Cyber
0
 
rindiCommented:
Since diskmanager shows the whole disk (156GB) in one solid, good, bar, it looks as if everythings is OK. Your disk is fully recognized and also fully usable.
There only seems to be another (small) problem somewhere, a part of your OS doesn't return the correct size. I suggest you run a windowsupdate. Since the original
Windows XP version had this barrior of max 127GB it is likely that not everything has yet been patched correctly. In what program / display did those 127 GB
show up?
0
 
icemanwolCommented:
Well, the controller controls the speed and the size of the HDD, this is why you are able to get a newer serial ATA or ATA 133mb/ps that supports drives larger then the 127GB limit.  See, the controller.  You can get controllers that need the system bios for there other functions, but thoughs are really not controllers.  Most ATA controllers have there own internel bios if it's either a externel harddrive caseing or a PCI plugin card.  Here are a few sites that talk about the limit
http://www.48bitlba.com/pciidecontrollers.htm


If you give me the brand name/model of the casing i can take a look to see if i can find a firmware update
0
 
croccoAuthor Commented:
@Cyber-Dude: I have some concern of using the tool of your preference, since I dont have any experience with it,
and I havent heard many people (in fact, none at all) using or recommending the tool. not saying anything about the tool itself though.
I want to try, but I really dont like playing it with HDD filled with my files (and please, lets not go to what files are there :) ).

@rindi: I believe I have fulfill windows requirement  about this issue.
btw, it was the Windows Explorer showing this (Size: 127GB Size on Disk: 136 billion bytes).

@icemanwol: as I said in my question, its the casing of CD-RW from Plextor (PX-W4012TU, also known as PlexWriter 40/12/40U)
Yes, its NOT originally made for HDD, I just thought it would work just the same. so I took out the CD-RW drive inside, put the HDD instead.
other than this problem I have now, everything just worked fine all these times.
And about the firmware, from plextor website I only get the firmware for the CD-RW drive instead (PX-W4012TA),
but if you can help finding in another place, I would really be thankful.

0
 
Cyber-DudeCommented:
You have nothing to be afraid of.
True, it is a very powerful utility but, as long as you you dont use commands like 'clean' or 'delete', there is nothing to fear from. Take in mind that this is a formal Microsoft utility (though I know some professionals may will say "NOW we have something to be afraid of" - just kidding). What about the Maxtor utility I linked you to? Since you are using DiamondMax hard drive, this utility is suitable for that drive, allowing you to analyze and examine the drive it-self. It also has the ability to partition (allowing you to see if there are any other partitions on the drive).

Good luck

Cyber
0
 
nobusCommented:
i recommend a full backup before playing with disk formats; if ANYTHING goes wrong, you're stuck.
0
 
rindiCommented:
In that case it looks as if it is a bug in windows explorer not correctly showing the size, or windows explorer didn't get upgraded when you did the windowsupdate.

Right Click your windows explorer (C:\Windows\explorer.exe) and click on properties. Select the "version" tab, Now select the "File Version" and tell us what is
displayed under "value".
0
 
happispiderCommented:
Some drives have a jumper which limits their capacity somehow.

http://ev1.ranish.com/~mranish/part/part244.zip

Make a boot disk, boot from it, then under "Ending" select the cylinder value and increase it until an error occurs.  Then decrease the value back so that the error goes away.  Then press F2 to save or ESC to exit and select "Yes" if there's a warning.

The program might show the disk partition in red with an error because of compatibility issues.

In Win2k there's a repair option so try:  Boot from WinXP install CD and choose R for repair, then C for console, then FORMAT C:<enter>.  FIXMBR, FIXBOOT, and CHKDSK could help too but I doubt it.  CHKDSK is in the CD's i386 folder.

If you work on an extended partition then you need to change the values of the Extended partition and the partitions within.

Win2k's (or WinXP's?) text-mode installation program doesn't always manage partitions properly and creates extended partitions.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 5
  • 3
  • 3
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now