Windows-Delayed Write Failed Error

Hi
Two W2K machines with SP4 are having the windows-delayed write failed problem when working on files over the network on our file server.  The file server is W2K server sp4.
In event viewer the problems's Source:MRxSmb Event ID: 50.
Nothing appears in the event viewer of the server and I have tested the files from other pc's and they open and save fine.  
The problem also seems to be intermittent here is the full error "Windows was unable to save all the data for the file \L... .  The data has been lost.  This error may be caused by a failure of your computer hardware or netwotk connection.  Please try to save this file elsewhere."
Of course there is plenty of space on both machines and on the file server.  I have found quite a few douments on this error.  The documents on the windows website suggest this fault was fixed with sp4 which is on both machines.  I tried several of the fixes like disabling the write cache on each machine, it is already disabled on the server.  Also from knowledge base article ID:321733 I tried the workaround on the enablesecurity signature and found it was at this value already, ths hotfix is included in sp4.
Any help would be very appreciated.
Darragh
darraghkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott_WillcocksCommented:
I have seen this on a couple of machine in my organisation usually when loading autocad drawings now there is two problems to do with our pc.

1: there local temp folder c:\documents and settings\local settings\temp
                                     c:\documents and settings\local settings\temporary internet

were quite full they had set autocad to use local folder temp as it's temp and it had become quite full. So I needed to empty these folders to reduce the users profile and in the internet browser settings reduce the size of the temporary internet folder settings so it didn't get so full. Becvause these had a lot of files 10's of thousands windows was having problems creating new temp files.

2: Client network settings needed adjusting on our network we have IP telephones which were causing problems we needed to set the phones to a fixed speed 100 full duplex on the telephone switch and computer as the autonegotiate was not working to well also on the client network driver settings there is a setting on there called flow contol which is set to on as default depending on your network where you are working are you gigabit 100 meg or 10 meg if 100 meg and above turn this off as it causies large files to be broken into smaller packages and has caused the same problem on our network.

The error message is due to packets being dropped and you will need to check your network cards and settings as they will need to be set up properly.

It is the client machines setting causing this if you go to the affected clients and set there network card up properly they should be ok  
0
darraghkAuthor Commented:
Hi thanks for your help
On the two pc's with the problem the temp folders are relatively small only a couple of MB's and the profiles are stored locally.  

Also only one of the computers's runs through an i.p. phone.  I am trying to recreate the problem on the computer with the i.p. phone then I can remove it and test it further.  

The intermittent nature of the problem is making it difficult to narrow down.  
0
Scott_WillcocksCommented:
if one has an IP phone on the switch port set to 100 meg full duplex as well as the phone itself and on the pc set the network card settings to 100 full duplex it seem on our system to be the auto negotiate doesn't work to well with ip phones in place the PC queries phone phone queries switch and it just seems to randomly try and switch network speeds and switch off flow control.

On the PC without you need to do the exact opposite set to autonegotiate on the switch and pc and let it decide but do turn flow control off you only need it if your network runs at odd speeds.

I've had fun playing with these ip telephones heres a tip as well if you install an IP phone and it downloads a new flash bios wait till it's finished it will reboot the phone and you will then need to enter the phone settings and set it up as 100 meg full duplex, the guys from our network team installed the phones power on set the settings on the phones then it would download the flash update and rebbot at which stage the phones would set to out the box standard which is to auto  detect settings you then need to either as it reboot catch it and set it up or reboot then set up the phones have fun.



0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Scott_WillcocksCommented:
oh yeah the IP phones we have are mitel and we started getting a lot of failures oh about a year and a bit after they were installed just after the warranty expires. I would definately look at the phone on the one with the ip phone
0
darraghkAuthor Commented:
I have also tried large pings 35000 bytes from client to server and vice versa.  There is an occassional time out usually after 50-60 pings 95% get through.
0
darraghkAuthor Commented:
Sorry 1% failure rate after 450 pings from both sides.
0
Scott_WillcocksCommented:
there you have it you got a network problem some where could be cables phone switch happy troubleshooting
0
darraghkAuthor Commented:
I have removed the i.p. phone which seemed to solve one of the pcs and replaced a cable on the other
which is working fine so far I'll award the points after a bit more testing.  We will be implementing voip in a few weeks what's the best way to set the port speed. I was going to set auto on the pc's and 100 duplex on the switch.
Tks for the help
Darragh
0
Scott_WillcocksCommented:
we have found that the best way to set is to set the switch telephone and pc to 100 meg full duplex all of them and turn off flow control on the clients pc. We found that there is a problem with our dells that we built in that if you use the standard windows 2000 disk and don't install the dell updated driver that the flow control can severely affect performance so unless your sure of your builds switch it off. It seems on our networok that if you set them to auto it has problems and can drop out with large files on the network auto negotiation seems to work well without the ip phones but not so good with them in.

When you plug the phone in for the first time ie new out of the box it will download a flash update let it do that trhen it will reboot then go into the phone settings and set it up if you don't it will set iutself up as default which is normally auto. good luck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.