System cannot start, no beep, no screen

Recently, I just changed the case for my system, however, after i changed the case, my system cannot startup.
Here is my problem.
When I turn on the power, the CPU fan starts up, the vga fan also starts, but there is no screen, no beep, after few seconds, the vga fan shuts down.
I tried to unplug all cards and re-install to it, no use; and I use another display card, no use.
I tried to re-install the ram, no use.
I tried to re-seat the cpu, no use.
I tried to change the power supply, no use.  
I also tried to remove the batteries on the MB for an hour, no use.
The only thing I haven't tried is to switch the CPU and motherboard.  Isn't that the problem of the CPU or motherboard?
york98Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gjohnson99Commented:
It sounds like you are missing the 12 volts for cpu -       normally a 4 pin plug
0
nobusCommented:
Usually, yes it is the mobo or cpu.
Does the whole system shutdown after 4 sec? or only the Video card fan?

If the system is started, and you hold the power switch for 8 sec, does it power off?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
But since you changed the case, i suggest to take out the motherboard, put it on a piece of plastic, or hardboard, and start it out of the case, as you may have grounded something; look for the screw positions and such
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SirJoshuaCommented:
If you are not even getting a POST, then it is usually one of five things.  RAM, Video Card, Power Supply, CPU, and/or MotherBoard.  If you have more than one stick of RAM, try each one by itself.  I would also try to test the CPU, and if that doesn't solve the problem, then you're most likely looking at a motherboard issue
0
ChokEy31Commented:
Lets hope you were wearing a ESD wriststrap when putting your PC together.  Not wearing one can cause a static discharge and ruin important hardware.  Also make sure you put in all of the motherboard screws in so the mobo will be grounded to the case like nobus said.
0
york98Author Commented:
My system is AMD Socket A, it only has one power supply plug.

Since there is no screen, the harddisk light didn't flash, I don't know whether the system is running or not, but the CPU fan do still running, and I can see from the Thermal Panel that the CPU temperature is switching between 29-30 degree.

Yes, when I hold the pwr switch for few secs, it do turned off.

0
gjohnson99Commented:
Dose your keyboard power on?
0
nobusCommented:
then you cpu shows some activity. i suspect the motherboard. did you try my suggestion to test it out of the case?
0
Chris BRetiredCommented:
<<AMD Socket A, it only has one power supply plug>> Yes, but is it a 24 pin or 20. If it is a 20, there is a square 4 pin socket on the board which must have power plugged in. If there is no plug, you have the wrong power supply.

Chris B
0
djsuperzCommented:
If the only thing you have done is change the case, then its a grounding issue.
0
york98Author Commented:
I finally change the MB, but it's not working again, then I changed the CPU, then it works this time.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.