iPaq 5450 locked out

Model: HP iPaq h5450 using Windows CE 2002
Problem: Message saying "the fingerprint reader failed to turn on due to insufficient driver memory available. You must perform a normal reset to use the fingerprint reader"
I do a normal reset and get the same message.
I do a hard reset, get to the 'align screen', then get the message again.
I take the battery out, leave it out overnight, and get the same result as a hard reset.

The hard reset is supposed to clear the memory, which it does (mostly), but it didn't eliminate the password/fingerprint requirement for me to log in. Since the fingerprint is my normal authentication method, and it doesn't work, I am locked out of the device.
When I try to access from activsync 3.7.1, I type the password that worked earlier and now it doesn't work.

I can't use HP support, since I'm out of warranty.

Let me know what you think or if you need more info.


LVL 9
SirtenKenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mikal613Commented:
http://www.hp.com/sbso/special/ppc_upgrade.html

Why not do the upgrade to 2003???

it will flash your device
0
SirtenKenAuthor Commented:
Thank you for your suggestion. I am looking for no-cost solutions. Can I somehow reflash the old OS?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

SirtenKenAuthor Commented:
I tried the method of hard resetting described in the article, but that didn't help. I found that I could get into the file system if I quickly selected the menu after the align screen routine. But.. I still have a window asking for the fingerprint and saying that the driver can't be loaded. Would deleting the bioswipe.dll have a positive effect on my condition? Or is there a registry key where I can set it to have no authentication method?

Thanks for your continued help
0
Mikal613Commented:
i would contact the fingerprint company and ask them please tell me the results
0
SirtenKenAuthor Commented:
You don't by chance know which company this is?
0
Mikal613Commented:
didnt you install it?
0
SirtenKenAuthor Commented:
Mikal613,
I installed the Ipaq and related software on my pc, but the fingerprint reader is integrated. Whoever supplies the thermal imaging device used as a fingerprint reader in the iPaq doesn't seem to advertise.

Surki1, thanks for the link, I'll get back to you once I check it out.

/Ken
0
SirtenKenAuthor Commented:
The result from trying the BIOS update:

"The Update Utility cannot get a response from your iPAQ Pocket PC. Please check the USB/serial cradle/cable that it is connected properly between the PC and your iPAQ Pocket PC.
 Perform a normal reset by pressing the reset button using the stylus and run this Update Utility again."

I ran the BIOS update utility, got the message, reset the iPaq and tried again, same error. I can browse the device from my pc, so there is no connection problem. The messsage "the fingerprint reader failed to turn on due to insufficient driver memory available. You must perform a normal reset to use the fingerprint reader" persists.

I don't suppose there is a way of flashing the BIOS that doesn't involve using the activesync link...

I am only able to get into the unit after a hard reset, align screen, then I have a fraction of a second to hit the Win/Start Menu before the driver/memory error message appears. I can't get into the password applet from control panel, because it wants a fingerprint to get in. I'd like to change those settings manually (registry), but don't know how yet.

I was able to check the registry and found two keys that might be relevant.
[HKEY_LOCAL_MACHINE\Drivers\FingerChip]
"Prefix"="FCA"
"Index"=dword:00000001
"Dll"="FingerChip.Dll"
"Order"=dword:00000000
"GPIO_RST"=dword:00000000
"GPIO_PCLK"=dword:00000001
"GPIO_TPE"=dword:000000ff
"CS"=dword:00000003
"BaseAddress"=dword:a8400000
"RefreshDataClkCnt"=dword:0000001f
"ThreadPriority"=dword:00000064

[HKEY_LOCAL_MACHINE\ControlPanel\Password]
"TimeOut"=hex:\
      00,00,00,00
"Group"=dword:00000000
"Redirect"="\\Windows\\BioSwipe.cpl"

Thanks for any additional help you can offer.
0
SirtenKenAuthor Commented:
0
SirtenKenAuthor Commented:
I deleted the registry entry "redirect"="\\windows\\bioswipe.cpl" and am no longer plauged by the "fingerprint reader failed to turn on" error. I have a request for further info from Atmel and want to thank the experts who posted for their assistance.
0
Mikal613Commented:
Thank you SirtenKen

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphones

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.