DHCP over wireless using WEP

I have a Netgear WGT624 wireless router, which is also acting as a DHCP server. It works fine with no security, but when I enable WEP (64-bit or 128-bit), my laptops can detect the network & get a good signal, but they're unable to get valid IP addresses (they get an auto 169.254... address). DHCP still works fine for wired users.

The laptops are Toshiba Tecra 8200s, with built-in wireless cards, and the latest driver update. The router has the latest firmware update. I've set this up and undone it and re-done it several times, but still can't get these laptops on the network via wireless. Browsing the net, this looks like a fairly common problem...but I haven't found the solution anywhere. Please help! Thanks.
LVL 4
slovisaAsked:
Who is Participating?
 
edkim80Connect With a Mentor Commented:
I looked up the manual for the netgear 624 and you have the option to use a passphrase or manual (hex ).  Try using the manual 64bit wep and enter 10 hex numbers.  In your network key box in windows, enter the same 10 hex numbers.  You probably only need to use 1 key (index 1?)

let me know if this works...
0
 
khngCommented:
Made sure that the wireless client had already configured with the same WEP

if not since the signal is encrypted and the client don't know how to convert the encrypted signal into a way that can be understand by the client
0
 
MarakushCommented:
Slovisa,

I had the same issue with the Netgear router.

I changed the SSID, and it worked for a little while (About 2 weeks) then I changed the lease time for DHCP to 60 minutes, that worked for while (about 1 week) then the same issue started happening again.

I finally gave up and assigned DHCP to a 192.168.1.50 - 192.168.1.99 for the wired and used static IPs for the laptops.

I know its not the answer you wanted to hear... but that's what worked on my part.

Marakush
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
edkim80Commented:
I think khng is on the right track..

WEP keys are either going to be entered by ASCII or HEX... Make sure that on both ends you are entering the WEP key in a consistent format.  You could be entering ASCII  - xxxxxx on the client and HEX- xxxxxxx on the server which will allow you to associate, but not decrypt any packets.

Regards,
Ed
0
 
slovisaAuthor Commented:
Well, I'm not sure how to address that issue. On the router, I'm entering a 5-character passphrase to generate 4 keys. I can see those keys. On the laptops, I'm entering the same passphrase, but I can't see what is generated to compare. What should I do to verify that they're speaking the same language?

Thanks for your help!
0
 
slovisaAuthor Commented:
Well, in trying to enter a hex number in the laptop's configuration, it restricted me to using "5 printable characters." I don't know what that's about, but it led me to find a different configuration for the card in which I can enter the router's hex (or ASCII) keys. Now I'm up and running. Thanks so much for your help!
0
 
GabrielBarreraCommented:
I had the same problem with a linksys WRT54GC ....using hex in the laptop worked also
0
 
REFRUGCommented:
I think you will find that this mentioned in the documentation of the Linksys router.
0
All Courses

From novice to tech pro — start learning today.