Can ping loopback, won't pickup dhcp addr, hard address fails, works on other networks

Here's the odd situation:

Have a guest at a hotel I do IT for.  He's reporting that he can't get a dhcp address, and when we configure his card with a fixed address it fails to ping itself, though it can ping loopback OK.  He says he was using the wired card in his office, yesterday, and he was on wireless down the street at Starbucks earlier today.  

Nobody else in the hotel has problems with dhcp, so it's not the switch or other infrastructure.  

My guess is his network card has gone south.  Any other ideas?
LVL 1
itgbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetworkArchitekCommented:
Hi itgb,
Well, without knowing the Operating System ... if it is XP have you tried doing the winsock fix?

http://www.spychecker.com/program/winsockxpfix.html

Do you get link lights?

Cheers!
0
itgbAuthor Commented:
Sorry, it's WinXP, sp 1.

It does get link lights, and we've tried different cables and different wall ports.  

Haven't tried the winsock fix, will try that.  
0
huntersvcsCommented:
It could be your card - could be your cable - could be the RJ45 connector.  Set manually an IP in the same subnet as the DHCP Server, reboot, and then try to ping it.

Got any firewalls operating?  Try shutting them down before you ping!

Are there enough free IP's available on the Server?  Check it out!  You may already be logged on once, and settings prevent a secondary logon.

Hope this helps.
Rick
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Cyber-DudeCommented:
If you get a loopback reply; it could be another device answering the loopback. If you configure it to use fixed address and ping it from your own machine, it may be well a few of the followings;
a. Drivers.
b. A Windows 'disabled' NIC (they tend to be disabled if you unplug a network cable while the device is on.
c. Malfunction NIC.

Try to check if the NIC is disabled via OS (i.e. Right-Click 'My Network Places' => Choose 'Properties' and verify the NIC's status (Or if it is available at all)). Also, try to see the 'Event Viewer' (System) for any errors...

Hope that helped

Cyber
0
holger12345Commented:
Failing to ping itself is something worth to remember... what can be the reason for that?
- no or false connection to the switch/hub... mostly the network will be marked as unreachable or unplugged.
   suggestion: use other switch port | use other cable (you did it) | use other cable type (crossed vs. standard) | use other NIC (defect)
   not suggested: don't reinstall TCP/IP, as your ping to the loopback works - test of the TCP/IP protocol
- autodetect of full duplex / half duplex setting doesn't work proper or doesn't work for that NIC
   suggestion: just try any setting but no autodetect - perhaps think of 10/100MBit autodetection too

if nothing works just reinstall a new version of the driver software (perhaps try this FIRST) - it's very annoying to see that everything works in the newest release (I've done that sometimes !)

good luck
Holger
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itgbAuthor Commented:
Thanks for the suggestions, guys.  When the guest returns tonight, we'll work on these.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.