Runs fine on local web server, but not on development web server

Tonight I was taking my website down inorder to migrate some database changes.  But when I went to put the website backup, I have found empty datagrids and other problems within the site.  I thought that something must have changed in the code, but when I run it from my local server, everything runs fine.  The data is pulled from the database fine, which populates the datagrids.  There appears to be no problems.  But when I move the files to development....all of a sudden there are problems.  I even tried to move other backups to the development server, and still I get problems.
Please help.
shorrigaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RazixCommented:
Check your Database connection string. This is sometimes stored in the root web.config file.  Your local database connection string will usually vary from your live database string.
0
shorrigaAuthor Commented:
I don't think this is the problem as the website is still partially functioning in development.  For example, searches against the database run fine.  But then when I click on the links it brings back I get this error:

OracleParameter object is already contained in a collection

Again, everything works when I am running it from my local server, but not on the development despite pointing at the same data.  The only code change a made between the two migrations was uncommenting a response.redirect command that points them to a "Site Down" warning page and then commenting this line out when I was finished with the database changes.

I just checked to see if everything works on the website in production by getting around the warning page, and it does.  Is there anyway this could be a server problem?
0
RazixCommented:
yes it could, hard to diagnose with limited information / access..

try rebooting the development server .

does anyone else use/access the development server? someone else may have changed something..

did you correctly move all the code to the development server? If you just put the bin file and not didnt put any modified aspx pages that could cause problems.

based on what you are saying, the database server is fine and your code is fine. so it does look like a web server issue.. reboot.. to get rid of cache etc..

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fahimnxbCommented:
Dear shorriga,

The best way to figure the problem out is to use remote debugging/ trace switches.

Regards,
me
0
shorrigaAuthor Commented:
There was an upgrade made to the development server, which disallowed global declarations of OracleParameters for use in multiple stored procedures.  Now I have to specifically, declare the parameters each time I run a stored procedure.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.