[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 624
  • Last Modified:

Domain Controller NIC properties inaccessible

I have a domain controller that is running Win2K. Somehow, someone entered in the DC's own IP address as the primary DNS server. Whne I try and go in and fix this mistake the Properties Dialog box for the adapter in question, pops up on the screen but shows no data (all fields are blank or greyed out). Within thirty seconds of being displayed it dispappears as well as the whole desktop gets cleaned off except the background color then the Desktop reloads in it's default state but no properties box for the NIC.

I have tried this logged in as Administrator which has full Domain wide rights. I have alos tried correcting this in Safe mode. All with the same outcome. I also tried setting upo the secondary NIC with the correct IP's only to have it show up and disappear just like NIC #1.

My domain is running correctly and all the other servers in the domain have the correct DNS entries so no issues their. It's just that I can't see the outside world with the DC. This is a real issues especially considering MS Updates and AV updates are not accessible at this moment. Please help!!!!!

Gendai
0
gendaiblade
Asked:
gendaiblade
  • 6
  • 4
  • 2
  • +2
1 Solution
 
WeHeCommented:
> someone entered in the DC's own IP address as the primary DNS server
thats correct and recommended by MS.
0
 
valiconCommented:
Is DNS set up on this DC? Are you using AD integrated DNS?
0
 
gendaibladeAuthor Commented:
We are using a source other than the DC to get our DNS info. My biggest concern is my inability to alter the data in the NIC Properties window and the fact that it closes down shortly after opening it. This may or may not have anything to to with the current Primary DNS entry.

Gendai
0
[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

 
valiconCommented:
If there is no DNS server on this machine then the DNS settings should not be pointing back to it, it should be pointing to the respective DNS server(s).  Can you set the NIC to get its IP and DNS dynamically?  This may free the NIC and let you enter the correct settings.
0
 
eleventy5Commented:
Sounds to me like something is corrupted. have you tried unistalling the nic and reinstalling it?
0
 
gendaibladeAuthor Commented:
Valicon: You are correct, that is why i was attempting to change it to the correct IP. The problem is I can access the NIC IP settings to change the respective DNS settings. All fields are blank (no data) and shortly after the NIC properties window is displayed (even with no data) it closes down with any intervention or input from me (mind of it's own).

Eleventy5: I suspect you are correct, I haven't removed it and re-installed as I was concerned with the repurcussions with respect to killing the primary DC. That is my next step though unless someone comes up with a silver bullet for this problem.

Gendai
0
 
WeHeCommented:
try to set the ipsettings with "netsh interface" and look, if nic properties are viewable again.
0
 
gendaibladeAuthor Commented:
WeHe,

I will give this a try this afternoon when I arrive back at the customers site. I will update all afterwards.
0
 
Wayne BarronCommented:
Go to your [Event Viewer]
Clear it out (Save it to file if you desire, for future refrences)
Then
Run the process again to create the problem. But going into the
Properties of your NIC.
After it has done its thing, and you have your Desktop back.

Go to the [Event Vewier]

And get all the [Errors] from [Application & System]

Post them here, so that we may be assist you.

Carrzkiss
0
 
gendaibladeAuthor Commented:
I tried to show the config for the ICs as well as set the DNS to a static IP and here is the output....

Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\Documents and Settings\Administrator>netsh interface ip show config

Error obtaining configuration for interface Local Area Connection 2.

Error obtaining configuration for interface {5EE65A77-03B8-4A64-827E-22D19ACF891
5}.

Error obtaining configuration for interface Local Area Connection.

C:\Documents and Settings\Administrator>netsh interface ip set dns "Local Area C
onnection" static 64.169.140.6

Error obtaining configuration for interface Local Area Connection.

C:\Documents and Settings\Administrator>



When I cleard out the event log and opened up the NIC properties sheet, this is the event that was generated.

Event=1102

Description: The shell stopped unexpectedly and Explorer.exe was restarted.

At this point I will be deleting the interface and re-installing it to see if that correct the problem.

Any of the brilliant types (obviously not me) have a suggestion?

Gendai
0
 
Wayne BarronCommented:
(Sorry for my bad grammer in last post, was tired.
And yse English is my Language, I have no excuse... Right?)

This could be a TCP/IP Issue.

Either After Or Before you have "Uninstalled and Reinstalled" the drivers
For the Card,
You might want to "Uninstall TCP/IP" and Reboot.
Then "Reinstall TCP/IP"
Then Install your NIC.

That sounds a lot like a problem that I had on my NT4 Server back years ago.
And once I did the above information, everything worked great.

Carrzkiss
0
 
gendaibladeAuthor Commented:
Carrzkiss,

I was reading an article (Article ID : 242430)and (Article ID : 239924) in the knowledge base at Technet and I think you might be on to something.

As for your grammar, I have the same problem. Except I am not proud and will blame it on a tiny Dell keyboard...hehehehe.

As I am leaving for Dallas on Sunday I will have to see if my partner can try this fix. I will keep you all updated. Thanks for the suggestions so far.
0
 
Wayne BarronCommented:
Dallas Cowboys ;-)

  Have a fun trip.

( Yes I am a Cowboys fan, through and through :-)  )

Carrzkiss
0
 
gendaibladeAuthor Commented:
Hmmm..won't say mine under oath but they are currently 1 - 8 uggghhh.

I did do some experimenting today besides what I posted earlier. The box (Dell PE 2600) in question can't see the outside world (Internet) but I could ping inside resources (Intranet). The worst part is that I can't pinpoint when this problem occured other than the last date I ran liveupdate for my Norton  AV Enterprise.

Gendai
0
 
Wayne BarronCommented:
Liveupdate from Norton.
That took out 2 of my computers back 4 yrs ago.
Well actually mine and my mothers. We was talking on the phone and I got her
To do the Liveupdate with me, so she could learn how it is done.
And the next day my computer started acting up, then my mother called me
And her computer was doing some freaky mess.

To make a long story short.
It took 3 days to get my computer fixed. and I ended up having to
Totally redo my mother’s computer.
Even though both are Win2k machines (The only OP I Trust and Love)
It affected hers worse then it did mine.

Sometimes Liveupdate has a little thing in it that takes out a system.
But.. I ran Liveupdate last Wednesday and this Wednesday and everything is fine here.
I received the same as what you have.
Symantec updates the Liveupdate on Wednesday's, but you can do the Web Download
Nearly Everyday.

So cannot say that it was a bad Update on Norton that caused the problem or not.
It does strang things to different computers.

You could try uninstall Norton and reinstalling it again.
But, if something had happened with the Liveupdate, then the damage is done.
And uninstalling and reinstalling will not fix it, unfortunantly.
So mark through the Uninstalling/reinstalling of Norton.

Carrzkiss
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now