Can not reach http://localhost

I have a system running Win XP Pro. I have IIS installed and running.

Through the bowser I can not reach http://localhost or http://127.0.0.1

What do I have missing?

TIA
moose25Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DrWarezzCommented:
It would seem that you haven't started/configured the server properly.. as if you had, you would be able to load it.. assuming that a firewall isn't blocking it.. Disable any firewalls and try again.. if still no luck, try reinstalling it perhaps, and reconfigure.. ?

gL,
[r.D]
0
jonnyz0109Commented:
Make sure the IIS service is running.  Start > Run > services.msc will show you all of the services, and whether they are running.
0
moose25Author Commented:
Checked it and it is up and running.
Stopped it and started it up again.
Still no access to localhost

Any other suggestions ?
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Joseph OLoughlinIT Support SpecialistCommented:
If you have not got TCP/IP installed nor bound to an network adapter, install it.  If you have no nic, add a LoopBack adapter, listed under Manufacturer Microsoft.  
0
jonnyz0109Commented:
assuming you have access to outside network / internet?
0
moose25Author Commented:
Yes. I have outside and inside network. I can see that box from other and viceversa. I have perfect access to the internet.

Suggestions ?
0
Joseph OLoughlinIT Support SpecialistCommented:
Add localhost and 127.0.0.1 to your proxy exclusion list.
0
jonnyz0109Commented:
I'd like to bring up again what DrWarezz said in the first post... make sure you don't have any firewalls blocking the port.  If you can't get out your nic  and directly back to it, something must be blocking it... either that or there is nothing to answer the request.  But you said the service is running... so I would be 200% sure you don't have a firewall or something blocking the port.

Http port is 80, btw.
0
jonnyz0109Commented:
and I guess make sure IIS is running on port 80... I dont see why it wouldnt be, but the port CAN be changed...
0
matthew1471Commented:
try this for me

Start-> Run -> "cmd"

then in the command box type "telnet localhost 80" if you get "Connection Refused" or whatever then tell me.. Otherwise if you have an empty screen with a flashing cursor type "Something <Enter> something <enter> something <enter>" or anything after a while it should say "Invalid Request" or return some other message :)

Have you modified the IIS page? If your using scripting then it could be that Norton Antivius (or any other Antivirus offering "Script Blocking") is blocking your page without telling you
0
moose25Author Commented:
Mathew;

After typing telnet localhost 80 I get something like (translated from Spanish):
"Connecting to localhost... Can't open a conction with host at port 80. Couldn't establish a connection because the teh remote machine has actively denied such connection".

As far as I know (which is not much) I have not modified the IIS page. How can I do that?

 I am using Avast professional as an antivirus and I have disbled block scripting but I still get the same error

How can I make sure that IIS is running on port 80?

I don't use a proxxy

How can I make sure that something is blocking port 80?

Regards

0
matthew1471Commented:
Right the service is definitly not running or beiing called on port 80, Do you have a firewall running on the computer? Open up "Internet Information Services (IIS) Manager" and right click your "Default Site" or whatever the name of the site is next to a world icon.. Goto "Properties" and under "Web Site" under the section "Web site identification.. make sure "IP Address" is set to "(All unassigned)" and that the TCP Port is "80"... Another idea is to try setting the "IP Address" to your LANs' address and trying http://LANSADDRESS/ again
0
Joseph OLoughlinIT Support SpecialistCommented:
Can you ping 127.0.0.1?
0
moose25Author Commented:
Yes I can ping 127.0.0.1
0
Joseph OLoughlinIT Support SpecialistCommented:
That tells us that TCP/IP is working.

Try from a command prompt
telnet 127.0.0.1 80
You'll get connection refused or a blank screen.  If the latter type (though you may see nothing on screen)
get something
You should get raw html of an error message back as a reply.
If so then your web server is running and accessable, we basically used telnet as an alternate browser, so its some browser setting.  
If telnet can't access the web server, is it set to respond on all IP Addresses or only one - is the web server running on port 80?   Is your firewall blocking access.
0
matthew1471Commented:
Atheist see above ^

"After typing telnet localhost 80 I get something like (translated from Spanish):
"Connecting to localhost... Can't open a conction with host at port 80. Couldn't establish a connection because the teh remote machine has actively denied such connection".

As far as I know (which is not much) I have not modified the IIS page. How can I do that?"
0
matthew1471Commented:
moose25 : did you try

"Right the service is definitly not running or beiing called on port 80, Do you have a firewall running on the computer? Open up "Internet Information Services (IIS) Manager" and right click your "Default Site" or whatever the name of the site is next to a world icon.. Goto "Properties" and under "Web Site" under the section "Web site identification.. make sure "IP Address" is set to "(All unassigned)" and that the TCP Port is "80"... Another idea is to try setting the "IP Address" to your LANs' address and trying http://LANSADDRESS/ again" ?
0
moose25Author Commented:
OK,

I have decided to reinstall IIS.
Now I get the following when trying to http://localhost or 127.0.0.1
"HTTP/1.1 404 Object not found" with firefox 1.0
"Page not found. HTTP 404 file not found" with IE 6.0.26

From all the suggestions given up to now I get/have the following:

-No firewalls running that I know of

-No proxxy

-Services.msc shows that IIS is running

-I have a network adapter working with TCP/IP. As a matter of fact is a laptop that can be attached to he network via an RJ45 connector or optionally with a wireless PCMCIA card

-Have access to the internal network and to Internet. (via an ADSL router attched to the network)

-Telnet localhost 80 gives me a black screen. Typing something a few times gives me nothing. Pressing the <enter> key a few times I get:
"HTTP/1.1 400 Bad request
Server: Microsoft-IIS/5.1
Date: Thu, 09 dec 2004 09:38:29 GMT
Content -Type: text/html
Content-length: 88
<html><head><title>Error</title></head><body>Parametr is not correct. </body></html>
Lost conncetion with the host"

-I have not modified the IIS (I don't know how to do it) and I don't know i I am using scripting. As an antivirus I am using Avast Professional 4.5 with blocking script ON (trying to find out how I turned it OFF before)

-Going to the IIS manager and under "Default site" I have : State =active, IP =*all unassigned * , Port = 80, State = .  If I left click the "+" on "web sites" and  then left click "Default web site" I get the error "The system can not find specified route" and the last column of "state" on the default web site changes from blank to "system can not find specified route"

-On the above changed the IP to the IP of the laptop. Then tried "http://LANSADDRESS" and with IE I get "Can show the page .....". Changed the IP back  to *all unassigned *

-I can ping 127.0.0.1

-I can ping localhost


Any ideas ?
0
jonnyz0109Commented:
<< "The system can not find specified route" and the last column of "state" on the default web site changes from blank to "system can not find specified route" >>

That would be a problem :)

By default things should be mapped to C:\inetpub\inetroot.  If you moved that, it could cause problems.  I'm not at a computer now that has IIS running so I can't validate the area that you're talking about, but take a look at that and I'll see if I can figure it out with my IIS when I get home.
0
matthew1471Commented:
Right that error is from IIS saying The object (page) cannot be found, perfect the service runs and by all accounts is live :)

Simply double click the website in IIS Manager and find out where on the hard-drive it's looing to find your site.. then in that folder create the textfile (page) "default.asp" and inside write "Yay" then try again :)

The default place it looks is C:\Inetpub\wwwroot\.. So in which case (again check IIS manager if it doesnt work) create your file and place it in there :)

Hope this helps, it seemes your problem was solved my reinstalling IIS :)
0
moose25Author Commented:
Double clicking on the websit in the IIS manage gives me the error "the system can not find the specified route" Right clicking on it and going to propertie there is a tab which syas (translated from Spanish) "Specific directories". In there all the checkboxes are unmarked except for "Register visits" and "Index this resource". All the other fiels are blank (empty) except for "Execution permits" which has "None".

What seems strange to me is that the three radio buttons at the top and "Route to local access" are greyed out and I can not change/modify options.

Shouldn't be something in that latter field?

How can I find whre it is looking for in my hard drive?

TIA
0
matthew1471Commented:
I think when your clicking on it what it's saying is "The System Can Not Find The Specified Path"? (Seen as a route might be the same as a path in spanish I imagine)

I know it's for a different version but look at : http://www.heikniemi.net/kirj/web/pic/iis1.gif

Your looking for the tab "Home Directory" and the box your looking for will have "Browse" next to it (i.e. you need to change the "Local Path") and it will be just above the checkboxes you mentioned, turn on "Directory Browsing" then create a folder on the computer and change the local path to it :)

THen visit the address again you should see a listing of the files you put in there
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joseph OLoughlinIT Support SpecialistCommented:
Our reasoning is that from the TELNET responces we can tell that the web server is working as a web server.  Did Matts advice help you solve the problem of the web server not being able to serve up content?
0
jonnyz0109Commented:
<<  I think when your clicking on it what it's saying is "The System Can Not Find The Specified Path"? (Seen as a route might be the same as a path in spanish I imagine)  >>

That's what it sounds like to me.

From an above post:
<< After typing telnet localhost 80 I get something like (translated from Spanish):
"Connecting to localhost... Can't open a conction with host at port 80. Couldn't establish a connection because the teh remote machine has actively denied such connection". >>

You guys would know better then I would - would this error come up with an error 404 in addition to the web server simply not running?  If so then I think this has something to do with the path.

Moose - I'm going out on a limb here, but we are all assuming you are running a *legal* copy of Windows XP Professional.  If you aren't, that would be a good reason for this not to work.  If it IS legal maybe try removing IIS (go to Control Panel > Add/Remove > Windows Setup button on the left) and reinstalling it.
0
matthew1471Commented:
There's no need to reinstall IIS as the author did that and now has it running fine :) The only problem he has is a configuration problem...

Simply setting the correct path to it will solve this :)

The Author has also told us that the service responds to a simple telnet request (albeit with us just sending garbage) and it also responds to web browser requests with a file not found error :)

The service is fine, we just need to set it up to look in the right folder
0
jonnyz0109Commented:
I guess I'm a few steps behind  :o)  
0
moose25Author Commented:
Ok folks. Problem solved

As matthew1471 mentioned it was a Path problem.

Changed that and it is working fine.

I have a similar problem with another machine.

I will try and solve it. If I am unable to solve it I will post a new thread in a couple of days.
0
matthew1471Commented:
Hey moose25, Glad to have solved your problem :)

Thank you very much for the points and have a great week
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.