Error connecting to remote SQL Server through Enterprise Manager

Trying to connect to remote SQL Server through Enterprise Manager.
Using IP Address and SQL Server Authentication
Have User setup on Server
Getting this error:

[DBNETLIB][ConnectionOpen(Connect().]SQL Server does not exist or access denied. Context: Error during initialization of the provider.

Getting this error when attempting ODBC Connection:
SQL State: '01000'
SQL Server Error: 10061
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionOpen (Connect)).
Connection Failed
SQLState: '08001'
SQL Server Error: 17

- database is SQL Server 2000
- OS is WinXP on client machine and WinXP on server
webdorkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

muzzy2003Commented:
Have you got a firewall between you and the server blocking the SQL Server port? Is the server set to respond on the default TCP/IP port number or has it been hardened? Try to ping the SQL Server, and then try to telnet to port 1433 on the SQL Server from the client machine - post the results, and I'm sure we can start to get you sorted out.
0
webdorkAuthor Commented:
How ping SQL Server?
How Telnet?
0
muzzy2003Commented:
Open a command prompt.

At the prompt, type:

ping xx.xx.xx.xx

See what it says. Then for the telnet, at the same command prompt type:

ping xx.xx.xx.xx 1433

In each case, replace xx.xx.xx.xx with your server's IP address.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

webdorkAuthor Commented:
ping xx.xx.xx.xx result:
Request timed out. packets sent 4, received 0, loss 4 (100%)

ping xx.xx.xx.xx 1433 result:
bad parameter
0
muzzy2003Commented:
Sorry, telnet should have read "telnet xx.xx.xx.xx 1433" - my mistake. But the first is the real indicator. Either there is a firewall between you and the SQL Server, or the IP address is wrong (are you sure it is correct?), or there is some sort of routing problem between the client and the server. Try the correct telnet command now anyway. Also, type "ipconfig /all", and tell me the IP addresses of your client machine, the server, and on the client machine, the subnet mask and default gateway.
0
webdorkAuthor Commented:
I don't think I can reveal that information...I'll revisit this tomorrow.
0
muzzy2003Commented:
Did you get any further with this one? Do you need any more help?
0
webdorkAuthor Commented:
yes I do but I'm instructed not to reveal the ip addresess.
0
muzzy2003Commented:
OK. Odd, but I won't argue the point. Did you try the telnet command after I had corrected my typo? Can you tell me the result of that?
0
webdorkAuthor Commented:
telnet xx.xx.xx.xx 1433

response:

Could not open connection to the host on port 1433

connection failed
0
muzzy2003Commented:
OK. The possibilities are:

1. There is no network route that your machine can work out to get to the SQL Server.
2. The SQL Server, or at least its SQL Server service, has not been started.
3. The SQL Server has been set up not to communicate via TCP/IP, or to do so over a non-standard TCP/IP port.
4. There is a firewall between your machine and the SQL Server preventing communiation over TCP/IP port 1433.

How much of an understanding of TCP/IP networking do you have? Are you able to rule out 1 by yourself? That's why I was asking for IP addresses and other information. Incidentally, if these begin with certain values like 10 or 192, they are purely internal values to your network, and posting them here really won't reveal anything to any attacker.

I would assume 2 isn't the problem, I only include it for completeness. If you are not responsible for maintaining the SQL Server, you would need to ask the DBA to check if 3 is the problem. The DBA may also be able to answer 4, but if not your network guys would be the ones to turn to.
0
webdorkAuthor Commented:
OK some progress...

The server SQL was set to port 1030 under the Client Network Utility. That has been changed to 1433 and I can now telnet to port 1433. I cannot ping as the server SQL is behind a router and pings are turned off.

I still am unable to connect through SQL EM...
0
muzzy2003Commented:
Try connecting using the machine's IP address rather than name. If this works, then you need to use the client network utility at your end to specify TCP/IP as the default connection method (or you could just leave it connected by IP address).
0
webdorkAuthor Commented:
I don't know another way to connect other than with the IP address.  I'm remote desktopped into the server EM right now and I don't see where to see or set the allowed users.
0
webdorkAuthor Commented:
I'm trying to test my connection through the Import data wizard
0
muzzy2003Commented:
First thing is you need to try to register the remote server in Enterprise Manager. Right click on Server Group (if memory serves me rightly) and cloose something like "Add new server registration ...". You might get a wizard, or a simple dialog, but they are both fairly easy to use. Enter the IP address of the server, and the username/password pair you have for the server. Let me know how this goes.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
webdorkAuthor Commented:
OK That did it.  Thanks muzzy2003 for putting up with possible paranoia. I've opend up another question:

http://www.experts-exchange.com/Databases/Microsoft_SQL_Server/Q_21223735.html
0
muzzy2003Commented:
I'd already answered your other question before I saw your last post on this one. ;) Glad we got there. Don't worry about the paranoia, it's the best way to be!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.