Printer redirection in terminal services

Ok here is my problem, every time I connect to one of my servers from terminal services it keeps installing the printers from my client machines on the server I connect to. I know when you using the Remote Desktop Client for Windows XP you can disable it with a check box. Unfortunately I have more than a few servers to mange so I use the remote desktop snap in for MMC. This allows me to switch through server with no difficulty. The problem is there is no option to disable printer redirection. So I figure there must be a group policy setting for it, so I check and find that there is a GP under \computer configuration\administrative templates\windows components\terminal services\client server data redirection\do not allow client printer redirection\ ENABLED.  Now I have set this policy over the client computer OU and the servers OU. I have rebooted the servers Windows 2000 and ran GPUPDATE on the client machine XP. I still get errors every time I connect to the servers.

Driver HP LaserJet 8150 PS required for printer __scanner_Systems is unknown. Contact the administrator to install the driver before you log in again.

I have tried for a week to figure this out. I guess its time to hand it over to you guys.
LVL 2
djohnson104Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

inlinemikeCommented:
I had the same error message with a Lexmark t630.  I worked off and on to eliminate the error but couldn't find a solution.  I ended up installing the t630 driver on my terminal server and the error went away.  

Here's a great resource for explaining the terminal services print functions.  It was written for 2003 but most of this applies.

http://www.brianmadden.com/content/content.asp?id=62
0
brownmattcCommented:
You can disable printer mapping on a server level.  This will disable ALL printer mapping though.

1. Start -> Run -> MMC
2. Add in the "Terminial Service Configuration" Snap In
3. Select the connections folder and on the right hand side you will see the different types of connections (probably RDP and mabey ICA).
4. Right click on your connection type (RDP is assumed) and click properties
5. Go to the "Client Settings" tab
6. In the bottom section "Disable the Following" Check "Windows Printer Mapping".

Now no printers will be created when you connect to the server.

Let me know,

Matt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
brownmattcCommented:
I belive that I have correctly specified the location to disable printer mapping.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.