Host file mapping does not work

Hi,

I am running Win XP Pro
I changed my hosts fle in C:\WINDOWS\system32\drivers\etc\hosts
to resolve some specific addresses instead of their default dns resolutions.

ip address1    www.xxxxx.com
ip address 2   www.yyyy.com

However when i type in www.xxxx.com in a browser i still go to default dns resolved name.
Something is overriding my entries in the hosts file.

Has anyone come across this problem. Can anyone outline steps for me to debug this problem




VlearnsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
Hi Vlearns,
try this
go to a prompt and type
ipconfig /flushdns
then try

Cheers!
0
stevenlewisCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VlearnsAuthor Commented:
ipconfig /flushdns  did not work
 
some other problem.

0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

stevenlewisCommented:
check my other link, have seen this once before, where the name resolution order got changed in the reg
0
VlearnsAuthor Commented:
that didnt work either :(
0
gjohnson99Commented:
Did you reboot ?
0
VlearnsAuthor Commented:
yes that didnt help

The problem was solved eventually.
The reason was that dns client had to be shut down
and the proxy had to be disabled at the same time.

0
VlearnsAuthor Commented:
run services.msc from run menu in windows
locate dns client , shut it down
uncheck IE->Tools->Internet Options->Connections->Lan settings->Use Proxy
restart dns
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.