Disable the session choose option on login screen of Fedora RC2

Hi is there anyway to disable the options in the login screen for changing the session type? I want to keep the options to reboot and shut down but not give the user the option to use a different session type ie Fail safe of kde. It should always login to GNOME

Im sure on either Suse or red hat 9 this was a simple thing to do but havent been able to find it on this version of Fedora . I can see how to disable the actions  ie shutdown, or restart from the login screen settings dialog, but can find nothing to do with the session type. I would not have thought this would be a difficult thing.

any ideas?
uuccuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Hi,

  Please edit /etc/X11/xdm/Xsession and comment out the selection in "case" condition.

Regards,

Wesly
0
uuccuAuthor Commented:
ahh ok so is that the entire double nested case statement at the bottom of the file?
I tried commenting out both case statements, but after a restart at login a message said that my session only lasted a couple of seconds and ended, then recommended i fix my xsession file. So i guess i edited out the wrong case statements, could u be a bit more specific on which bit to edit out?

Many thanks
0
wesly_chenCommented:
Oops, the case in /etc/X11/adm/Xsession is for ssh-agent.

Edit /etc/X11/xinit/Xclients as the follow:
------
PREFERRED=gnome-session
#if [ -f /etc/sysconfig/desktop ]; then
#    . /etc/sysconfig/desktop
#    if [ "$DESKTOP" = "GNOME" ]; then
#        PREFERRED=gnome-session
#    elif [ "$DESKTOP" = "KDE" ]; then
#        PREFERRED=startkde
#    elif [ "$DESKTOP" = "WINDOWMAKER" ]; then
#        PREFERRED=wmaker
#    fi
#fi
------
Then the only choose is GNOME.

Wesly
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

wesly_chenCommented:
Besides, you can rename the following files:
/usr/share/apps/switchdesk/Xclients.enlightenment --> _Xclients.enlightenment
/usr/share/apps/switchdesk/Xclients.fvwm -->  _Xclients.fvwm
/usr/share/apps/switchdesk/Xclients.kde  -->  _Xclients.kde  
/usr/share/apps/switchdesk/Xclients.toplevel   -->  _Xclients.toplevel  
/usr/share/apps/switchdesk/Xclients.twm  -->  _Xclients.twm  
/usr/share/apps/switchdesk/Xclients.wmaker  -->  _Xclients.wmaker

Then the user cannot switchdesk after they login.

Wesly

 
0
dufdufCommented:
If you want allow only Gnome, I presume that you use GDM. In /etc/gdm/gdm.conf you can find following variables:

SessionDesktopDir=/etc/X11/sessions/:/etc/dm/Sessions/:/usr/share/gdm/BuiltInSessions/:/usr/share/xsessions/
ShowGnomeFailsafeSession=true
ShowXtermFailsafeSession=true

Set latter two to false. Then check the directories listed in the first one and remove the entries you don't want to show. Restart gdm.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
uuccuAuthor Commented:
hhmmm strange I set both variables to false as you said but it only got rid of the Failsafe option, the gnome and default system session is still there. I should have said this is for a kiosk machine and i want it to go to the default system session (which is starts up a browser when the kiosk user logs in, this is set to automatically happen) but the user can press contol alt and back space to go back to the login screen. Its password protected anyway but I would like to restrict the ways a user can mess around with the system.

Ahh well, doesnt really matter im afraid nether of the suggested options appear to have worked... Any other ideas
0
dufdufCommented:
What is your default session? If it's Gnome, I'd say you're done. If it's not, make it so. In gdm.conf:

# This is the default .desktop session.  One of the ones in SessionDesktopDir
#DefaultSession=default.desktop

Here's my setup, which actually reaped out all other entries from the session menu. It worked, to some extent. I could log into gnome session, but for some reason gdm thought that this is fail safe session. It was normal gnome session, though. The only option I had in the session menu was default session.

#SessionDesktopDir=/etc/X11/sessions/:/etc/dm/Sessions/:/usr/share/gdm/BuiltInSessions/:/usr/share/xsessions/
SessionDesktopDir=/usr/share/gdm/BuiltInSessions/
# This is the default .desktop session.  One of the ones in SessionDesktopDir
#DefaultSession=default.desktop
DefaultSession=gnome.desktop
ShowGnomeFailsafeSession=false
ShowXtermFailsafeSession=false
ShowLastSession=false
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.