reseting TCPIP on a Windos XP pro

i have a small network of about 30 computers all of which are running windows xp pro (service pack 1 installed).

so far this happend on two computers... although both computers can connect to my novell server (sees all network drives) it loses connection to the internet.

i run ipconfig and all i see is "autoconfiguration ip address", and the IP is not part of my block?

i tried renewing and it doesn't work and i also ran the netsh command - netsh int ip reset resetlog.txt... and still doesn't work.

all cables and network ports are fine because i tried another computer and it works.

any feedback is greatly appreciated!
lsmtechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
0
Daniel Van Der WerkenIndependent ConsultantCommented:
Did you do release and renew or just renew?

Try:

ipconfig /release

and then

ipconfig /renew

0
RDAdamsCommented:
sometimes you need to do IPCONFIG /RELEASE then restart your computer.  Are they all connected to one switch or through a router?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

miloudiCommented:

It seems like u have been hit by a adaware.
you need to delte your sockets 1  and 2.
and reinstall the TCP/IP stack.
Deleting the sockets can be from:
regedit
local machine
system
current control set
services
winsock
winsock2(make sure to delete onlt these two)
after that
goto your folder options and show hidden files or even if u have to protected file systems.
right click on network places
properties
right click on local area connection
click install
protocol
you can either type nettcpip.inf or look forit in windows inf folder...
once found, click OK and restart the machine.
Hope this helps
 

0
abu_deepCommented:
or Try running this Winsock Repair on both computers :
http://www.spychecker.com/program/winsockxpfix.html

another winsock repair steps :


Use this piece of software to reset your TCP and winsock settings.
http://ntcanuck.com/Beta/useful_programs/WinsockFix.exe

You can determine if you have a winsock problem by doing the following.

Put in the windows XP CD and navigate to the support >Tools folder.
Double click setup and select full install.
Click Start >run >cmd {enter}
Type       netdiag /test:winsock /v    {enter}

To reset the winsock registry entries

Click Start >Run >regedit {enter}
Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock and delete it
Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2 and delete it
Exit Regedit and reboot.

To install TCP/IP over itself (to do this you need a copy of nettcpip.inf  there IS one on the Windows XP CD and MAY be one on your hard drive)

Right click "My Network Places" select Properties.
Right click the connection and select Properties.
Click Install >Protocol >add >have disk
Browse to the location of nettcpip.inf  (see above)
Select TCP/IP click OK
Reboot
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
abu_deepCommented:
Also check that IE is not using a proxy server address unless you actually have one.

I would also get the latest NIC drivers.
0
ib1netmonCommented:
It might be a lot simpler than that. Do the IP addresses start with 169.254? If so, then the machines are not getting IP addresses and eventually default to the zero configuration addresses, randomly selected addresses that all start with that prefix.

If so, they are not getting IP addresses  - probably because your DHCP server is down or unreachable from those workstations. Go find it & reconnect or fix or whatever.


0
lsmtechAuthor Commented:
after trying to renew and release TCPIP the next thing i tried was running Winsockfix util and resolved my problem.  Thanks for all the comments... asi mentioned this was the secondtime this happened to me and i anticipate that it will happen again.

if the utility doesn't work the next time it happens i will surely try the other comments that were given... thanks.
0
stevenlewisCommented:
Hmmmm, I posted the winsock fix first???
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.