IIS6 logging to an other Server in a Workgroup?

In our new Webfarm that Im working on we currently have the following.

1 Windows 2003 Standard Server setup with a share called Weblogs

3x Windows 2003 Web Servers in a NLB cluster.

What I want to be able to do is dump the logs onto the log server but with the servrs not being in a domain im having problems with accessing the share on the log server.

Originally I created an account on all 4 servers that was identical and gave that full access to the share on the log server, then on the servers I added a startup script in gpedit to launch the following batch file at startup.

@echo off
net use \\server_name\share_name /USER:Test test /PERSISTENT:YES
exit


This does not work though, so how else could I do this? Could I run IIS Service using this account that is identical on all the servers and the log server so that it will have access? or is it not recommended to change the account the IIS service run's with?

Any idea's would be greating appreciated.

King regards.

Darren Bolton
Systems Administrator
DarrenBoltonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

belatucadCommented:
alternatively you could give the account IIS runs with access to the share ;\

you could just schedule a job to copy the files over nightly or something also, and run it as whatever user you want, without modifying IIS at all
0
DarrenBoltonAuthor Commented:
Disk space is an issue thats why im wanting the log to another server, i won't be able to grant the account that IIS is running under because the servers arn't in a domain
0
dmoxCommented:
IIS can't log to anything but it's local hard drive.  

http://www.microsoft.com/resources/documentation/WindowsServ/2003/standard/proddocs/en-us/Default.asp?url=/resources/documentation/windowsserv/2003/standard/proddocs/en-us/log_savinglogfiles.asp?sd=gn&ln=en-ca&gssnb=1

Explains very briefly that you can't, but there is a doc out there that explains fully why I just can't find it at the moment.

We ran into this issue and we are currently hosting 8 Web Servers.  To work around this we've scheduled a batch file to copy the logs once a week to a network share then delete the logs out of the directory.  You lose approx 1 minute tops of log file information, but it's the cleanest way of doing it.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

belatucadCommented:
Darren - as dmox and I said, schedule a copy(move) of the log files nightly(or as often as you want)

0
Dave_DietzCommented:
With IIS 6 this is very easy to do.

(IIS 5 doesn't support remote logging, IIS 6 does....)

On the target machine you will need to create a Null share:

Create a new share, for example, public.

Make sure Everyone has Full Control in the NTFS permissions for the target directory.

From the Start menu, click Run.

In the Open box, type Regedit.exe, and click OK.

Navigate to and double-click the following key in the registry:
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\NullSessionShares.
   Note that NullSessionShares is a REG_MULTI_SZ value.

On a new line in the NullSessionShares key, type the name of the share that you want to access with a null session, for example, public.

Navigate to and click the following key in the registry:
   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA.

From the Edit menu, point to Add, click DWORD Value and then add the following registry value:
   Name: RestrictAnonymous
   Type: REG_DWORD
   Data: 0

Quit Registry Editor.

Restart the server.

Finally, point the logging directory for the site to the new Nul session share via UNC path.

You should be set to go.....

Dave Dietz
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DarrenBoltonAuthor Commented:
I've tried the method that you have given me and it does not appear to work, when I try and connect to the share I get "Bad username or password"
0
DarrenBoltonAuthor Commented:
Finally got it working!

Had to enable the "Let Everyone Permissions apply to anonymous users" for it to work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.