Ubuntu Linux with fglrx: unable to change screen resolution

Hi all. I'm a Linux newbie (winxp convert) and need some help setting up my video card drivers on Ubuntu Linux.

First of all, here is my core system setup:
Motherboard: MSI K7N2 Delta
Video Card: ATI Radeon X800 Pro (256 MB RAM).
Monitor: Sony HMD-A440 19"
Processor: AMD Athlon 2500+
RAM: 1GB dual-mode DDR

I used the Synaptic Package Manager to download and install fglrx and fglrx-control. fglrx is the free ATI driver, and fglrx-control is the control panel for it (which I have still been unable to find).

After I installed it, I rebooted and ran fglrxconfig, the configuration utility which rewrites XF86Config-4, the X-Server configuration file. This is the XF86Config-4 file it generated.

# XF86Config-4 (XFree86 X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
      FontPath      "unix/:7100"                  # local font server
      # if the local font server has problems, we can fall back on these
      FontPath      "/usr/lib/X11/fonts/misc"
      FontPath      "/usr/lib/X11/fonts/cyrillic"
      FontPath      "/usr/lib/X11/fonts/100dpi/:unscaled"
      FontPath      "/usr/lib/X11/fonts/75dpi/:unscaled"
      FontPath      "/usr/lib/X11/fonts/Type1"
      FontPath      "/usr/lib/X11/fonts/CID"
      FontPath      "/usr/lib/X11/fonts/Speedo"
      FontPath      "/usr/lib/X11/fonts/100dpi"
      FontPath      "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
      FontPath      "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
      FontPath      "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

Section "Module"
      Load      "GLcore"
      Load      "bitmap"
      Load      "dbe"
      Load      "ddc"
      Load      "dri"
      Load      "extmod"
      Load      "freetype"
      Load      "glx"
      Load      "int10"
      Load      "record"
      Load      "speedo"
      Load      "type1"
      Load      "v4l"
      Load      "vbe"
      Load      "xtt"

Section "InputDevice"
      Identifier      "Generic Keyboard"
      Driver            "keyboard"
      Option            "CoreKeyboard"
      Option            "XkbRules"      "xfree86"
      Option            "XkbModel"      "pc104"
      Option            "XkbLayout"      "us"

Section "InputDevice"
      Identifier      "Configured Mouse"
      Driver            "mouse"
      Option            "CorePointer"
      Option            "Device"            "/dev/input/mice"
      Option            "Protocol"            "ImPS/2"
      Option            "Emulate3Buttons"      "true"
      Option            "ZAxisMapping"            "4 5"

Section "Device"
      Identifier      "ATI Technologies, Inc. Radeon X800 Pro (R420 JI)"
      Driver            "fglrx"
      BusID            "PCI:1:0:0"

Section "Monitor"
      Identifier      "Generic Monitor"
      HorizSync      30-75
      VertRefresh      50-85
      Option            "DPMS"

Section "Screen"
      Identifier      "Default Screen"
      Device            "ATI Technologies, Inc. Radeon X800 Pro (R420 JI)"
      Monitor            "Generic Monitor"
      DefaultDepth      24
      SubSection "Display"
            Depth            1
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
      SubSection "Display"
            Depth            4
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
      SubSection "Display"
            Depth            8
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
      SubSection "Display"
            Depth            15
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
      SubSection "Display"
            Depth            16
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
      SubSection "Display"
            Depth            24
            Modes            "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Section "ServerLayout"
      Identifier      "Default Layout"
      Screen            "Default Screen"
      InputDevice      "Generic Keyboard"
      InputDevice      "Configured Mouse"

Section "DRI"
      Mode      0666

I did notice in the log after running fglrxconfig a message stating that no supported video card was found, although I am running an X800. However, in the list provided at the start of fglrxconfig, the X800 is not listed. I am probably foolishly assuming that my card is supported when it's not.

So I restarted xserver using the command: sudo /etc/init.d/gdm restart

Everything came up fine, but I wanted to change my screen resolution and this is the error message I got:
--> The X Server does not support the XRandR extension.  Runtime resolution changes to the display size are not available.

Anyone see anything, maybe in the XF86Config-4 file, that jumps out at you?

I haven't even TRIED playing a game with this yet :) I also tried the official ATI drivers but I'm still a linux noob, so converting the package to .deb and all that didn't seem to work for me at all... long story short I couldn't get it installed and the package manager was much easier.

Thanx in advance for your help.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Can you do an lsmod so we can see what dirvers are running?
SuperMarioAuthor Commented:
lsmod doesn't show ati or fglrx, it still shows the default linux graphics driver.

Also it's not a PCI card, it is AGP.
SuperMarioAuthor Commented:
Okay I reinstalled linux but now I have the same problem (XRandR extension not supported, runtime changes to resolution not permitted)

Here is lsmod.

Module                  Size  Used by
fglrx                 207876  7
proc_intf               3968  0
freq_table              4356  0
cpufreq_userspace       5336  0
cpufreq_powersave       2048  0
button                  6936  0
ac                      5132  0
battery                 9740  0
ipv6                  230020  8
af_packet              20872  2
ndiswrapper            99728  0
via_rhine              19848  0
mii                     4864  1 via_rhine
crc32                   4608  1 via_rhine
snd_via82xx            26660  2
snd_mpu401_uart         7296  1 snd_via82xx
tsdev                   7168  0
ehci_hcd               27780  0
usbhid                 28864  0
usblp                  12032  0
uhci_hcd               29328  0
usbcore               104292  7 ndiswrapper,ehci_hcd,usbhid,usblp,uhci_hcd
sata_via                7428  0
libata                 36356  1 sata_via
ohci1394               32004  0
ieee1394              100536  1 ohci1394
emu10k1_gp              3840  0
gameport                4736  2 snd_via82xx,emu10k1_gp
snd_emu10k1            80776  4
snd_rawmidi            23232  2 snd_mpu401_uart,snd_emu10k1
snd_pcm_oss            48168  1
snd_mixer_oss          16640  4 snd_pcm_oss
snd_pcm                85540  3 snd_via82xx,snd_emu10k1,snd_pcm_oss
snd_timer              23172  1 snd_pcm
snd_seq_device          7944  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         59268  2 snd_via82xx,snd_emu10k1
snd_page_alloc         11144  3 snd_via82xx,snd_emu10k1,snd_pcm
snd_util_mem            4608  1 snd_emu10k1
snd_hwdep               9120  1 snd_emu10k1
snd                    50660  16 snd_via82xx,snd_mpu401_uart,snd_emu10k1,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore               9824  5 snd
shpchp                 87276  0
pciehp                 83948  0
pci_hotplug            30640  2 shpchp,pciehp
via_agp                 8832  1
agpgart                31784  2 via_agp
floppy                 54996  0
pcspkr                  3816  0
rtc                    12216  0
md                     44744  0
dm_mod                 51068  1
capability              4872  0
commoncap               7168  1 capability
parport_pc             32064  1
lp                     10436  0
evdev                   9088  0
parport                37320  2 parport_pc,lp
ide_cd                 38276  0
cdrom                  35872  1 ide_cd
mousedev               10124  1
psmouse                17800  0
sd_mod                 20480  0
scsi_mod              115148  2 libata,sd_mod
ext3                  109544  1
jbd                    54552  1 ext3
ide_generic             1664  0
via82cxxx              13084  1
ide_disk               16768  4
ide_core              125272  4 ide_cd,ide_generic,via82cxxx,ide_disk
unix                   25904  680
fan                     4236  0
thermal                13200  0
processor              17712  1 thermal
font                    8576  0
vesafb                  6688  0
cfbcopyarea             3968  1 vesafb
cfbimgblt               3200  1 vesafb
cfbfillrect             3712  1 vesafb
try adding this source to
your /etc/apt/sources.list:
deb http://people.ubuntu.com/~daniels/ l-r-m/$(ARCH)/

and following the instructions in

"   1.

      sudo apt-get install linux-686 if you haven't already.

            or -k7 or -686-smp or -386... whatever matches your kernel.

      sudo apt-get install fglrx-driver

      echo fglrx | sudo tee -a /etc/modules

            This command won't have any effect until you reboot. To load the kernel module immediately, run sudo depmod -a ; sudo modprobe fglrx, but this will only work if you have already rebooted since upgrading the kernel. If it doesn't work, perform the next step (below) and then reboot.

      Edit /etc/X11/XF86Config-4 and change "ati" to "fglrx", perhaps with a command like:

            sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/XF86Config-4

Note (optional): If you are going to compile 3d applications, you will want to install the fglrx-driver-dev package

Note (optional): You might want to install the fglrx-control package, which provides a control panel to configure graphics card options such as dual-head display (two monitors). "
There is a relatively obscure fix for this on the Ubuntu Forums.

In your Xorg.conf, make sure this is included in the Modules section rather than "Load extmod"
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension

Let me know how it works out for you.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.