?
Solved

Cannot access OWA from an external site

Posted on 2004-11-18
12
Medium Priority
?
5,173 Views
Last Modified: 2008-01-09
I have a Windows 2003 server + ISA 2000 + Exchange 2003.
The problem is I followed the instructions to enable OWA. It is ok from our local network but from external it takes some time then displays the "Page cannot be displayed".
I ran thru a lot of help from this site and from Google groups but no way.
0
Comment
Question by:Ehab Salem
  • 7
  • 4
12 Comments
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613590
I already installed EX SP1 and ISA FP1 and ran the OWA wizard on ISA. I am using ssl
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12613631
what's the error? Are you using forms based auth? If so, is this a front end/back end configuration?

D
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613660
I am not using FBA. There is nothing coming, it waits for 15 seconds and displays: Page cannot be displayed ...." error
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12613693
then it's not coming into the network. You should get the login popup first. What link are you using from outside your networkl?

D
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613709
from inside my network and outside I am using

https://mail.domain.com/exchange

locally it is connecting and asking for username and password and then logs me on to my account. But externally it is not working
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613722
I tried now to use non secure connection and it worked from external connections.

I used http://mail.domain.com/exchange and it is ok from external
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 1000 total points
ID: 12613804
then 443 is not published on the firewall, at least not for owa....
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613817
I already run the Publish OWA server wizard on ISA, does that mean that port 443 is open?
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12613857
At the bottom of the error page is written:
Cannot find server or DNS Error
0
 
LVL 14

Author Comment

by:Ehab Salem
ID: 12614962
Thank you for your help.
OWA wizard did not open port 443 on the ISA server. I opened it and it works.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12616269
Sorry I wasn't around this morning, had to go to work :)
0
 

Expert Comment

by:tonygitau
ID: 15084467
Use IIS to enable external users to logon to your exchange server using OWA. Right click default website then grant access to anonymous.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question